[resolved] Activities are Blank Screens - Discovery Flights, Flight Training, etc

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Ever Since SU6, I’ve had a lot of issues. One was that XBOX Gaming Services tried to update as the Sim was launching post-SU6 update, and it corrupted something. Gaming Services was causing a stutter every 2 minutes in Sim, and in Event viewer the stutter coincided with an error message about the service being missing. I followed numerous Asobo, Microsoft and online guides trying to repair, redownload, fix Gaming Services but was unable. It would not let me do anything.

So, as a last ditch effort, I tried to do a system restore. It completed successfully.

It doesnt appear that Gaming Services is “fixed”, because it still shows as “0” kb installed, but at least it’s not causing errors now in Event Viewer. and Microsoft Store seems to work correctly now, too.

However, I noticed that the system restore completely messed up my MSFS2020 install. No planes were showing up in the Hangar, and I finally noticed that many files were missing from the install, including all of the .cfg files in all the sim folders. So, I bit the bullet and re-installed the entire sim. First, by uninstalling, then reinstalling and doing a Verify in Steam, and then letting it re-download all files.

Now, I have all my planes back in the hangar and I can launch world flights, but, all of my Activity “Flights” are missing;

- Discovery Flights
- Landing Challenges,
- Bush Trips
- Flight Training

All of the install content is in the “Official” folder, and it shows installed in Content Manager, but the screens are blank. There is nothing but liveries (which I dont want) showing “uninstalled”.

I’ve tried removing my Content.xml file, and FlightSimulator.cfg. Pretty much out of ideas. I’ve tried resetting Xbox app and Companion App, I tried logging out and in with both the Simulator and the Xbox apps, and made sure all my Windows and Windows store updates are current.

Since this is a new installation, what else can I try? What would be causing this?

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
PC specs and/or peripheral set up of relevant:
i7-10750 6-core CPU, 32 GB DDR4 ram, and Nvidia RTX 2060 GPU with 6bg of memory. Two 1TB M.2 NVMe SSDs.

GPU / CPU are factory default clock speeds. Have never enabled overclocking.
Build Version # when you first started experiencing this issue:

Its crazy to me this issue has never been seen before. No one has any clue how to fix it. MSFS Zendesk is silent, and no users have any ideas?

I’ve tried a complete re-installation, made sure windows and xbox are up to date, etc.

I guess all I can do is uninstall it and try again some day in the future.

1 Like

I also tried installing it on a different SSD in my computer, and had the same issue. So I suspect something is either corrupt with my Xbox profile or my computer OS is missing something.

System File Checker and the troubleshooters say that everything is fine - no errors.

1 Like

Per Asobo and Microsoft Support suggestion, I did an In-Place Upgrade of WIndows 10 (reinstallation) using the Media Creation Tool, and it completed successfully, but it did not solve this missing activity issue. I’m still not convinced that Gaming Services is functioning correctly. It shows 0 KB installed.

Does ANYONE have any ideas? It seems i’ve tried everything short of a clean wipe of Windows or litterally buying a new PC. Neither are options (since the only issue is MSFS2020, all other apps seem to run just fine).

I’m getting kind of desperate and feeling hopeless here.

I should add that the DISM Online Cleanup-Image tool, and System File Checker still report no issues.


I’m BACK up and running after downloading the latest update. Here’s what I did:

  • I let MS store update, and with it, update Gaming Services and other apps. Restart.
  • Removed Community folder, and entire AppData/Roaming/Microsoft Flight Simulator folder and launched the sim to rebuild it.
  • Did NOT delete sim and start fresh (I figured it would be faster to try it this way, expecting it not to work, but worth a shot anyway).
  • Let sim install all updates from today. Had VERY good download speeds (70-100mbps).
  • After loading, let sim install all updates in Content Manager. Had a problem with the NXG1000, but after restarting sim again, it downloaded successfully.

Tried Activities…and…they all work!! :slight_smile:

I DONT know what fixed it ultimately (frustrating not to know) but something in what I did tonight got it back. I suspect SU7 itself refreshed something.

I am encountering a similar issue. But, strangely enough I noticed there were literally thousands of screenshots from MSFS in my computers photos. So naturally I thought that my computer was doing this on its own. So I deleted them all. And now when I load the Sim up… I’m getting blank Greyed out tiles for most of the activities, and even the options menus. I re-installed the game. Seems to have gotten better… a bit. But I will try your method