Reverb G2 blurry and jerky image even at >60 fps

Hi everyone!

I am writting here because I run out of ideas. My issue is :
I went from a perfectly configured set up in vr , running super smooth and at no less than 30fps to one day , without opening the pc for a week , having a terrible blurry and laggy image in the sim to the point to make me feel motion sickness and sick.
I have tried lots of things :

  • recomended settings from videos on youtube
  • rollback my Nvidia drivers
  • rollback last windows updates
  • uninstalling and reinstalling WMR
  • removing all addons

And probably other things I might be missing now.
What I am so frustated about is that it was working just fine , I wasn´t ussing OpenXR at the time because It degraded just a bit my performance . No motion reprojection , and no DLSS , just TAA .
But now no matter what I try , nothing works , even at high FPS ( 50 , 60 or even 75…)

My pc specs are :

Ryzen 5600X
Nvidia 3080
32GB Ram
Dedicated 500GB SSD just for the sim.

Have you any ideas what could be possibly going wrong ?

Have you checked whether Holographic Shell is running?

Path is: performance monitor / data collector sets / event trace sessions
If Holographic Shell shows up running in that list, right click and select Stop.

I check this before each flight as it comes back sometimes for reasons I don’t understand :thinking:

Yes I did ,
As you say , sometimes comes back for me too , but after stopping it there is no chage whatsoever.

Have you tried locking at 45FPS? It doesn’t get smoother than that unless you go 90 (or whatever your HMDs refresh rate is). 45 is a lot smoother than even 55.

I have tried locking at 45 either from the OpenXR and from NVidia control panel . And even getting 45 fps in game with a headroom of over 10% looks really bad…
Before all this happened It was ultra smooth at 30fps , but now… Is ghosting and lagging like crazy… :cry:

Maybe try locking with Rivatuner, works really good for me.

I´ll give it a try.
However I don´t think is a fps locking problem since I can se ghosting even at the menu at 90 FPS when I move my head.
All other games work just fine…

Something might change in your system. Maybe there was a windows or driver update which messed things up? Btw I had that jerky image too after SU11 and fps locking with rivatuner was the only solution (locking in NVCP is not working anymore for me, it is stuttering).

I must say , it improved a tiny bit , but it is still no where near as before…
Thank for your ideas , I will keep trying more options

Also try enable rolling cache.

Rolling cache was enable , I reset it and gave it some more GBs but no luck
I did reinstall WMR drivers and nothing…
Reading on the web I found some people with ghosting problem in general and recomended disconect the headset´s PSU from power for sometime and let it cool ( mine has been conected since 3 months ) so I am going to give it a try and tomorrow will test further

Did you change your monitor refresh rate?
I’m asking because I changed my monitor recently and when I increased the refresh rate, I started having nasty framerate issues with MSFS.

No , refresh rate still the same for the monitor…
Today after dissconecting the headset psu and let it powered off for more than 15h I have noticed that ghosting has minimized , however it still jerky and lagging , againg having frames rates of over 45 or 60 when setting graphics to low…
I don´t understand why having these frames number is not able to smooth everething out as it was before…
I am starting to run out of ideas… :disappointed:

Sorry to hear. I have some more tips:

  1. Uninstall your GPU driver with Download Display Driver Uninstaller (DDU) and reinstall the latest.
  2. Run system integrity check (In the command prompt window, type SFC /scannow).
  3. In nvidia control panel set virtual reality pre rendered frames to 2.
  4. Check your task manager if there is any background tasks with high cpu usage.

If nothing helps, there may be a hardware issue. Maybe your CPU or GPU runs too hot and there is a thermal throttle. Check your temps with HW monitor while you fly.

This has gone donwhill fast…
Today I few for a while just try to forget about performance and enjoy a bit the blue skys , this was in the morning . In the evening upon booting up the pc I realized there was a Windows update and proceed to installed , afterwards I opened the sim just to come to a warning that said that it wasn´t able to open it refer to the Microsoft store to see more info. Which I did , and gess what? There was no info at all , I had my game in my library but it wouldn´t open no matter what I tried .
So I thought , last thing I changed was the windows update , lets uninstall it and roll back to the previous. Which I did also . But this didn´t work … I still got the same warning message , so I decided to perform a system recovery to the moment before installing that update . After this was done I still get the message and the sim won´t start… So for the moment I am going to leave it aside for a while untill I forget all this and I recover some strength to do a windows clean install and start all over again.
Thank you all who assisted with your coments .
I really appreciate it .