Reverb G2: CTD after switching back to VR mode (CTRL+TAB)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

CTD after repeated swapping between normal 2D view and VR mode during flight (eg, to take a normal screenshot). Flying with PMDG 737-700 YSSY-YMLT then YMES-YMLT

Provide Screenshot(s)/video(s) of the issue encountered:

NA

Detailed steps to reproduce the issue encountered:

  1. Start flight in 2D mode to configure FMC and start up the plane, switch over to VR mode for taxi
  2. Continue flight as normal, swap to 2D mode using CTRL+TAB to take a few screenshots, then CTRL+TAB back to VR mode
  3. Continue to do this a few times at random throughout the flight
    Result: FS locks up and crashes to desktop

PC specs and/or peripheral set up if relevant:

Mac Pro 2019 (Mac Pro 7,1)
BIOS: 1731.140.2.0.0 (iBridge: 19.16.16064.0.0,0) (type: UEFI)
Processor: Intel(R) Xeon(R) W-3245 CPU @ 3.20GHz (32 CPUs), ~3.2GHz
GPU: AMD Radeon Pro W6800X 32GB
Chip type: AMD FirePro SDI (0x73AB)
1TB NVME SSD (FS2020 and Win 11 only)
48GB DDR4 ECC 2933mhz ram
HP Reverb G2 and LG Ultrafine 5K 5120x2880 + Dell 4K screen 3840 x 2160
Apple Wireless Magic Keyboard with numeric keypad (silver/black)
Windows 11 Pro for Workstations 21H2
OpenXR toolkit disabled

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Fault bucket 1679385387353620609, type 5 (YSSY-YMLT)
Fault bucket 1737193690078999540, type 5 (YMES-YMLT)
Previous fault buckets:
Fault bucket 1993030694580311431, type 5
Fault bucket 1958867272847754922, type 5

Are you using DX12?

YES

Are you using DLSS?

NO


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Another CTD on the ground in Courchevel:

Fault bucket 1679385387353620609, type 5

Same as before, swapping between 2D mode and VR. Same machine as before, no other changes.

Tried a bunch of times, but I’m able to switch between VR/2D every time. Mod planes, default planes, etc.

What are your graphic settings? Does it need to switch between TAA/DLSS when switching for example?

Anti Aliasing: TAA.
Reprojection mode: Off
World Scale: 130
Render scaling 95 or 100
AMD FidelityFX Sharpening: 200
Global Rendering Quality Custom
TLOD: 100
Off screen terrain pre-caching: Low

On a thought, I watched the GPU temps to monitor them, it goes up 80ºC but that’s as far as it goes then it drops down a bit. It’s not at the limit for the card. It’s fairly similar to what I see from the old RX580.

This time uninstalled OpenXR toolkit to try and isolate that out.

Same result, DX11, if I switch to VR mode just once and stay there, things seem fine. As soon as I switch to 2D then switch back to VR, immediate CTD:

Fault bucket ID: Fault bucket 1679385387353620609, type 5

Faulting application name: FlightSimulator.exe, version: 1.27.13.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 1.27.13.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001cdf224
Faulting process ID: 0x1dac
Faulting application start time: 0x01d8ae3807cdf977
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.27.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.27.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report ID: 90882ab2-0f68-4356-9f00-ed9409d8e5e4
Faulting package full name: Microsoft.FlightSimulator_1.27.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

I did some more testing and reset the Open XR toolkit (the Microsoft one) along with Mixed Reality Portal.

I’ve swapped into DX12 mode in FS2020 and I managed to do some helicopter flying with some swapping to and from VR mode using CTRL+TAB (around Valdez airport).

I didn’t get any crashes to desktop this time. Also on the latest update that just downloaded.

I’m not going to say 100% the CTDs are gone, but this is promising.

edit 2: Another flight with FBW A320 and no crashes, fingers crossed.