Reverb G2 produces dim image

,

Recently I encounter the following problem with my Reverb G2: When switching to VR, I sometimes get a very dim image, as though brightness has been turned to 25% of normal. Even on a bright day I barely see details inside the cockpit.

When I switch from cockpit back to the WMR cliff house, brightness of the G2 is back to normal. Reverting to the sim: all dim again!

The only way to solve this is to exit MSFS and to restart my PC. It happens with various planes. And it does not happen always.

Anyone else has observed this? Any hints as to why the dimming happens once in a while, and how to avoid it?

Yep, happens to me too on the odd occasion. G2.

Hit escape from VR to enter the settings menu and then escape again to get back to your flight. That cures it for me every time.

2 Likes

I don’t know if you’ve tried the brightness control on the G2. If voice control is enabled you can just say “Brightness up” and the screen will brighten. I don’t know if that’s the exact fix your problem, though.

1 Like

You mean: ESC, General Settings?

Not sure about that. When I go to the Cliff House, brightness is correct. Back to FS and it’s all dim…

Is this control working only with Steam or also if you are only with WMR ? (I don’t have Steam). Is there another way to do it ?

I don’t use Steam. I’m only through WMR. You can enable Speech Recognition in WMR Settings.

Literally just hit escape key once when in VR and it’s dim, which takes you to a menu screen, then just hit escape again to go right back to the cockpit in VR. My G2 does this same thing every so often and the double escape key fixes it every time. Not sure the cause but the workaround seems to reset it.

…that sounds promising! Thanks! I will try this next time the problem occurs…

Don’t go to the cliff house. When it’s dark in msfs VR do the double-escape’eroo

hey guys i bn running the rift s for long time… wondering if the g2 is worth upgrading to???

I’ve experienced this today for the first time with the Quest 2 using Airlink and then with the wired link. I believe this has been reported by some in the past.

I’ve experienced this FS2020 bug:

  • in 2D open the options (ESC)
  • Switch to VR (CTRL+TAB)

The view displays the dimmed background of the options screen, without the options tiles. Switch back to 2D and toggle options, or stay in VR and toggle options, and this restores normal view.

2 Likes

I get it all the time too. Escape twice always works. Sometimes I hit the tilde key and open up all sorts of developer windows in one eye. Those are always quite jarring.

Hi all,

I am new to this MSFS2020 and this forum with the following specification:

CPU: i9-109800xe
Motherboard: Asrock X299E-ITX/AC
Memory: 32GB + 12GB
GPU: MSI Radeon RX 580 ARMOR 8G OC

I obtained my MSFS2020 copy not from Steam but from Xbox yearly subscription. I recently bought the Reverb G2 and installed Steam, Steam VR and Windows Mixed Realty on my computer for the Reverb B yesterday.

No doubt that my video card is not good enough for Reverb G2 and the resolution was not good with blur but I wouldn’t blame because it was RX580 8GB GPU.

The playing of Reverb G2 was playable but I encounter the following issues after I rebooted my computer:

  1. I run MSFS2020 and load to main screen, then I switch to VR by pressing “Ctrl” and “Tab” keys, then the screen switches to VR mode and Windows Mixed Realty will run automatically. However, I could not load / save file during in VR mode. The save / load window pops up but it stays in the background, I could not switch (alt + tab) to save save/load windows.

  2. So, I load saved game without in VR mode. Then, I click “Ready to Fly”. At this moment, I switch to VR but the MSFS2020 screen keeps flashing on and off and the screen of Windows Mixed Realty would keep flashing and glowing sound. I could not do anything and MSFS2020 would shut down automatically after 15 sec later. Then, Windows Mixed Realty screen ould return to main lobby.

I am planning to upgrade my video card to 1080ti. I know it is still not good enough for MSFS2020 + Reverb G2, however, it would better than my existing RX580 8GB tho. I wanted to upgrade to 3070 or 3080 but it is not easy to buy one of those at reasonable price nowadays. I am really frustrate after buying the Reverb G2 with the above issue.

Anyone would suggest me how to fix the issues? Or I should not bother to fix the issues until I upgrade my video card?

Thanks!

Tony

i dont know bout vr… ino this is g2 and im rift but dont feel bad… im having the same issue. yesterday morning it fired up perfect… hires and all… flew around sfo for an hr at least. shut it down… went back to vc… made a couple flights with the guys;; shut down for lunch… came back on for more vr and its all messed up… dark screens… flashing and freezing the sim completely… i have no idea why it breaks… spent the rest of the day trying to fix it…i just hungup the headset… rift working perfect in other sims… just this one acting up… just saying if its the sim itll probably effect all the vr headsets in some way. hopefully Asobo will clean up the bugs.

Hi all,

I upgraded my video card to Inno3D 2080 Super but still having the same issue. I really don’t know how to fix it.

Anyone able to resolve the problem? Is this problem just for Reverb G2 or also happens to Q2?

Tony

update guys on my problem… ino im rift and still looking at g2. im concerned if these problems r headset or sim issues. i just found my problem… i like using the ATC. in vc i undock it to external monitor. if i switch to vr with that it crashes the sim. be aware of your multimonitor setup…

Updated. I checked all my setting in MSFS2020 and found that the Data setting was set to OFF. So, I enabled Data to ON and some kind of out of date message and forced to log me out from Xbox. After I logged back my account and it detected an update for about not more than 200MB.

After the update, I tried to switch to VR mode when flying, WMR autostarted and now WMR windows without flashing screen and glowing sound…however, MSFS2020 turned to black screen. If I close WMR, MSFS2020 screen returns to normal. I think something wrong two days ago.

Tony