Reverb G2 random black screens

Hi guys,
today I encountered multiple black screens while flying in the TBM over Germany with The G2.
At the beginning the black screens are about 10-30sec before I can fly again, but after a while of flying the black screens get longer and at some point the black screen never go away and the sim crashes.

The Graka (RTX 3070) jumps from about 80% to 20% during the black screens in the G2 and jumps back to 80% when the sim goes on. This is really frustrating.

Flying with the latest GPU drivers/Windows-and Sim updates and OpenXR at 75% resolution and 100% ingame. With these settings I get good performance, when there is no black screen.

Does anybody else have the same problem? Is it a known issue, which can be solved easily?
I would really appriciate some help here.
Thanks in advance!
sfighter17

RTX 3070
R7 5800X
32Gb 3200Mhz Ram
MSI B550

I have a Radeon RX 5700 XT, with my Reverb G2. I do experience the random blackouts. It happens in the Welcome screen, as well as when flying. They are not often, thought, but still annoying.

Another thing I noticed is that the right eye’s LCD in the headset displays a series of small translucent triangles – if you look closer, you can “see-through” those small triangles. If you close your right eye, they disappear. They are visible as soon as you enter VR mode in MFS2020. They do not show up in WMR places, though.

I think the blackouts and these triangles are issues with MSF2020 and the Reverb G2.

1 Like

Those triangles sound like they are glitches from when mixed reality portal transitions into msfs vr. The triangles that pop up as it transitions. Maybe try and reinstall windows mixed reality portal and see if that fixes it.

1 Like

I’ll try that. Thx!

1 Like

Hey guys, thank you so far. I actually dont have a problem with the triangels and the blackouts do not occure in the MSFS menu, just when I am flying.

Yes, turn down your system volume to around 85-90%. Random blackouts are caused by the G2 speakers being overloaded. Hardware issue most likely…

1 Like

I have the volume set at 50%, since the first time I used it. I thought it was a bit loud, since de default was 100%. I still experience the blackouts.

Regarding the triangles on the left eye, it turns out it caused by OpenXR. I reinstalled WMR, as suggested by VapeVader, and that eliminated the triangles. However, frame rate was painfully slow. OpenXR still had motion reprojection disabled, but WMR didn’t seem to be using OpenXR. So, I reinstalled OpenXR. Frame rate was back to normal, but so were the triangles. :frowning:

1 Like

Not necessarily…some people, like me, get the black screen but use headphones, and not the G2 speakers.

1 Like

Thank you Radeks. Its funny, because I dont actually use the Reverb Headphones, since I got good bluetooth headphones. But maybe the sound affects the Sim nevertheless. Gonne try it out. :smiley:

I should be receiving my replacement G2 from HP today. I will post if I see a improvement to my black screens. Also recently I tried to use a new pcie usb-c card to power my G2 and i didnt get errors however I did notice issues. I would get random audio device switching from G2 to my desktop speakers and that seemed to be caused by power? I am not sure but its annoying since it doesn’t give an error.

1 Like

So I just flew a few hours around Japan and I haven’t noticed any blackouts like I was experiencing before. If your having this issue I suggest contacting customer care and let them know the issue your having. I did have to eventually send in my headset but I didn’t have error codes. My headset would crash to black screen and mixed reality portal would crash along with whatever vr game I was using.

1 Like

Did you contact HP Support directly, to get a replacement?

1 Like

yes. I did have to wait a few weeks to get the replacement but I haven’t noticed the issue yet. I am not sure if my issue was caused by me not following the instructions for connecting cables and power. I will say that is a possibility.

1 Like

Ah OK. Thanks! I give it another couple of weeks, before trying the replacement route. I will try, first, uninstalling everything and starting from scratch.

1 Like

Have you tried disabling the toggle for use the latest runtime something above the use custom render scale check box to see if this on or off is affecting this? In OpenXR

1 Like

I had the same problem. I solved it by using the adapter and plugging the smaller g2 cable into a usb3 port instead of the usb c port.

1 Like

Hi ShalomHaifa,

I also have an RX 5700 XT and getting a G2. What Radeon video driver are you using?

Have you been able to sort out your issues with the G2 yet?

Thanks!

1 Like

How long were you without a G2? That’s the only reason I hesitate to try to get a warranty return (well, and the fact that later runs might contain minor improvements that aren’t enough to call it a G3), is that there will be a period of time where I’ll have nothing at all! Made worse by the current product shortage.

1 Like

Well I think it was close to a month. They will be able to give you a info as to rather they have them in stock or not before you send it in. It doesn’t hurt to at the least speak with them. You can send it off whenever you like.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.