Reverb G2 suddenly died?

I just plugged in my Reverb G2 after moving my PC to a new chassis and at first it loaded without any problems. I could also see the Reality Portal Mansion. However, after I set up the key to reset the VR position within the Sim, my headset suddenly died. Specifically it seems to not get any power, as the white LED on the cable itself doesn’t light up anymore.
I tried plugging it in and out a couple of times to no avail. The USB C Port and the power outlet work completely fine.

Any idea on how to fix this or what the issue might be?

Most likely the cable, worst case the headset.
You can try to contact HP customer service, if it is in warranty (1 year, 2 years in Europe for private individuals) they will send a replacement in very short time (happened to me twice, once cable, then the headset itself)


Oh thats a bummer. Is there nothing else I could try out before buying a new cable?
It just seems so weird to have it working without issues and suddenly loosing power without having touched anything.

Had the same problem. It was solved after using the version 2 cable.

Same here, I couldn’t get a sensible price out of HP so bought on Amazon. Not cheap I’m afraid.

After two more days of trial and error I have to accept, that it may be indeed the cable.
I have ordered a new one for a premium and will report back as soon as I have received it.
Appreciate your help nonetheless.


So, my V2 cable arrived today.
Plugged it in and the problem was immediately solved.


Could someone share the Amazon item number for the V2 cable? Thanks.

1 Like

I told you… :grinning:

1 Like

Can you please send some reference or link of the cable you’ve bought?

HP G2 V2 Cable story. - Virtual Reality - ED Forums (

Revision 2 of the Reverb G2 Cable and all the Mysteries Within! (Official Announcement Stuff.) : r/HPReverb (