Reverb G2, works on first try smoothly sometimes, other times have to toggle over and over or reboot? Typical or not?

I’ve followed the guides on here and achieved pretty good success in “most” situations with vr (3080 ftw3 card, 10900k). Running the .30 display driver version that is more golden as well.

I havent quite found an answer on this, but i’m just wondering if anyone else thats gets the g2 smooth, if when you toggle vr off and back to on, if at times it comes back a mess.

This is what happens on my system. Sometimes if you wait a full minute it will smooth out, other times you have to toggle vr off and on several times, or if that fails a full on reboot is required worst case (other times just relaunching the sim does the trick, but either way time consuming short of a toggle).

Anyone else had this happen on a regular basis? I assume its just par for the course for now but trying to rule out some other variable i havent accounted for?

Thanks in advance

NO, I have a G2 and it works all of the time.
The only time I’ve seen this is if I take the headset off during a long flight and walk away from my PC and come back say after 30 minutes. The game acts weird like it is locking up or stuttering while in non VR mode. Eventually it clears up and things continue as normal.

Thats kinda what i mean, sometimes i go away, come back, the vr mode is toggled because the goggles went to sleep, so I wake it and toggle it back, then its a mess at least on first try (usually). However in my case i can usually replicate by just toggling vr off then back on (I guess in your case you havent experienced it with a manual toggle though, odd)

It happens in this game but I’m not sure it is the game causing it.
It could be some other issue such as Windows, HP, or NVIDIA drivers.
Hard to say at the moment.

I too can’t go out of VR in the sim and then back to VR on without stuttering and massive frame rate loss.
Sometimes a switch off from VR just happens when trying to adjust things like weather conditions with the tool bar. I noticed this behaviour since VR beta.

If I go back and forth between VR & Flatscreen then there’s a huge memory leak or something hogging the entire system resources in the background, so what I do is this in these steps:

  • Wait until I’m at the Airport in the plane then go into VR Mode
  • If I go into Flatscreen for whatever reason I Close Down WMR and wait a few seconds for things to settle down
  • Going back to VR it’s smooth again as WMR is freshly reloaded

If I don’t close WMR in between then it’s a complete mess and never recovers.

I’m having the same problem with the Oculus runtime, so it can’t be WMR…

This happens to me too. I’m using Reverb G2 and Nvidia’s latest drivers (I’m not using the often recommended .3 drivers).

Same here, with the same hardware. Quite often, I need to restart the sim. Following, hoping for some solution.

Same problem here, Im using Quest 2 and oculus software…If i take headset off then come back to it 5 mins later massive frame drops and stutter

This thread should be in the bug section

1 Like

Anyone try the new Nvidia hotfix yet and has it made any difference to this?

I’m certain if you type “NVidia hotfix” in the search feature you’ll find the topic which is currently just above this discussion in the list (at this moment when I’m typing this) :slight_smile:

1 Like

Not seen this, I have a G2 and a 2080Ti, been pretty consistent apart from the microstutters every few seconds. No I try and avoid taking my headset off unless I’ve spilt my cup of hot tea… I think I need to buy a hot drink holder on Amazon - one I can use with a straw…

As the switching is between PC and VR settings I wonder if there is a GPU memory loss issue switching out textures. Do you get the same issue if you have medium textures in BOTH PC and VR settings - or at least use the same value for each?

1 Like

I have the same problem as well. I usually deactivate “Win+Y” and go out of fullscreen mode (Alt+Enter). Then go back to fullcreen
mode, switch to VR, and activate “Win+Y”.
Setting my cockpit gauges to high also helped “recover” from the stutters than other settings.

Just to add confusion to chaos I have witnessed issues changing settings generally while in the desktop version. I can get to the point where switching textures for example from high to low can lower frames, but putting it back to high again returns performance to normal levels, so I think there are bugs around GPU memory usage - stuff not getting cleaned up which could also be what’s happening switching in and out of VR.

Correct. Changing settings without restarting will induce the stutter more than anything else. It takes a couple minutes for my system to settle down if I do that.

2 Likes

Can’t say I have seen this issue with my G2.

Guys, this was mentioned elsewhere in the forums but can’t seem to find it… but

It seems that changing all your 2D graphics settings to low, including the lowest render scaling, eliminates this problem in VR. However, apparently it comes back if you alt-tab.

I don’t seem to have this issue anymore after trying this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.