Reverse thrust broken

I woke up on a Monday and Asobo changed my settings, i took me 12 hours just to get them back. I woke up on a Tuesday and Asobo Changed my settings, It took me 12 hours just to get them back. Yeah they love to change your settings, yeah you can never get them back, yeah you cannot play the game, youre spending too much time fixing everything. I woke up on a Wednesday and they changed my stuff, it took me 12 hours just to get it back, then I woke up on thursday and they chaged it again, it took another 12 hours just to get it back. PLEASE leave things alone, PLEASE just throw me a bone, PLEASE I wish that i could play, but Im on the forums trying to fix things all ■■■■ day!

2 Likes

Worked, unfortunately you cannot control how much thrust. Maybe Asobo should leave things that work alone!

I am on Xbox as well use another thrust master hotas stick and I used to have it mapped my baby button and now I can’t get it to work it sticks for two seconds until I rub the thrust up and then it closes and goes back to forward thrust! I’m really ■■■■■■ off at this a screwed up man! Not to mention so many other issues with this update and Xbox they really did a hosing for us!

This is very frustrating, first my reverse thrust wont latch and you can’t adjust thrust… Bad…

And now the new 737 ILS indicators disappear! A compete system reboot to see them again.
Change to a different airport port and there gone.

Are the coders pilots at all???
This all works in XPlane! Too bad the eye can’t sucs now…

Reverse thrust bug is not listed as top wish list in todays dev update? How could it be? I just can not believe it !

1 Like

Because it’s already fixed in the upcoming patch Release Notes 1.21.17.0

I can confirm it’s fixed in the beta patch - so should be in the final release as well. Works as intended!

But when it is out ?

it is out as beta … see Msfs2020 Sim 7 HOTFIX Pre release! Solves many issues from Sim update 7. Download tutorial - YouTube

#PC
Microsoft Store
Yes Dev mode is on - I tried turning it off without re-booting the game and no change.
Throttle is steady
Toggle reverse thrust will not engage; the throttle will only increase
Logitech Extreme 3d Pro
1.21.13.0

Did they ever figure out or fixed the bug or found another way to use them? I’m currently physically while in middle of landing the plane, moving the view down to the throttle and turning them on that way. Which are causing my landings to be ■■■■.

There’s a bugfix in beta testing that reportedly fixes it, see posts above. Should roll out in December.

1 Like

Plenty of workarounds identified. Fixed in beta.

Roll out the fix in non beta and once the wider community confirms it’s fixed I guess this can be closed but not before.

Using the beta for hotfix SU7, when pressing the assigned button for “toggle reverse thrust” it puts the prop pitch lever into feather (fully down) and vice versa instead.

I am using the Saitek X52.

Any fix to this?

1 Like

Maybe I am mistaken but reverse thrust refers to jet engines only… If we are talking about prepeller aircraft the controlls for reverse is completely different button

Thx a lot for the headup! I mistakenly assigned one button to two comands (toggle reverse on throttle and prop). Deleted the prop one and now it’s back to where it was pre SU7.

Cheers, Wolfgang

Could you please correct the thread title?

Why exactly?

Because it’s inaccurate. Reverse thrust isn’t broken as you have discovered. It would help your fellow forum members when they search