Rift S - constant CTD

Really stumped by a CTD problem I’ve started having. It was working fine until after the last update I think, although I did also update Nvidia drivers.

It just crashes striaght to the desktop with no mesage whenver I either switch to VR once the plane is sat on the runway or if I go into VR before pressing Ready to Fly it crashes about 30 seconds into the loading process.

This is the MS Store version, using a Rift S. I reinstalled the entire sim yesterday and had one flight straight after that when it worked perfectly then just tried it this morning and back to the CTD problem same as before.

Using an RTX2060 and have tried the older and newer drivers with no difference at all. Also tried the beta and non beta versions of the Oculus software again no difference.

Obviusly some variable that I’m missing but I’m really stuck trying to work out what it might be.

This is all the event log shows:

Log Name: Application
Source: Application Error
Date: 13/03/2021 10:24:17
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Faulting application name: FlightSimulator.exe, version:, time stamp: 0x6040b793
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x6040b793
Exception code: 0xc0000005
Fault offset: 0x000000000188bf77
Faulting process ID: 0x40c0
Faulting application start time: 0x01d717f245d56a79
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report ID: 460c6533-c0be-4746-a369-f40b99731f38
Faulting package full name: Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Event Xml:




C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.5.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

Have you previously popped out any windows like ATC or Map?

If so start in flat mode, close those windows, then switch to VR.

See here Sim VR thoughts.. Sim Update 3 - #13 by JoseJacobUK

Thanks but no, I’d already seen that suggestion and checked. Just tried reinstalling the oculus software, still no joy.

Shame. Tried using the steam OXR runtime?

No, can you do that with the ms store version then?

Yes, from memory go to steamVR settings then developer and there’ll be something along the lines of “set as system default OpenXR” and it’ll change to using steam instead when you Ctrl-Tab into VR.

Might not help but easy to give a try!

Cheers for that. I’ll give it a go!

So just to be a bit more accurate now I’m at my computer - start steamVR and click the triple bar menu top left of the desktop steamVR widget (you can also do it from within VR, both will work). Fourth from the bottom you’ll find settings (ignore developer below it) then when the settings tab opens you’ll see “developer” at the bottom left. Click that and you’ll see a button “set steamVR as openXR runtime”.

Oh and to change it back to oculus runtime you can see here How to install OpenXR – Microsoft Flight Simulator Support (zendesk.com) or I think you may be able to just re-install the PTC beta which should reset it, but i’m not entirely sure as I don’t use oculus anymore.

1 Like

Also just in case as I had such problem recently : Do you have any OC on your CPU or GPU? I had one on both and all benchmarks and stress tests worked fine running hours, and all my other games and apps running fine, until I launch MSFS or Elite Dangerous. Both was crashing at random moment in VR without any reason until I lower both Oc I had. It seems MSFS is really sensitive to Oc.

Thanks for this. Gave it a go but exactly the same.

Thanks but everything is just running at the default speeds, no OC. Also it’s not random crashes, it’s CTD as soon as it tries to run in VR. I just don’t get why it worked after a full reinstall of the sim before reverting to the same behaviour the next day. Very odd.

bugger… tried different USB ports?

I’ll give it a shot!

Nope no good. Thanks for all your help anyway but I think I might have to throw the towel in for now. I only wanted to potter about in my biplane for half an hour and I must be about four hours deep just trying to get it to work.

What one is it ?
Is it a default plane, the Carenado WACO of is it an FSX portover ?

If its a portover they will cause a CTD as soon as you enter VR.
There is a workaround to make them work though but its a bit convoluted.

I can’t post links here but there’s a thread at the Sim-Outhouse forums MSFS section called Legacy Aircraft where there’s more details on page 17 of the thread.

Hope this helps.

Thanks, it’s the Carenado Waco, though. Was fine previously, also tried some of the standard planes just in case it was that causing some weird bug but just the same with all of them.

Just to update this thread in case it helps anyone. I tried loading one of the training flights thinking it might alter some variable that was peraps causing the crashes due to more being predetermined. And lo and behold it worked fine. So I then tried a normal flight from the world map and it went back to the crashing behaviour. Remembering about the panels issue others had expereinced I loaded another flight from the map just in 2D and checked again. None of the panels were already open however I did press the “reset panels” option and then when I switched to VR it didn’t crash. But if I try to load a flight while still in VR it still seems to crash.

I have exactly the same problem and error code - but only with the new Aerosoft CRJ. Any other aircraft is fine. I use Oculus Rift S on a Nvidia 2080 Super 8GB and I9900k processor and 64 GB RAM.

Did you find a solution yet?

Not really, no. Only the workaround as stated above. Start in 2D, reset panels and only then switch to VR.