Rift S Not Working Just flashes

No add-ons in your Community folder

Developer Mode on or off, no change

Brief description of the issue: When switching to VR mode, dual pics show, but flashes (See attached video0

Detail steps to reproduce the issue: Start FS, switch to VR mode and the problem starts.

`PC specs: I7-9700k @ 4.5gHZ
Nvidea GeForce GTX 1070
32 Gigs RAM
800 W p/s
Dual 4k monitors, 1@30hz, 1@60hz
Rift S Headset
Logitech Extreme 3D Pro Flight Stick
Win 10 Version 21H1 (Build 19043.964)

Microsoft Store version?

`Did you submit this to Zendesk? Not yet

Don’t know how to add video to this post!

I had flashes until I changed the oculus software version. Try using the beta mode off / on in the settings and it will install update. You can revert to the old version by turning it off again and letting it update itself again.
I also have problems if I change to VR once already in a flight in 2D, I only change to VR when on the world map screen and leave it like that until I’m finished

I may have the same issue, depending on what you mean by “flashes”.

For me, entering VR mode and clicking the “Fly” button causes the computer’s display to blink between two different 2D views of the firfield. Exiting VR mode returns the 2D display to a flyable condition. When in VR mode the VR display also blinks between the same alternating display, except the Oculus application’s Home display is also included in the displays that regularly blink/flash.

I made a movie of the 2D display’s behavior in VR mode, but it is to large to upload here. I will try to drop the resolution to see if the file can be made small enough to upload here.

I tried that, but still no joy. Seems like Oculus and something else are fightinging for the feed?

I put mine up on you tube. It is video id: youtu.be/
10hDVjPV4IQ. I put the whole set of programs on another machine, I5-8600k(?) and Nvidea 970 Ti
Cant get the FS to go into VR mode, I re-bound the ctrl-tab to a button on the flight stick. Did not have time on the other computer to add the flightstick. Will try that today… Will let you know if it is a machine problem or a software problem.

See you tube video address below

If it helps, it’s took months for me to get my rift S, pc and msfs to all work together happily. And once your happy there will be an update from oculus, nvidia or msfs and you start again. I’ve learnt a lot on these forums and you just have to try every possible suggestion. You could check the posts about open XR, then try nvidia 457.3, double check which usb it’s plugged in to, …there’s 100s of possible causes. Just today my a320nx isn’t working properly so I’ll have to spend the next few hours figuring out the issue, but I don’t mind because msfs vr is simply too good not to try and fix issues

I’ve watched that video link you put on and I would look towards fixing an oculus issue first, nvidia or msfs hasn’t caused flashing like that for me only oculus problems seem to cause that

Well, I had it working for an hour or so. Always LAX small aviation parking, cold and dark.
I re-flashed my MSI Carbon Pro MB last night, with no immediate result. Old version was 2018, new is 2020.
I went to Oculus app (program?) Switched to beta and turned on public channel.
Started FS and went to graphics and shut off v-sync. (I have an Nvidea 1070)
I also (in Graphics) moved all the sliders to minimum and everything else to low or off.

Then something happened and it went back to the same thing.
Also, my GPU has 3 DP ports and 1 HDMI. I am running a double monitor system. Both monitors were plugged into DPs. The Rift S took up the 3rd DP.

When this was working, I had the 2nd monitor plugged into HDMI.
What was working was: DP (4k FS monitor) HDMI (4k primary #1 monitor) DP Rift S.
All USB devices are still removed except for USB audio.

It seems to me the Oculus home page is screwing things up. I’m not sure, but I believe when it worked, it bypassed the Oculus home screen somehow and just started working. (When I switch to virtual desktop monitor 2, I just get the same flat screen double image you see on the actual monitors.

HELP! I know this works and it is something stupid that reloaded itself.
BTH I unloaded almost all the drivers and dumped any programs I didn’t know what their purpose was. I also reinstalled Windows.
So why did it work and then quit? (I had rebooted many times after each graphics adjustment)

Are you trying to use multiple screens as well as a VR headset?

Yes, It was working with both screens, but I cant see what’s on the second screen unless I peek underneath the headset… I have tried with 1 screen (on both DP and HDMI, with no joy. Even tried to split HDMI output from Integrated Graphics AND the Nvidea 1070 card DP output for headset. Again, No joy. Now it is back to flashing and hangs the program. The Esc command is ignored as is Ctrl-Tab. Did you see the video? It is a little different now. Faster flashing and I see a yellow ! in a box (very briefly), center screen. Looks like it is a warning from the Oculus program.

I would disconnect any additional monitors other than 1 of them. Make sure the Rift usb cable is in a USB 3.0.

I have my monitor plugged into gpu hdmi port
Rift S into display port on gpu,
Rift S usb port into usb 3.0

Controller into usb 2 on the cpu

Whether or not my setup is right or not it works fine, but one thing I can’t fix on mine is having to replug in the Rift S usb plug each time I start the pc and oculus software, it doesn’t register a headset on load up.

Also I have read that the monitor is best at its native resolution to help fps in vr. You can check your active runtime is set up right - there is threads on this.