Rift S w 9900KF + RTX3060ti - bad stuttering issues

Hi, as per title… I run 5Ghz O/c 9900KF, RTX3060ti, 1TB SSD, 32Gb RAM, all games run great at max settings even in VR… but MSFS 2020 runs like ■■■■ at 20-30 fps and gives me massive stuttering issues.

I run all setting either off or low, terrain detail 100 or less, i usually have the MSFS Map Enhancement using Google maps, rolling cache at 20Gb… but even without it it runs badly, i tried many different things and settings, but the performance is terrible no matter what.

Ran MSFS in Dev Mode, says “limited by main thread”, but looking at Task Manager while i fly and seems the GPU and CPU are not even running at max, most of the time around 50% or less… so don’t understand.

I don’t understand what OpenXR is supposed to do or if anything changes using Oculus Tray or Steam VR, basically no matter what i try it runs like ■■■■.

Anyone have any tips please?
How can i diagnose the source of the issue, what can i try to improve, and what is the difference w using all the different apps??
Does having a rolling cache affect performance? What about this cache, would that change anything? Have offscreen cache set to high, i read it helps… still no joy.

I need some advice please :slight_smile:



If you are using DX12, please revert to DX11. DX12 is currently in the process of performance improvements being made by Asobo in SU10Beta, which will be released soon. Asobo is stuck until new drivers are available from nVidia, especially since there have been issues with nVidia GPUs.
DX12 is almost never a winner, especially in a VR environment with SU9.
SU10 is a work in progress and its behavior changes with each weekly upgrade; DX11 is (as of today) safe.

I personally believe that it is hard to reconcile the two when it comes to FPS and stutter and that many people tend to go for stutter reduction because the FPS does not increase much in MSFS.
Performance must be improved first, as VR will never perform better than normal display modes. I think the Oculus specific issues come after that.

The settings seem low enough, but try once moving the google maps extension from the community folder to something else and not loading it, just to be sure.
I don’t use these mods, but depending on the graphics format, the large VRAM hit may slow you down.
Also, try flying with the rolling cache completely removed once. I have no clear evidence, but it may change the behavior.

As for the main thread limitation, keep in mind that this is only in Dev mode. This does not mean that someone is limiting your PC, it just shows you where the performance bottlenecks are.

How does it run in 2D? I don’t use google map mod so dunno about that. Turning down the headset rendering resolution on the Oculus App reduces demand on the system. My laptop 3080 is ok at 4480x2256 but can’t handle the next level up at 4704x2384. In MSFS VR settings I find it needs render scaling at 100 to work ok, in either DX11 TAA or DX12 TAA. Another idea is reducing the MSFS PC screen resolution… since I only fly VR I run it in windowed mode at only 1024x768 (with the window sized at that size). I even did 800x600 and it seemed better but I’m doing some dev mode work and need the real estate. Also, I find the MSFS multiplayer impacts my performance, so I have it to off, I also do the same with air traffic… though I do use live weather and photogrammetry. The low terrain level of detail also helped in the VR settings. Also make sure you don’t have other unnecessary apps using too many resources on your system.

Hi guys, thanks for the replies and suggestions so far.

i tried a few other things in the meantime, seems some of it helped. FYI

  • changed from FXAA to TAA. So much smoother, better looking and better performance, can vouch for that as i tested exact same flight, same area, same session. Weird, i thought that MSFS implied TAA would reduce performance… go figure. One wonders why the hell Microsoft would not try promote something that looks better and performs better… it just seems retarded how that would not be made more obvious to VR users.

  • I changed some storage memory settings to improve performance, sorry no exact link/details at the moment cos i am on another computer, but basically i followed a few forums to manually allocate in advanced performance settings where the PC would be writing and how much space would be allocated… seems like it helped

  • still overall not too impressed w MSFS, i recognise some of the exact same photogrammetry areas from Google Maps app that i use in VR w Mods i downloaded, i can fly around at will no stutters or bs in Google Maps, but flying the same scenery in MSFS at a fraction of the speed seems to tank the whole system/ It is just weird, should not be that way, esp when any flight calculations have nothing do w GPU, and Google Maps would have no path prediction to pre render like MSFS does.

Pretty sure i’m just on DX11 ;

Trust me… do this and get back to me… nvidia control panel lock 30fps for fs2020. Youre welcome. Now youre smooth. :wink:

tried it, made no difference sorry

yeah i turned all the extra bits off.

I really don’t understand ■■■ the issue is. Last night it was running ok ish, today back to dogsh1t. Think settings are most the same, trying same area and plane etc…
tried moving cache location to another drive, with and without rolling cache, no change. Mountains and cities both running bad.
Checked again in Task Manager, CPU and GPU barely ever above 50-60%, temps under 90C on CPU and 70C for GPU, but still stutters and cannot play the ■■■■ game!!!

Def on DX11.
Tried w Google map on and off, and w rolling cache and not, 8Gb and 20Gb, still the same stutters. It’s just unplayable, i have pretty decent and powerful rig by most standards, i just don’t get it.

One problem I have experienced (and experimented with) that is so bad, about half FPS, is when HPET is ON.
This problem seems to be more pronounced on Ryzen CPUs, and when I experimented with it (SU10Beta 1.27.16), there was a frame rate drop of about 60% with it ON.
There are many similar examples on IntelCPUs besides MSFS.
I have answered another person in the past and that person was not cured, but there are many cases that can be cured, so I will give you the link.
You can try it if you like.

OK… an update for posterity:

-Reverted back to Win10 standard Virtual Memory settings, it was causing other issues and didn’t help one bit, maybe made things worse, i have 32Gb RAM so def not recommended, despite other forums’ advice. Don’t bother.
-Updated all Mods from Flightsim.to, i didnt know it had to be done manually, i have many, so who knows if some were bugged…
-Cleaned out Rolling Cache, updated to version 6.1.6 of MSFS2020

Now for the big one…

MSFS just had a major update? 8Gb? Anyway, i ran it… rebooted… BAM!

Game runs like butter now!!

No stutters, can even run High cloud settings, more tweaks possible to get more out of the game i think, but i just flew from Geneva to Lichtenstein up the Rhone/Rhine valleys, not a single frame droppped and marvellous visuals all the way. Hallelujah.

So, who the f knows what did it, but glad it is finally sorted. I reckon the issue was mostly to do with the system updating the cache and new map textures being loaded causing the stutters, because once an area was loaded i could always fly much smoother even with sudden movements in flight, while flying in a straight line onto new territory always caused more stutters for me.

IMHO, the MSFS update did it, seems like they traded some visual quality (especially in the far distance) for performance, but who cares, at least now i can fly at last. Happy days.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.