Round and round in circles...again

Update download looping at 2%…Netlimiter ON at 3Mb/s. I really give up

My update ran very well at about 45MB/s That is 45 MegaBYTES per second.
So far everything is running well. We will now check out the particulars of this update.

UPDATE: I wonder what is causing your problems. Other simmers may have difficulty too.

I’m very happy for you.


consider yourself lucky…I have 0 out of 123Gb downloaded and it will not download anything.

You would think after 2 years, they would have least fixed this part of the game (but sure, add complexity by making us use the ridicules and pointless XBox app on a PC).

Delete the file its looping on then it will continue. A google search will give more details.

1 Like

This SU10 “update” is only about 16GB and a few in Content Manager. I suppose you are attempting or need to download the entire MSFS again. Yilkes… There must be something you can do other than have to download the entire flight sim again. Maybe others will chime in… Sorry you are having such troubles.

it certainly was some issue with game - both ingame update and the Xbox app. I did reboot and try again and oddly, it was downloading in the background with no indication.

Update appears to have worked fine though.

1 Like

Blimey that’s impressive.

Have you tried shutting down your pc and resetting your router?
Shutting down background tasks on the taskbar, close all other software? Perhaps even try booting Windows in a clean-boot situation- Google how to do this.

Backbone city, USA, I usually get 90+Mbits/s. Right now I’m at about 0.3Mbits/s with rare spurious bursts to 40Mbits/s for several seconds. Been at it for over an hour and I’m at 53%.

I downloaded fine (I think) but been at this now for 2 plus hours…

1 Like

Aw that stinks. Only took me about 40 minutes to get everything (including content manager updates) over starlink.

Yes, thanks for the advice. After adding and juggling with VPN, Netlimiter on/off it seems to be downloading now. :crossed_fingers:

1 Like

Good to hear, hope the download goes well and completes without any further issues. Don’t forget to download updates via the Content Manager once you are in the sim. :+1:

1 Like

Sorry the OP is struggling, but this is the absolute SMOOTHEST update I’ve ever had. Fast, and no farting around with the Xbox app. Start game, “your game needs an update”, click continue, and less than 5 minutes later, I’m in the game menus. Amazing work Asobo!!

Moved to #self-service:install-performance-graphics

I believe I ahve seen some Anti-Virus software (Malware Bytes in particular), messing up the update, and causing these loops.
Since I started turning off Malware Bytes, before any update, I have ceased to have this issue…

Coincidence maybe – but if it is working, I am not about to mess with it and try making it fail again.

I try to install the SU 10,
have restarted it two times
during installation at 169/216 the installation seem to go in loop and continously try to install again and again “Asobo-simobjects-characters-0.1.55.fspatch”
any help here?

Try deleting this folder from the “Official One Store” folder, and restarting the update.

For my issue, I finally decided to close the game and re launch. Once back in it was a small 20mb download and it finished perfect. Odd…