RTX 4090 and MSFS2020 my experience on the PIMAX 8KX

Thanks so much for the lengthy and detailed reply.

I will look into the issues people may have with the 8KX.

I’m wary of the Quest Pro despite the good reviews, given that the resolution is the same as the Quest 2, albeit with pancake lenses.

Also, the lack of a display port seems odd.

Maybe the 8KX will be what I go for!

How about the Pico4?

Never used it so I can’t be much help on it…sorry

Thanks to this thread, this is the main reason I upgraded my gaming rig. Mine came with 13900KS and have similar…actually higher FPS with same settings.

1 Like

I realized my Parallel Projection is off and turned it on(your most recent post says yours is turned on) and I start to see some lag/stutter (even though my fps remains to be above 60). Even decreased TLOD to 200 but problem remains the same.
I know turning it off makes performance better but 60 fps while turned on? Not sure what’s wrong with my settings. Turning PP off makes everything smooth again.

I checked my settings again because I have switched between DX11 and DX12(Beta) and a few other changes…so I am posting my settings pages for MSFS VR and PC and the Pimax software now updated to and I still have OpenXR toolkit set to CAS and 100% sharpening no other changes to OXRTK. Hope that when the next SU12 update comes out I can go to DX12 and get better performance…we will see. This gives me between 35-40 fps. Hope this helps ya.

1 Like

have you tried my color settings?! :wink:

Thank you for posting your settings ( BTW, you posted your settings for Traffic on PC mode and not VR mode but I got your VR mode settings from earlier post)

I realized I’m using PiTool and not the Pimax Client. By installing Pimax Client, I was able to update my headset firmware which was not offered on PiTool. HOWEVER, starting MFS throttled my FPS to 8-10 just at the menu screen. Tried all the uninstalling-install-reboot troubleshoots but no luck. Google search did not find anything related to Pimax Client.

So I switched back to PiTool, this time with Parallel Projection turned on now everything is smooth. I now have similar FPS yo yours with exact settings. 45 FPS in Bora-bora, 40FPS in New York. I guess the new firmware version fixed the PP.

Again, thanks to you. This thread should be stickied for other first-timers like me with 4090 and Pimax 8KX. The Pimax MFS Starter guide on their site is outdated.

Now I have to figure out how to fix the Pimax Client…

1 Like

not yet…sorry