Rtx2080 19fps?

How can this be possible?
RTX2080 32RAM i7-8700k and 19 to 35 fps on High-End 2k?

… really???

It isn’t. I have the same CPU with a 2070S and I get three times that in cities with half settings on Ultra on 2k.

Im running benchmarks on my PC and no problems.
Oh and also i have the MSFS on a SSD 970 Evo Plus.
I’ve already reinstalled drivers and keeps running 20fps average.

Just curious, are you running it in 2k ?

Sorry, if I had an idea of what’s wrong I’d tell you. I am also running on a Samsung SSD.
Maybe use the Windows task manager or resource monitor to see if something is stealing CPU or GPU.

Yeah, as noted I run 2K.

1 Like

Actually, I get 3 times that at “high” graphics level. I get 40fps with half the high settings set to ultra. My initial post was worded poorly.

29 fps…

I’m getting 60 with a 2080 and an I9. 4K on ultra even in big cities I’m getting about 40

How the actual F

Have you tried changing the games streaming cache to a drive other than the one your pagefile is on and the one it is installed on? It’s just a shot in the dark but it is something I did that seemed to help me a bit. The game seems to thrash the pagefile and other assets while streaming even more assets from the server. I’m not to convinced this will actually help but it’s a shot. I have the same CPU but only 16gb of 3600mhz ram and a 1080ti and get much better than that at full 1440p ultra settings. Something is definitely not right.

Sounds like you have the best 2080 ever made. I’ve watched 2080ti’s get pounded below 40fps at 4k ultra in a lot of areas.

Actually the GeForce Experience suggest me low/medium settings.
I repeat …really?

Thats not what i saw last days on streamings, what happened.

My PC seems just fine, XP11 runs wonderful even with tons of addons, mesh and stuff.

I have a 2080, 9900k and frames are pretty fluid.

The amount of data streamed is tiny going by what MSFS tells me and he is on an SSD.
If it is a consistent 19 FPS then there is something wrong somewhere. I can’t remember what it was but I noticed in Star Citizen that my FPS were low and I checked with Task Manager, I had an up running that was taking 20% of my CPU, I think it was FireFox. As soon as I killed that it was normal again.

I assume you have rebooted your computer since installation? GeForce Experiences isn’t worth the price we pay for it (0$) and something I make sure to not install so I wouldn’t take a lot of stock in that.

It seems the GPU doesnt have a lot of load

We can see your CPU says it is up to 71% load but only 40% of that is used by FS. That will probably be your issue. There is 31% of you CPU that is doing something else. Sort by CPU usage and see what is there.

1 Like

Do you really think there is a usage problem? idk it seems to me that the GPU is not fully required by the MSFS.

I mean, the Sim has 40% of CPU the next one is ICUE with 12% an so on.

1 Like

Why is that the only thing you focused on? Again I wasn’t saying I had a fix but I mentioned a few things that are all happening at the same time and potentially on the same drive. Seeing he has a lot of gpu resources untouched shows there is a bottleneck happening elsewhere. Could it be streaming? Maybe but doubtful and that wasn’t the focus of my comment. I would recommend installing hwinfo and watching that while playing. Maybe he can get lucky like I did and see the red warnings happen.lol That was the first time I ever seen a game destroy a pagefile so brutally.

There definitely seems to be something running that is slowing things down.

But a quick question: Do you by any chance have FSUIPC7 running?
If so there is a known issue where the simconnect released withe MSFS is causing the frame rate to drop dramatically, and Asobo is aware.

I run an i7 9700 @ 5.0GHz, 32Gb RAM 3200, RTX2080 8Gb, and MSFS on a SSD.
I easily get a solid 60fps on high (have not tried Ultra yet), but the fps drops to 20fps w stutters when FSUIPC7 is running.