RTX3090 low performance with capacity to spare

Hi.

I need to lower my settings more than I think I should, and still get some flickering and performance drops with my computer.

Looking at loads and utilization, all my cores are below 50%, with some periods a bit over. My GPU sits at 60-80% load.

I haven’t measured FPS in the sim, but I’m getting obvious drops where even ASW can’t keep up.

I have a bottleneck somwhere, and I’m struggling to locate it. If I had a maxed core or GPU I’d just say that’s the limit of my system, but I’m not.
All temps are fine, even low-ish.

RTX3090
i9 9900K @ 5GHz all cores locked
64GB 3600MHz DDR4
Quest2 @72Hz and max res
Render scaling 100, reasonable serrings, LODS at 100, no fancy effects etc.

Anything I can check, monitor or change to figure it out?
Edit: also no upscaling other than the OIculus slider all the way right.

You are CPU bound.

2 Likes

Did you read my post, or just the headline?

My cpu had no single core over 50-60% use, which is why I think I’m bottlenecking somewhere. So while I think you’re probably right, it’s becomes even more important to at least get my mainthread to 100%.

Hi,

What happens if you disable ASW and try capping the max frame rate of MSFS to 36 FPS in Nvidia Control Panel? Make sure you then restart the sim. That should produce a smooth result in the headset with 72Hz.

That’s the config I’m running with an i7-10700K and RTX 3070. My headset resolution is 4864 x 2448.

Technically, my PC runs the smoothest (i.e., zero stutters, flickers, performance drops etc) when it’s capped at 32 FPS in Nvidia Control Panel (tested in the densest areas, with demanding aircraft), however, I rarely do that type of flying, so I bumped it up to 36 FPS to get the smooth experience that having 1/2 the refresh rate offers, for most of my flying.

On my setup, I noticed interruptions to my VR experience primarily stemmed from fluctuating frame counts.

For example, theoretically if my PC could output 50 FPS, think of the headset displaying 50 of those frames, but it still needs to fill in the gap because it’s refresh rate is 72. Therefore, it will repeat some of those frames (22) to make up the difference. It does that every second. If the next second, the PC outputs 43 FPS, the headset has to repeat 29 frames, instead of 22, which it did the previous second. That generates stutters, which even ASW has difficulty making up for, especially if the number is fluctuating wildly when flying over dense areas.

The main benefit of capping your FPS, is that it means the computer can reliably generate a stable number of frames, every second, regardless of where you’re flying. That’s where the 36 FPS number comes in. For me, because my PC isn’t as powerful as yours, it’s technically 32 FPS.

The other benefit that capping your FPS can offer is when you can match it to half the refresh rate of the headset. That means the same number of frames is displayed in the headset, twice, every second. Thus making the experience smooth, without necessarily needing ASW.

Ideally, the game would be running at 72 or 90 FPS all the time, in which case it wouldn’t be an issue. However, that’s not possible at the moment, so ideally it’s good to try and aim for half the refresh rate of your headset, and keep that number as stable as you can.

Obviously this approach does reach a point where your brain will notice the repetition of frames every second; think moving very fast, very close to the ground, looking sideways. That’s where having 72, or 90 fps, every second to match the headset refresh rate, comes in. Perhaps DLSS or other sim improvements may offer improved FPS in the future.

Cheers,

2 Likes

I’ll try that, but right now I’m not using my stuff at its full potential, and it’s new very interested in getting the hardware to full speed, then looking for stability within that performance bracket. Right now my system is dragging it’s feet, and I struggle to figure out why.

Your LOD is too low. As such, the CPU is under utilised. Start with setting both LOD sliders hard right, restart the sim and try. then gradually adust them further left (if necessary) until you get the sweet spot. Remember to restart the sim fully between each adjustment and let us all know how you get on.

3 Likes

You can also try increasing your traffic settings (air, land, sea). I think they’re mostly reliant on CPU, so that may also help take up some of the spare capacity, in addition to increasing your LOD sliders, as previously mentioned.

Just be sure to change one thing at a time, so you can test to see what impact each setting has.

Cheers,

You are CPU bound, just because the CPU is not maxed, or has a single core running flat out, you are still CPU bound. Im CPU bound on a 12900k in built up areas, it’s insane along with a 3090ti.

3 Likes

I had a quest and changed to a reverb
Running 3080 and all at uitra lod 200 and above always around 25/32fps.
Quest was a disaster with me.
Running 3100/3100 resolution btw.
I use open xr toolkit. Great stuff!!
I suggest try higher some settings like lod. Youre GPU should be at 90/100% during use.
Maybe you need to feed it more workload.
And really with youre kit try a reverb
Really a gamechanger!!

Do you think "Process Lasso Pro " may help ? Helped my system at the time when i started with VR…

I would think that if my CPU was underutilized, and I wasn’t hitting my fps caps, I’d see at or near 100% load on my GPU?

And vice versa, if I was CPU bound I’d see one or more cores at or near max load?

With the 3080Ti I used to have I was clearly CPU bound, one core was close to 100% all the time, and my performance was better and more stable.

I read 60-80 % GPU load, hence CPU bound. Theres literally thousands of threads on this exact topic on the forum.

INdeed, but most of those end up with one core maxed, I’m at 40 on my most taxed core.

I’ve found some settings that got my GPU closer to maxed, it’s sitting at 80-95% most of the time, and the experience is reasonably smooth.

I was just expecting a much more loaded CPU, especially with VR and a data-hungry GPU, but I giess the overall low fps just isn’t taxing the CPU very much.

Thanks for the help and nudge in the right direction anyway. :slight_smile:

I got a feeling you are checking CPU and GPU load on Task Manager while the sim is minimized, is that correct?

Increasing the LOD will load the CPU. You can use the Xbox overlay (in Windows) to show you performance while the Sim is running :+1:

I tried it, but the chop got way worse.

I have nearly the same rig as yours: i9-9900K, DDR4 3600 Mhz, I run 4K, HDR10, max settings, all ultra, render 120%, TLOD 5.0, OLOD 3.0, Nvidia filter effects… and most of the time my GPU load at 99% (temperature 75-77°C) and CPU at 48% (MSFS, Firefox and many other apps simutanouesly). I am pleased since my 3090 works pretty hard.

You should expect your GPU 100%, not CPU.

1 Like

But this is pertaining to VR specifically.

Sorry, I missed it. Not sure if OP tried running in non-VR mode with max settings to see whether his rig still get something low performance, or only limited in VR.

I haven’t, for a while. That’s a good idea, I’ll do that.