RTX3090 low performance with capacity to spare

I did, and had poor performance there too.

Basically still saw low CPU loads, but limited to mainthread until I got away from the airport a bit. when frametimes went down I started to get GPU limited, as I would expect.

Så, culprit was Hyperthreading somehow got enabled on my mobo. Disabling that and I went from 45 on the tarmac to 85+ and GPU limited almost all the time. Single core loads now show 50-95% load.

I’ll go back and check VR, but I suspect it’s fine.

2 Likes

CPU load is often misleading, you can be single thread bound without any given core being maxxed out due to the way work is spread out. If your GPU is not maxxed out (and you aren’t artificially limiting frame rate with either a frame rate limit or vsync) then you are almost certainly CPU bound in some way unless there is something else obvious like lack of ram etc.

If you enable dev mode you can see what’s capping your frame rate at any given time, that’ll give you the definitive answer as to what is capping your fps.

I’m Mainthread limited up to around 60ish fps, then I start seeing GPU limited up to my max when i’m away from the airport.

VR was GPU limited at around 45fps, and quite jerky with much lower settings than the 2D test (Ultra preset). With higher LODs I could provoke a mainthread limited, but I never got above the 45ish fps.

Pair that 3090 with a 5800X3D and reap the rewards!

you’ll pry the Intel from my cold, long dead fingers.

Anyways, I’ve given up on VR for now. I’m probably just asking too much of my system, having seen the settings people find amazing in VR.

Hi there, VR user with a Rift CV1 / R3600 / 1080 Ti.

I’m having pretty much the same experience. I’ve spent (and still spend) an awful lot of time in X-Plane VR with a pretty good grasp on how to spot and avoid bottlenecks and tweak the performance in VR so I first went with near absolute minimal settings (suggested VR settings with everything medium or higher switched to low except for textures high and off-screen buffering ultra) and framerate locked at 30 fps with locked ASW using Oculus Tray Tool.

This gives me pretty low and stable GPU usage around 40%, GPU frametimes around 16 ms and CPU frametimes between 6 to 12 ms as reported by the Oculus Debug Tool performance overlay. Still it seems that the CPU usage is very spiky (afterburner records occasional CPU thread usage spikes around 70-85 %) and it seems that these CPU load spikes coincide with the few remaining stutters I have.

These are infrequent but pretty hard stutters (sometimes up to half a second) and I still need some testing on this but they seem to be related to scenery complexity. I don’t have nearly the same amount of stutters if I’m flying around an island than if I’m above a continental urban area. Coincidentally, X-Plane has the same limits with the sheer vastness and complexity of the scenery that can easily choke the main CPU thread. Now I may be wrong on this since these spikes seem to happen even with the game paused and in the background.

I guess I’m pretty much in the same situation than with X-Plane with CPU single-thread performance being the ultimate roadblock to a perfectly smooth experience, except in MSFS there doesn’t seem to be a graphics compromise however aggressive that can solve the issue, and while my CPU isn’t the absolute fastest, breaking the bank to buy the latest and greatest would not be guaranteed to be enough anyway.

Still if anyone has some more tips on managing these CPU load spikes, I’m all ears.

Hi,

You mentioned you’ve capped your FPS, which is good. I’m curious if you’ve tried changing MSFS texture resolution to medium?

Also, what LOD are your sliders currently set at? I fly with Terrain at 100, and Objects LOD at 130.

I spent ages trying to figure out stutters in VR during dense scenery. Then I dropped the texture resolution from high to medium, restarted the sim and it made a huge difference in performance.

For example, I have add-on scenery for Chicago. With texture resolution on high, the location would grind to a halt, and sometimes never recover. On medium, I can fly through there smoothly and enjoy the view.

And thankfully, I can’t say I’ve noticed the change in quality to be honest. I’m sure it’s there, I just haven’t noticed it yet.

Cheers

You have pretty much the same hardware I do. You did not say on the original post what RTX 3090 you have. Mine is a Strix 3090 OC (factory overclocked) and I get crazy FPS considering I keep EVERYTHING in Ultra with an HP G2 and the OpenXR Toolkit at 90% and Preset for Quality. I am not CPU Bound. I have a GEM of an i9-9900K, some call it winning the Silicon lottery. I reached 5.1 when needed (see attached clips). I get an average of 30-32 (sometimes 36 or more, depending on the weather and altitude… You need to play with your settings, do not go for what others telll you, cause every system is different, some MB are better than others. You CPU/GPU combo is very capable. I am not CPU bound AT ALL, but again, because I got the right settings on Nvidia, Toolkit, and everything else.
Find another post of mine where I wrote my VR settings and go from there (posted it yesterday, Post tittle was something about what are you getting out of your RTX 3090)
On this clips, look at the TEMPS on my CPU, considering the load is super cool (had it going flawless for 2-3 years now.) and the amount of NVRAM used by the 3090 AFTER flying for about 3 hours.
Good luck.
Screenshot 2022-05-02 025923
Screenshot 2022-05-02 030123

I’ll have a closer look, but your system looks pretty close to mine, both in temps and settings.

I have the ROG Strix OC Ampere, again, comparable to yours. I’ve raised the limits of my card, and I’m never throttling if GPU-Z is to be trusted, at least. Always PWR or VRel limited on the cad, even with limts raised to the max. I seem to have won the silicon lottery on my GPU. :slight_smile:

I really haven’t played much with the Oculus tools, but I’m currently running whatever res the Oculus app sets as max, with no upsampling anywhere. Clarity is suffering compared to running render resolution 120 and above, and framerates and stuttering don’t really improve when going below 120, so it seems I’m CPU bound, not GPU.
I could also just dream of running stuff at Ultra in VR. Even in 2D I can’t run LODs above 200 with Ultra presets, so there’s definitely something throttling my system.

I’ll keep trying on occasion,especially since I got AirLink up and runnin gnow, so there’s less of a threshold for putting VR on without the cable and hassle.

Edit:
I seem to remember the 3080Ti working better in MSFS, I might try to throw that back in the rig just to compare.

Check your BIOS to make sure you have XMP turned on, otherwise your DRAM will not run at advertised speed.

Here are my settings, and it should work the same for you since we have almost identical systems, except for VR Headset.

OpenXR Tools for Windows : 100% rendering and Motion Reprojection turned off

OpenXR Toolkit:
Upscaling: FSR (looks better even though we have Nvidia cards)
Anamorphic: Off
Size: 90%
Sharpness: 30%
Fixed Foveated Rendering: Preset>Quality>Wide

Nvidia Game Driver Version 512.59 (latest as of 5/2/2022

Low Latency Mode: Ultra (This change alone got rid of my CPU Bound message and my card FPS went up)

Preferred refresh rate: Highest available

Texture filter - Quality: Quality

Threaded optimization: On

Vertical Sync: Off

Virtual Reality pre-rendered frames: 1 (the low latency in Ultra is a better choice than this one)

That’s it!

Your 3090 “OC” is much better than the 3080Ti.
3090; 24 Vram 3080ti 12 Vram (look on my clips/pics above, I use more than 18 gigs of Vram on my 3090

3090 “OC” up to 2040 Mhz just by using the OC default on the Asus Tweak II utility (look at my clip above)

3080Ti Boost to 1845 MHz Mhz (Strix 3080Ti OC)

A standard 3090 is barely better than a 3080Ti, the 3090 OC is far more superior that a 3080Ti and very close to a 3090Ti.

Which MB do you have? Mine is an MSI MPG Z390 GAMING PRO CARBON AC

This has got to be the most significant topic & post for me to date.

I was in the same boat with CPU but just assumed that was the somehow ‘max’ my machine could do.

If I’d actually been at my day job I should have thought - ‘why am I not at max CPU on the MSFS threads?’ - GPU’s not bound, IO’s not bound, memory’s not bound.

Hyperthreading. Sigh.

Well, ■■■■ thing is off now, and the results are glorious.

Except…still not totally maxing the MSFS threads out. Can’t seem to push beyond high 30s FPS.

Thanks.

XMP is on.

My mobo is Asus ROG Strix Z390.

I’ll have a look at the OpenXR settings, haven’t touched them at all.

And yes, Hyperthreading is off, that abomination should never have been invented.

That is one I haven’t tried…I will and see if it makes a difference…
Update:
I tried disabling Hyperthreading and it did not make a difference in my system. I turned it back on because other software works better with it.

Tip: Ensure the headset is on but that Steam VR or other VR software is not running before loading FS20. FS20 ought to activate Steam VR and other necessary software as part of the loading process. I get super smooth viz running a Vive Pro 2 on Ultra resolution with a RTX2060.

just 2 more month to wait…