Rudder locked after landing

I’ve made 3 seperate flights now (2 in the 787, 1 in the 747) and each time after landing, the rudder is locked to the left. I unplug my rudder pedals and joystick put it makes no difference, it remains locked left.

Checked all the sensitivty graphs and they are all in the middle and working ok. When I try to use the rudder, I can see it physically fighting on the rudder pedals in-game back to the ghost input. Even with all peripherals unplugged and all commands on keyboard/mouse to do with rudders removed - the input remains.

Once I turn the engine off, it immediately snaps back into the middle like nothing happened. Any ideas what I can do to prevent this? Everything is fine until I try and come off the runway.


Joystick rudder is the third graph. Again, in the middle.


Third graph are the rudder axis. As you can see, perfectly in the middle. Even increased the deadzone to try and combat something.

Pedals showing a deflection to the left.


Turn the engines off and the rudder immediately snaps back to its natural position.

In those a/c disable autopilot either just before touchdown or immediately after. See if that helps.

I usually disconnect A/P around 1000ft AGL.

You don’t have any assistance options enabled do you? Maybe auto rudder is messing with it.

Double check in the Assistance Options under the Piloting section, that Auto-Rudder is turned off

Should have mentioned in the OP. Have checked all assistance options and everything is off. Only happens on landing. Absolutely fine during pushback/taxi/take-off/cruise.

What’s the position of the tiller?

Tiller matches the rudder pedal position.

I’ve now done multiple flights with various 3rd party aircraft (Fenix A320, iniA300) and none of them have the problem. It’s only the default aircraft.

Assuming apart from re-installing the sim, I’ve got no hope of fixing this problem?

Yaw Damper?

This still happens when all 3rd-party addons are removed, right?
Perhaps a spurious binding (keyboard, mouse, joystick etc.) might be causing this (guessing here). Think about what controls are only used after landing that might have inadvertently been mapped to the rudder left (Yaw Left) or the Joystick R-Axis. I don’t usually fly airliners so can’t give an example, but imagine you always press ++some button++ after landing, & this is not only mapped to the action you want, but one of the rudder mappings too…

1 Like

Have same issue like you . Tried everything . It worked with pedals disconnected and cashe file cleaned out but just for a day or so
I am using B737 800 PmDG .
I also increased the rudder dead zone and problem remain
Never had this issue until now
Works perfectly to take off , midair and landing
Once cleared the runway after breaking , the rudder stop working
Let us know if you can figure this out
I did checked all settings and FMC for failure plus hydraulic maintenance !