Saitek Flight Panels

I will try to post a video soon.

1 Like

@GAParadise we’ll have a look and see if it’s possible to do something about this.

@PIC4506 that is indeed odd, but I strongly suspect an aircraft-specific issue. Which aircraft is it and does it do the same thing with other aircraft?

Stock grand caravan, WT CJ4, stock 152,172. Will try others .

Hello everyone. Likewise, this issue has already been discussed but I cannot find a solution to the problem. Every time you start the simulator with USB Yoke saitek, the simulator closes automatically. If you started the simulator without the USB inserted, the simulator works perfectly. apparently it is a profile conflict that the CTD creates. someone knows something about how to fix the problem and delete the profiles and start everything from scratch. Thank you.

possible relevant:

The thread mention “Thrustmaster” in heading, but seem independend of device-typ.

Hello, I hope it helps those who have problems with profiles when connecting a USB.
1-Disconnect the Internet.
2-Delete everything that this route contains.
C: \ Users \ User \ AppData \ Local \ Packages \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ SystemAppData \ wgs \ xxxxxxxxxxx …
3-Connect your devices to USB.
4-Start simulator (it will ask us that we are without internet so we are going to configure everything again and with the options of without internet.
5-Check in controls that the devices have been detected and check in the route that we have already created the correct profiles.

I hope it helps those of us who had this problem.

1 Like

Does anyone one if there is a way to change the default value of 890 to something else. Since most of the ADFs where I fly is in region of 300-400 KHz.

1 Like

So it is not running, even when I add the command -r

The first callout for the exe.xml does not exist.

This is the second exe.xml

Blockquote <?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type=“SimConnect” version=“1,0”>

		<Name>Logitech Microsoft Flight Simulator Plugin Steam</Name>
		<Path>C:\Program Files\Logitech\Microsoft Flight Simulator Plugin\LogiMicrosoftFlightSimulator.exe</Path>


:joy: :joy: :joy:[quote=“captainLIF, post:1258, topic:123511, full:true”]
By way of a little, interesting light relief:

I was watching the Netflix film ‘3022’ last night [not recommended] and near the end, where our hero jumps into the helm seat of a shuttle to go and find his partner who is adrift in space, I nearly fell off my chair when I noticed the controls he was reaching for:

Yes, you guessed it. Only a Saitek yoke!!!
'Course he’s not going to get very far… it’s not plugged in! Hahaha.

Cheap is very cheep … :joy: :joy: :joy:

1 Like

I have the same issue as @TaurineCorn668 with my multipanel switch and is almost brand new; I bought it only three months ago. It worked perfectly until I bought and started using my Honeycomb Yoke.

At the beginning I thought that was the main reason of failing; (I have as well the radio panel and it works just fine) but now that I am testing it again with my X56 with all the AP controls unbinded, the panel just keeps doing the same; I attach a video so you can see what actually happens.

I have tried the panel with another computer and the Multipanel works just fine, so I am pretty sure that is not a hardware issue. Do you know anything else I could try?

Thanks in advance Tr1cky !!

Tell us how you connect the devices to your system, direct USB ports USB 2.0/3.0/4.0? Or via hub? with or without power supply?

Both radio and AP panel are directly connected to the computer via 3.0 USB ports, the rest of the hardware is connected to two USB hubs, one of them is a 4 port USB-C hub and the other one is a 4 ports 3.0 USB hub.

Do they have an additional power supply? If you only connect the radio panel, are the problems the same or different. Are these USB port on the mother board (backside) or front ports?

None of them have an additional power supply. I have an Omen Laptop so the radio panel and AP panel are directly connected to two of the 3.0 ports on the laptop; and I guess both of them just go straight into the motherboard.

The other hubs where I connect throttle, joystick, trackir, mouse, keyboard… don’t have any additional power supply.

And the radio panel works fine on all USBs and both USB hubs, it is an issue relating only the AP panel.

Thanks GuiHuy for the replies.

With a laptop you should definately get a power supplied usb hub, the power is pretty critical to USB ports of this kind. try the AP panel alone, does it work then?

I just switched off the computer, switch it back on and tried connecting only the AP Panel straight to the PC; the same issue continues happening, the first turn of the knob increment x1, but the second and following turns always makes them x2; and as you could see on the previous video if I stop and start turning again the first increment is always x1.

Even if it is not the main reason of the problem I am looking already for a powered USB hub.

I assume you have the latest driver installed and tried to unplug when the fs is running and plug it in again? i checked with my panel and without the hub but it worked fine (driver version 8.0.313.0) .
Have you tried older versions of the driver? or

I have tried with lots of driver versions and none of them none seems to work. I have now installed the last one 8.0.313.0.

I just tried as you said and once I plug it back on, it connects back to the sim and keep working on the same odd way.

I just tried again the panel on another computer that I have at home just to be sure again; and it works great, increments always x1 and not jumping x2 after the second turn. For it I used the trial version for

I have already tested on my PC, getting same results I can see how the knob after the first time rotates x2 until I stop for a while. I don´t understand at all what is happening, but thanks again for your help

Best Regards

Hi just a quick ? Are you driving a Porsche? That would be nice…
Ok here is my last suggestion - start removing the device and it’s data when it’s plugged in - cause you need the plugin data at that time - delete it, after you unplugged it. Here is how you find the data:
See screenshot - sorry it’s German but pictures say more than words…

Devices and Printer
HardwareID is what you need
Open regedit.exe in command prompt
Find the entry Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\VID_06A3&PID_0D06\5&521a615&1&8 (in your case the VID is different)
Unplug now and delete the VID_…that your AP is using but leave all others in there
Close regedit
restart computer
Plug in again after reboot
Device should report that it’s installed again
open regedit with the address it’s showing in the Devices and Printers… (might be the same)
look for EnhancedPowerManagementEnabled and set it to 1
close regedit
try now

1 Like