Saitek X52 Serious Problems Not played for weeks!

Have not played FS2020 for over 6 weeks, because of serious control problems with the Saitek X52! I have kept FS updated. Unable to land and steer the aircraft on the ground, the rudder just judders all over the place. No fault with the X52 as it works fine with AeroFly FS2 and other games/sims. I have posted this problem on the forums before, but no suggestions helped? In the control section I have tried all the settings I can think of. Changed from X52 to default, but this makes things worse. Nothing I can do, and I totally regret buying this buggy sim. So sick to death of FS2020 I will probably remove it from my PC!

Change your flight model to “modern” it’s probably on legacy.

I have x52 and it’s working fine

Thanks where do I find that setting? In controls section there are only 2 options Saitek X52 and Default, none of which cure the problem?

Settings - flight model and change to Modern.

You don’t need to go into control settings.

“Flight model” has its own tab

Leave your control settings at x52

X52 here and no problems either, so it does sound like the flight model being on legacy.

Flight model is already set to Modern. As said same problem whether set to X52 or Default. Weird thing is, that ‘take-off’ steering is straight on runway until air born , the rudder seems to work in the air but when I land, the rudder control is juddering ‘all over the place’ and sometimes end up crashing or stopping on the grass. This problem has been going on for such a long time, It seems there is no answer? I have reported this problem as a bug. This is the second time I have reported this on the forums and tech support. WHAT IS THE PROBLEM!? The X52 works fine with other sims/games so why NOT FS2020?

Are you using any other controller that my have an axis assigned to the rudder?

Thanks for all replies, there are NO other controllers connected, other than the keyboard and mouse. I have just tested the X52 in AeroFly FS2 and it works perfectly.

I have the X52 Pro and msfs setted to Legacy and it works well.
delete every commands assigned to the rudder, also in keyboard commands,
save & apply
assign the rudder to X52 axis you need ( Z ?)
before taxi make sure you have not hooked anything to the plane the gpu / fuel truck / …

Thank you Flavio, I will try that. I have already tried loads of things but appear not to find a solution. I have to go away from my PC now. So I will get back at a later time. I will let everyone know when I find a cure, but I am not very hopeful.


I had this rudder problems too and I had to disable all assistance. Please try this, put all dificults in hard and disable the ai assistance in the flight bar.


I have to concur with my esteemed colleague hehe , it sounds like something in your assistance is causing your issue.

After the su7 released the sim seemed to reset all assistance to easy level, so make sure to check everything in there as well…

That’s probably not the case with you, but I realized after update, and on a few occasion after crashes, game related not my plane…that the difficulty level was set on easy or beginner, and lots of setting were on automatic, and also automatic pilot was on…but this was probably me getting frustated and maybe I hit the shortcut…I have a X52 pro and of course I could not do much with it, until I did set back those settings to user control, I can’t remember how they label those setting, I think it goes from easy to hard or custom if you flip a few items off.

I was writing my answer and just saw that I am not alone on this…:slight_smile:

We forgot to tell him anytime you install / uninstall things from the content manager, its has a tendency to do it as well.

I agree with the others. I had the same problem right after SU7. After the update, all of my assistance was turned on.

Thanks for all replies. I have tried all of your suggestions, but unfortunately none have worked? I can ‘take-off’ straight from a runway, and ‘in-flight’ controls are OK. But soon as I land on a runway the steering goes ‘all over the place’, no control. I have reported this to MS FS as a bug, but not heard back. I do like flying around but I will have to forget about landings in FS. Have to practice my landings in AeroFly FS2 and other sims.

I have the Saitek X52 Pro with one of my pc, and it works fine. I mapped all the controls and switches from scratch, I also checked and adjusted the sensitivity of the primer flight controls, works fine . I use all the assistance controls in “hard”, I don’t use any AI for piloting in any way, or copilot. I never use the Legacy setting.

Good Morning ! Perhaps refreshing the Saitek Drivers might resolve this issue which is easily done using the Installation Software or using a Download from Saitek.
Kind Regards.

I have the same problem, following the last update. On the gound all looks good, start rolling and the aircraft peel off to the left. I am using spadnext. It seems it maybe an update problem which has caused some alterations in the set up. I will try the legacy/modern solution and also remove any keyboard settings for the rudder, One at a time obviously, but any help appreciated.
oh Merry Christmas and a Healthy New Year.