SALK Satellite scenery textures no longer visible. Only generic textures

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?
Made changes but now using the sim in normal mode

Brief description of the issue:
Satellite photo scenery no longer visible. Only generic textures.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
I tested it in South America region, not sure if applies everywhere else

PC specs for those who want to assist (if not entered in your profile)
PC Intel i5, 16G RAM, SSD, nVidia 1050Ti

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?
MS Store

Did you submit this to Zendesk? If so, what is your ticket #?

Yesterday everything worked fine so I don’t understand what really changed to cause this issue. Tried basic things like resetting cache file, changed photogrammetry option, restarted the sim, but no luck.

Thank you

Photogrammetry is a 3D rendering of a building based on the multiple angle of satellite imagery. It’s not the same as a satellite ground texture that you’re showing.

Make sure you turn on everything in your Data options. Especially the Bing Maps option.

Sorry about the wrong concepts. Well, I just started the sim to go and try data options again, and found it was solved before I did anything. Maybe was a MS server issue, couldn’t guess. Thks

It is happening today again. I didn’t change any options. Chose different servers, no solution. I will try starting the sim once more in a few hours. - Just created a ticket #104170

Third day in a row. The issue keeps going on after a clean reinstall of the sim.

I can’t get to find a solution a week later. Can anybody fly to SALK airport in Argentina and share a screenshot? Thks in advance.

Not sure if this is the right area, but here’s what Bing Maps is currently showing:

Data is ON.

1 Like

Thanks!! That’s the correct area. It seems Bing images are not showing on your sim too.
Ok then, I hope the devs take note of this. Thks again


i’m going to move this to #bugs-and-issues:scenery and close your other post since they’re duplicates.

1 Like

Today I checked the sim without changing setting and It worked OK, back to normal. Just updated to and everything looks OK so far.

Hi, the issue is back today. Just to mention it. I think it will be fixed anytime soon as happened before.

Did you check your Data setting again, namely on the Bing Maps switch?

Yes. Problem solved trying again the switch. Sometimes it does help, like this time.


Yeah, for some reason if you have some internet connection issues, the game just disables the Bing Maps data switch to off. But when your internet connection restores, it doesn’t switch it back on. So you need to keep manually checking and switching it back on again.

1 Like