San Juan Island run hangs up after first leg

I flew the first leg of the the San Juan Island run included with the 40th anniversary update. It tells me leg is competed. I click continue and it freezes and won’t ley me continue. I tried going back to main menu and then I return to the bush trip. I has me flying over the lake. I land on the lake again and head to the dock to drop off passengers. When I approach the dock it says leg completed again and puts me in the same situation. There doesn’t seem to be anyway to continue the mission. Any ideas?

Same here.

J’ai le même soucis.

The problem is the wrong arrival in W33, this water airport is out of reach. Your destination is Lake Cushman with airport LCMD., where you finish this leg 1. May be leg 2 is missing or it’s a mistake by Asobo determining the correct destination.
Conclusion: You can’t get 100% until this error is corrected.

1 Like

I have the same issue. Tried to land in W33 but got “Leaving the area” message, then the leg restarts.