Screen flickering, bad FPS even in world map

Hi everyone,

For months I have been experiencing very bad FPS, screen flickering. Even in world map, it takes time for the mouse to move around and select menus I want to enter.

SU9 came up and, magically, everything was working perfectly. I got to fly with Ultra settings on and photogrammetry with no issue. Everything was so smooth.

Then two days ago, another small update came up and everything went back the same as it was before.

I cannot fly anymore, having to fight with the mouse moving around so slow, screen flickering, it is just impossible.

Any idea ? Any help ? Thanks everyone.

PC specs and/or peripheral set up if relevant:

Alienware R17
|Processor|Intel(R) Core™ i7-8750H CPU @ 2.20GHz 2.21 GHz|
|Installed RAM|16.0 GB (15.9 GB usable)|
|System type|64-bit operating system, x64-based processor|

Hi @leptiotgerard, and welcome back to the forums! Sorry to see you are having performance issues.

Since you are looking for advice on your issue, I moved your post to the #self-service:install-performance-graphics category where issues like yours are being discussed. I also added a couple tags to help with searchability. Good luck in your quest.

1 Like

Hi @leptiotgerard

What possible solutions have you already tried?

Cheers Mark

Hi @Boobbuster007

I have tried turning off the online function, thinking it could be coming from a bad internet connection. Sometimes it helps a bit smoothing the flying experience, sometimes it doesn’t change anything.

I have tried changing a key in the registry following this video but no improvement at all : 30 Second Fix to Increase MSFS Performance | Smoother FPS & No Performance Degradation - YouTube

I have tried using aircraft selector to load the aircraft once in the game as some videos on YT said it could solve some FPS issues but nothing changed.

I have tried reducing graphisms to their minimums but didn’t change anything.

I have also removed addons and cleared the community folder but no improvement.

I am out of ideas! :smiley:

the ndu video… lol… dont trust all these youtube experts ( we have a big topic about this placebo ) :rofl:

What exactly mean “screen flickering” ?

You own a laptop… is it these one with the GTX 1070 Mobile Gpu ?.. have you checked that also these GPU is used for gaming ? ( and of course that all drivers are up2date )

It sounds weird because the other day you said it worked flawlessly and the day after it was rubbish.
Could be a bad connection but you already had ruled that out.

Very strange…

Maybe you are running too much background processes?