Screen frozen at 100% world loading


First fly launch after update, home screen is ok, aircraft selector screen is ok, so lets fly and … stuck at 100% for many minutes now …


The progress bar gradually goes to the end, then…nothing…

Please help!


Do you have anything at all left in your Community folder? I had the same issue. So I removed everything from there, and rebooted. After that it worked fine. I haven’t added anything back yet, so I don’t know for sure the offending mod, but I’ve heard from others that stuff to do with vegetation will cause this (I had a tree fix mod still present, so I’m hoping it was that).

I have the same issue - will try and report back.

1 Like

I’m also in the process of reactivating my favorite mods step by step. I found out that the popular Tree Mod is broken in SU5 and should be avoided in my opinion. When I have it activated the loading of the scene never ended with no Fly-Button in the end.

Are you referring to the Bijan seasons mod? I’m having the same issue as the OP and I have no mods in my community folder but I did get the seasons mod from the Marketplace a while ago.

No, I’m referring to the ‘Tree_Distance_Draw_Fix’.

1 Like

pretty similar issue for me, but I cant get past the first screen, it gets stuck at about 70%
I’ve cleared my community folder, no interfering mods and am still getting issues

You should be able to temporarily uninstall your seasons mod in the content manager to find out whether this one is the problem.

1 Like

Yes, testing 1 thing at a time. Just deleted my content.xml to see if that will help.

Hi Cherry, I think that is a different issue. We are taking about the flight loading screen, not the initial loading into the sim screen.


omg, that was in my case thanks. definitely broken

1 Like

I uninstalled all my Marketplace mods and got right in. I wouldn’t doubt it’s the seasons mod. I’ll be adding them back today to see what the culprit was.


Yep, removing everything from the COMMUNITY folder fixed it for me!

I was able to get in to my flight. All I did was delete the ad on scenery, including the airport textures and the fall and spring and summer stuff

I was able to keep everything in my community folder. I did have to exit out of the game and go back into the game, otherwise the airport runways were bright pink

Yes, I think it’s the seasons mod

Appears the Seattle/Chicago landmarks by Drzewiecki are causing it too but still testing around. These are all marketplace mods, my community folder is empty atm.

When I had the seasons mod installed by itself it worked, but when I added the landmarks it didn’t and had to take the landmarks and seasons out to get it back to working.

I’m having the same issue. I’ve emptied my community folder and still have the same issue.

1 Like

Did you buy any mods through the Marketplace? If so, check your Content Manager under profile and remove any of those mods. Then close the sim, delete your content.xml file and try again.