SDK Latest version does not allow changing of properties

Anyone else notice that trying to change any objects’ properties in scenery using the latest SDK doesn’t work unless you right click the object, untick properties and then click properties again. This allows editing its properties except for being able to drag a material like concrete etc over the surface. This simply cannot be altered that I’ve discovered

I found many bugs in the latest Dev Mode update I submitted to Zendesk, but I did not notice this one, I will try and see.

Also, I was honestly puzzled with the complex usability that is being implemented in the Dev Mode. As a scenery developer / user of Dev Mode and a UI/UX designer for a living I find the usability choices a little strange and somehow complicated and sometimes obscure.

In the past 4 years, I used WED (World Editor) for XPlane and although it’s an old school 2D external tool, it has straight forward intuitive usability that I wish the Dev Mode in MSFS could have (grouping, renaming, etc etc). I also sent feedback about these on Zendesk…


I think that I will log it as well but first I’ll try an uninstall and reinstall of it

1 Like

And there I was thinking it was just me with the problem!

So I uninstalled and reinstalled the SDK and the problem remains except now to edit an object I have to right click it to get the properties window to activate for it. It still requires me to “hover” over an element in the properties window to accept input. Changing surfaces requires me to select the material first then right click the object and then I can click the material property. It then cycles between the new and previous value.
It’s a pain really-there’s something wrong and slows me down having to right click everything to edit it. Haven’t logged it yet. Seems like it only affects a few of us? So they’ll probably do nothing but I guess they at least would know of the issue

I tried going back a version, but the problem still exists, which may point to the simulator and not the SDK being the problem.

Also, unlike before when you selected a parking space to add a jet way, you don’t get the drop down below the parking space in the scenery editor to show the jet way belongs to the parking space. Though that could be because I have drawn most of the airport in ADE 1st.

I’m going to draw a test airport using the sdk only to see if that makes a difference.

Definitely nothing to do with ADE RE: Jetways. Looks like things are pointing to the sim update as opposed to the sdk update. :frowning:

Did you ever get a fix for this? My system has just started having issued with properties. eg, add a runway, then it is hit and miss if I can access properties. usually, any selection on the properties panel causes a blank properties panel.

For me it sort of self-healed. It now just works and I didn’t alter anything. i am able to select an object and the property is editable

yeah, I know what you mean. These sorts of issues just appear, and then, maybe vanish. Mine appeared yesterday, long after the MSFS and SDK updates. I have built several bush strips with never a sign of the ‘properties’ issue. Anyway, hopefully, it also eventually goes.
I removed and reinstalled the SDK, but still the same.
I am starting to get used to always right click one or more times before left click opens up the Properties panel.
I am saving scenery and building more often now. if it stops completely.

I can’t modify a project before the update: for example I change the position of a builder, I remove the solid line from a taxiway, when I do the BUILD PACKAGE I get a RED error (packagebuildlog_G AddKey wrong key: PREPARE) that I didn’t have before and doing export of the project, then I find myself that has not made any changes.
all the things I did before were successful updating the exported mod, now the project does not want to take into account the changes.
have the roots of the package directories changed? I am speechless.
Thanks for your help

Try deleting the _packageint folder and all its contents for that project before you start the sim. Then go into Dev mode and load the project (not the (BGL) then click build. This should recompile all your added models and recreate that folder. It holds all the metadata and time stamps and it can get confused. Now you should have a clean build, close the project and restart the sim. Your project should be good to edit again and have the missing model and accept edits etc

1 Like

Thank you so much for your answer. I tried to delete as you said but it did not solve the problem, I make the changes on the project but probably it does not make the correct BUILD because it does not update the project with the change. I also see this in the .xml file in the project’s “data” directory.
This DevMod SDK seems crazy. I will wait for some updates, in the meantime I try to build a non-ASOBO new airport to see what happens.
I wouldn’t want it to depend on VISUAL STUDIO installation …
I would have to reinstall the SIM with the slow download of a snail (excuse me the snails).
Thanks again, if you have any other ideas I would be really happy.

If you like I could send you the project, so see if you can for example make some changes to what you want and see if it saves it.
Thank you
my e-mail to contact

Hi. Check your email :slight_smile:

I found the reason: I forgot to save the scenario, which is trivial but very important.
Thanks so much

For some reason, the SDK now allows changes to properties without right clicks!! I am still using ver 10. I think the constant ‘improvements’ to the SDK, make the whole SDK stability very questionable, but one of those things.

I’ve had the same problem forever. But I think I solved it. I unplugged my controller from the USB port. No more problems with ticking and unticking. But now I can’t use my controller. :thinking:

I can avoid the unplugging of the controller by making a blank profile, and using that when adjusting properties. Also when switching objects, with the profile editor open, left-click on the top of the window to activate the properties of that selected object.