SDK Recently Started CTD with Saving

I’m hoping someone can help me. Recently the SDK is having a CTD anytime I try and click the save project or build button when creating scenery. I have created airports as recent as two weeks ago and have never had issues like this. At this point I have a completely empty Community folder, Just completely reinstalled the sim and the CTD still happens as soon as try and save a newly created project. I would truly appreciate any advice, I am incredibly frustrated at this point.

Is this with the latest sdk update?

Currently using the latest version of the SDK. I noticed this issue right after the sim update but prior to the new SDK coming out. Both the sim and the SDK are up to date. I sure hope I’m not the only one with this issue, I’m lost on what to do next at this point.

Yep, I’m getting CTDs with a lot of things in Dev mode, mainly when saving files but also with small things like changing values on objects and especially with visual effects

1 Like

SDK 0.13 causes CTDs upon trying to save after adding a runway, that’s for sure. Telling Zendesk and reverting to 0.12.

Hi, today 25/06, I had a small update when started MSFS, I also took the opportunity to update with the SDK v0.13, but when I tried to open my project I have a Crash To Desktop.
I worked with the SDK version 0.12 yesterday and it worked perfectly well, but today with the v0.13 I can’t open my projects anymore for modification because of the CTD, as soon as I select my file and clic on “Open”, everything is closing.

In the meantime, my previous projects which are already completed are still working (It’s just scenery and missing airport ICAO on Reunion Island, mainly helidap)

I’ve uninstalled SDK v0.13 and re-installed SKD v0.12, But now I have the same problem of crash to desktop.
Can somebody advice me? Do you have the same probleme?

Thanks Everyone.

Sure the ctd when opening is in the sdk notes as being fixed for next build in yesterdays development update.

I’m getting CTD’s with 0.14 after building an airport, or on closing a project and attempting to go back to the main menu.

I’m also getting issues with the Scenery Editor:

  1. Not unmounting the existing airport, so all the objects are there so when you move one, the original stays where it was
  2. I haven’t figured out a common reason, but, occasionally, all the textures and objects disappear, usually after a Build. It could be related to the textures “flashing” every so often that’s been going on since December I think.

I wonder if it’s related to issues I’ve been having outside of Dev Mode when trying to fly in windowed mode? I get lots of time skipping in windowed mode, the screen will flash and my plane will jump back a second in time (like). I don’t get this in full screen mode. I’m playing on a 4K monitor with a RTX2070 Super. Of course I always develop in windowed mode (it used to crash if I didn’t, haha).

For one of my airports, process is:

  1. Build Airport
  2. Objects disappear
  3. Close Project
  4. Esc, Select Main Menu
  5. Yes, exist to Main Menu
  6. CTD

Edit 2: The other difference that I noticed that this started after…
I realized today that they now expect Airport Services and Living World Config files to be in SPB format instead of XML, so I I’ve been converting each of my airports and tidying up all my AS/LWC stuff across my airports today. I didn’t have this issue with objects disappearing and then CTD on exit before I did this.
Could be just a coincidence, but I thought I’d note it. I just converted another airport to it, and, as soon as I did, bam, it’s showing the same response.

Edit 3: Then again, it didn’t CTD on exit this time… sigh.

Edit 4: ahh, there we go… this time it did… And I made a change to the Services.xml file.