Server Disconnect with cache on and Manual Cache Greyed Out

Hi fellow pilots, after trying to find help on the forum without success, I’m posting in hope to receive help.

1-When I cache is on, there is server disconnect every 1 to 10 min non stop. When I turn it off, then everything is fine on the server side.

2-I don’t know if the issue is related, but since I reinstalled the sim 2 weeks ago*, I cannot create any manual cache and I’ve tried everything, read as much as I could and no suggestions in other pilots post where working.

I’m lost on what can cause that. I never experience that before.

Thank you to the community. Be safe.

:love_you_gesture: :small_airplane:

*Warning : if you don’t already know, never never do a scan for file integrity on steam for MSGS, it as been reported that it just delete your MSFS installation. I didn’t know so that’s why I had to reinstall…

Same here. After a boot drive corruption, I did a complete OS install and msfs 2020. I no longer can enable manual cache. I was told a patch was on its way.

1 Like

Thank you to have taken the time to answer me. Is it me, or I didn’t see many other talking about this issue. Please let me know if you find a solution or any other kind of info. I will do the same.

Happy holidays.

: )

im sorry if i may have caused some confusion. My issue is no matter what i do, manual cach can be created. But when i go to a map location, everythings greyed our. Even though i can see my cache folder.

Same for me + the aforementioned thing concerning constant disconnect when my cache is on. Never had those issues before.

I decided today I wanted to create a manual cache since I tend to stick to the same areas of flying. The options on the right are greyed out - I see a path for my cache, but the size is zero and I can’t change it.

Founde something that mentioned removing the cache, so I went to the place on the path and looked for the (name).ccc file which did not exist. I’m wondering if I create that file if it’ll let me modify it? I have no idea what the structure of the file is though.

Tried wiping out my rolling cache, re-creating that, restarting MSFS, but neither did anything for the manual cache.

1 Like

Wow, you have exactly the same issue and thank you for your answers. I also have tried to reinstall and I still have the same issue. I did all the same step as you.

Little question, did you succeed on finding more info on this. I created this thread because I didn’t found anyone talking about this in the forum.

I would suspect we are not the only one, but maybe the manual cache is not the most popular feature that virtual pilots use, idk.

Anyway, if either one of us find a solution, let’s share it to the other.


1 Like

I found that the manual cache is only for the photogrametry stuff - not the scenery, but the buildings. Since the area I fly in has 0 photogrametry (Hawai’i), it wouldn’t benefit me to have it cached. The rolling cache though is scenery from what I read.

Same here, I started with msfs around christmas, manual cache never worked. Mostly the whole option is greyed out, sometimes I can access it but all options on the satellite map background are greyed out.
If I copy and rename the rolling cache .ccc file it is possible to start a download of an area but I cannot change the size of the cache and downloading causes a crash. So that’s no workaround.
Since my internet connection is fairly slow I really would need the manual cache! If anyone has a solution, please post it:-)

I’d been having issues recently - not being able to create a manual cache as has many other people it would seem!

So after not being able to find a fix, I started to play around to see what I could do and whaddya know… I fixed it!!!

The problem arises when the manualcahe.ccc file is previously deleted.


Make sure the sim isn’t running.

Create a rolling cache.

Locate the file generated by that rolling cache (ROLLINGCACHE.CCC)

Copy it and paste it into:

C:\Users[your username]\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

Once copied, rename the file to “MANUALCACHE.CCC”

Reboot- SORTED :smiley: