Settings wont save and achievement progress reset

This is a WinStore install (not steam)
Last night before the UK update I fired up FS and was greeted with the Out Of Box Experience. I hadn’t played in a few days and thought it was odd. After completing the setup I noticed that all of my input assignments were reset to default but I was able to select the saved profiles. Then I noticed all of my uncompleted achievement tracking was reset to 0% (weekly challenge, airports landed, etc.). My profile stats were all reset (distance traveled etc.)
After saving the settings, I restarted the game to be greeted again with OOBE and no settings are being saved.

I was hoping todays update would fix the issue but no luck same thing none of my settings are getting saved.

The one thing I did notice is that right before I launched the game I took an update to “Gaming Services” to build 2.50.12001.0. I think this might be the culprit but not sure. Anyone run into this before and know hot to fix it?

Still no luck. I’ve uninstalled and reinstalled the gaming service and tried resetting the installation. The only other thing to try is a full uninstall of Flight Sim which I really don’t want to do.

I’m also getting OOBE every time I launch the game. I’ve tried all the standard uninstall/reinstall, log out back in type solutions that I can think of.

Yes still nothing working for me either I did a full uninstall and re-install no luck. I’m not seeing anything in eventvewer entries that look wrong either. Nothing change for me either one day it was working fine the next it wasn’t

The only thing I have going on is that I cant take (KB4601319) Update for 20h2 because it doesn’t know my hardware.

Ryzen 5900X with Gigabyte X570 master

Hi all.
I have the exact same problem.
Everytime I start MSFS I am presented with the default out of the box questions.
Everything is set to default and I have to configure everything again like setting the correct language, graphic options etc.
Did anyone of you find a solution? For me it also started out of the sudden. One day it was working, the next day I have this problem.




1 Like

Is it this you are all having:
Starting FS: Please insert disc, then I restart FS, asks for settings as in first install? - Bugs & Issues / Miscellaneous - Microsoft Flight Simulator Forums

It started today for me…

Yes looks like the same issue. I filed a Zendesk help ticket 93789 but not a bug.

I’m also have this issue. Every time I start the game I have to run through the basic setup (accessibility, graphics, data and controls). I even tried running the game as administrator but it made no difference.

1 Like

Me too! annoying as it worked fine after the uk update, today, no settings saved and only a few details saved in the logbook

Someone posted a temporary work around here: UI broken and reset user settings - Bugs & Issues / Performance, Graphics & CTDs - Microsoft Flight Simulator Forums

Like I initially suspected the updated Gaming Service is the cause. Unfortunately all of my stats leading up to the issue are lost :frowning:

Mine just started doing this today as well. Before all settings were saved and now every time I launch the game I have to redo everything and get the OOBE like I just installed it for the first time. Quite annoying having to redo all my flight system controls. What’s up with this Asobo?

This is not Asobo’s doing, it’s Microsoft’s doing. Microsoft pushed a update to Gaming Services, like DarkClown said, and that is what is causing the issue. The GS bug reported (UI Broken and Reset User Settings) obviously ties in pretty heavily with the sim and for some reason, forces the sim to behave in a strange way, resetting all previously saved settings & not communicating profile requests properly.

I’ve read on other forums that other games are having similar issues, where they’re reliant somewhat on Microsoft’s Xbox gaming servers and the Gaming Services. It turns out that it’s happened before, where gaming communities have had issues because of Gaming Services receiving a bugged patch.

Hopefully Microsoft should push out a hotfix patch for GS sometime Monday, as I’ve noticed that it can get patched 2-4 times a week.

Yeah, saw in the Microsoft Store that the gaming service was updated yesterday and read in the other thread about it. Hopefully it gets sorted out soon.

Right now your options are to either wait for the fix or side load Gaming Services build 2.50.5005.0.

@ cooljay113 You don’t have to completely re-do your bindings you just need to select the saved profile

1 Like