Shift + P Won’t work

Hi Guys, I’m used to using Shift + P in FSX and P3d, so I was excited to see people using is int MSFS. Sometimes, you get spawned at a location where there is no push back and no way forward (without causing a crash).

However … I have never been able to get Shift + P to work. What am I doing wrong?

Left shift and p works for me. Right shift and P does not.


I thought of that and tried the other Shift key but still no luck.

I’ve found it sporadic too. I did find that one time if I held shift+p the push took place until I released it.

I’ve also found that shift+p cancels push back if it’s already called.

I’ve occasionally had it not work for me as well. It seems to work like 90% of the time.

But now I use this little tool. it’s free, works every time, and even lets you issue the steer left / right commands to pushback.


Have you tried assigning it for example to another key or a joystick button? Just in case there’s some sort of conflict.

It actually does conflict with the pause key.
I re-assigned it and it works great.

in my situation it’s work 100% where not pusher vehicle, but if it present it can glitch, some time it can be in hangar and you just don’t see it, and yes works only left shift+p, sure can binding other buttons and keys, some place have the vehicle floating in air but this may be mod’s problem

For some reason on my keyboard numpad toggles keybinds… Try hitting numpad and retry. Anyone else?

There is a general problem that shft/ctrl/alt plus a key also often triggers the key by itself (if assigned), sometimes without triggering the intended action.

There are other cases where this may cause a problem - see Major Flaw in Keyboard Shortcuts

Thanks, I hadn’t seen that topic.
It certainly explains a lot!