Significantly longer load times after 1.34.10, often followed by CTD

I have done mostly everything suggested in the MSFS posts regarding eleviating the long load problem but to no avail. I moved the Community folder to different drives and folders and reloaded the entire sim several times. At first it loads normally but after about three loading’s it starts to slow down getting progressively worse each time. I have a service ticket into MSFS and they added it to the plethora of others who are experiencing this same problem. It is not an isolated event, it apparently effects just about everybody at some time or another. Their response is that they are working on it and bug fixes will be included in future updated. So now we wait… SMH, this is very disappointing especially when many of us have invested in cockpits with adanced avionics.

I did reboot the sim (quit to desktop and stat again) and the consecutive load, with exactly the same MP and Community add-ons took 4 minutes and 21 seconds.

Did the same again and I got 4 minutes and 12 seconds.

Pretty consistent behavior in my case, so no progressive slowdown observed by @LordPC6781. Will also try after complete computer reboot.

EDIT: After full PC reboot the first try was 5 minutes and 18 seconds, which is still good compared to previous SU13 beta builds.

The second consecutive try (without PC reboot) was 4 minutes and 25 seconds. So back to these “stabilized” values.

Now I’m going to test another sim and add-ons aspects. :slight_smile:

I just loaded the sim on this same PC and this time it was 02:34; even faster than the 02:48 from yesterday evening and faster than the last load that was 03:08.

Obviously, there must be a bit of a tolerance window for loading times. Essentially, I’m thrilled to see these times having come down and a consistency maintained across multiple quit and load sessions.

1 Like

Did another 2 rounds after the full PC reboot - see my EDIT above. My “average” stabilized time is 4 minutes and 20-something seconds. Good enough to conclude that the issue is fixed, at least on my machine.

1 Like

Just got some other update. Downloaded a few packages and updated the release notes. Loaded to main menu in about 3:45 (with 3-4 items in EXE.XML like GSX, A&O, etc.) and then took another 35 secs to load up the Fenix on the runway at IniBuilds KLAX. 122 MP and Community addons were enabled. Can’t think of a more brutal plane or place to start it for testing.

Will test a few more airport / aircraft combinations but think I’m in business.

2 Likes

Just one quick circuit on asobo KMCO with default C152:

  • load from map to flight (ready to flight) was pretty quick: 43 seconds
  • no CTD at all
  • everything was smooth and nice from startup, through taxi, takeoff, in flight / turns, to the butter-soft “on stall horn” landing.

IMO very similar to SU12 latest release build.

1 Like

In the spirit of thoroughness, I just verified that the previously disabled MP work properly after this fix. No problem. About to start a flight from FSDT KORD for the first time in weeks!

Cloudy in Chicago but my Delta PMDG 737 is happily headed over to 28R for departure!

1 Like

I’m really curious about what they broke and then fixed again, what in reality caused these long-loading and CTDs issues. I have a strong feeling of some of these “stupid” / “oops, we forgot (un)comment this before the release…” error. Might be somehow helpful to know for future… :wink:

4 Likes

After all this, I’d just love to know what the problem was. I know they don’t usually share that kind of thing (and, we might not understand it) but would be cool if they shared some more details.

4 Likes

Maybe they should give it a try… :slight_smile: Some of us are for sure more experienced about software development and testing than others. Specifically me, I have 25+ years of software development, testing and architecture experience, so maybe our “expertise” might also be helpful during these betatesting seances. :wink:

But all this of course depends on them, especially how deep are they planning to really involve us and how much they are willing / able / allowed to “honestly uncover”.

First and foremost, we are still primarily “users of their product”.

Whatever they broke…please don’t do this again! :grinning:

2 Likes

After reading the positive experiences, I timed my current baseline load time into the sim; then re-enrolled in the Beta and updated my sim; then restarted my PC and measured again. Actually I measured a bunch of things including first and subsequent loads into the PMDG 737-800 and -700, but the bottom line is that for me and my content, the current build seems to have resolved the problem. Load times were within 2 seconds of each other with the same content (extensive Marketplace and Community content combined).

3 Likes

Has anyone tested latest build with more than 1024 addon folders in total? It´s just to be sure that the checking for updates loop issue has not returned. The main reason for the increased loading times after SU12 + AAU2 was the introduction of the checking for updates loop fix. If now that still works and also game loads faster we could be sure that the loading time fix did not break the previous checking for updates loop fix.

Cheers

Results encouraging on 1.34.14.0 so far, but I’m reinstalling the whole shebang (all the world updates and any remaining marketplace airports) to confirm. :smiley:

[Updated:]

  • current load with current stripped-down set: 2m04s
  • first load with marketplace stuff reinstalled that was previously still loading slow (48 packages): 2m48s
  • first load with all previously deleted world updates and airports reinstalled: 4m20s
  • second load: 3m17s

I can consider this sorted from my end. :smiley:

7 Likes

So what’s interesting for me is I’ve never had this issue until this morning. I shut down the game last night with the A310 being the last aircraft used. I went to start up this morning and it has been about 30 minutes and I’m stuck at 100% loaded on the progress bar with one CPU core maxed out.

I’ve never had issues loading before so this is new for me. Not sure if it’s the A310 doing it or whether it’s safe to force close and try again. It’s clearly trying to process something through.

I’m running all-SSD and usual load times around 5 minutes give or take.

EDIT:

This is likely a red herring. I followed a tip from google and shut off my internet connection and it loaded immediately. I suspect this is a complete coincidence.

This issue is solved for me as well. Went initially to over 7 min loading time, but am now back to 4min 40s after reboot with all addons enabled. Subsequent reload to menu takes 2min 50s, which is perfect for me.

[Moderator edit: please do not tag the Community Managers] thanks for taking this seriously and getting it fixed!

1 Like

Screenshot 2023-09-07 080649

c:\ Windows - Samsung 980pro 2tb - PCIE 4.0
d:\MSFS - Samsung 970 EVO Plus 2TB - PCIe 3.0
e:\ Additional Storage CT1000PP5SSD8

1 Like

I’d say the issue is solved ( for me).
I joined the Beta again and my loading times, including “Community” went from >12 mins to around
5-6 mins average. MSFS runs about the same as prior the Beta. Happy Camper

Oliver

1 Like

I’m not on beta and the load times in last 3 weeks have been a joke around 9 minutes on xbox.

1 Like

After being in every beta for 18 months I held off on this one because of the early problem reports and I couldn’t risk an unusable sim. With the good reports I’ve now switched to beta on my PC.

tl;dr my sim load times on beta are slightly improved in all scenarios compared to current general release. I have a lot of marketplace and community folder content.

I have detailed results I will post later, it’s taken an entire evening to accurately measure many before and after scenarios. I haven’t actually had chance to start any flights so no feedback on that yet.

1 Like