Sim takes over 8 minutes to start, even on a fresh install, no community folder etc

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

My sim always seems to take ages to start up. With community folder it’s around 10 minutes, On a completely fresh install (no community folder) it still takes 8 minutes 30 seconds.

Provide Screenshot(s)/video(s) of the issue encountered:

loading bar always stuck here for around 5 minutes long;

finally done;

PC practically idle while waiting;

Detailed steps to reproduce the issue encountered:

I’ve been having this issue for about 2 months now. So far I’ve tried; Completely uninstalling (both just the MSFS install, and even completely wiping the Steam install as well.
When I turn off online services, the sim loads up really fast. So it looks like something just gets stuck checking online for around 6 minutes, after which it times out, and loads the sim. The loading bar is stuck at that exact position from the screenshot for the full duration. It used to take around 3 minutes before this issue started.

So if anyone in the community has any idea what else I can try, I’d be interested to hear it.

PC specs and/or peripheral set up if relevant:

Windows 10, 5800X, 32GB DDR4 3600MHz CL16, RTX3080, Steam install

Build Version # when you first started experiencing this issue:

somewhere between SU9 and SU10 I think?

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Update; Tried starting the sim up while forcing safe mode (so neither community folder nor marketplace content gets loaded).

  • checking for updates takes 1:30 from double-clicking the MSFS icon.
  • a minute later (so at 2:30), the loading bar gets stuck at the same spot (around 80%)
  • total start up time in Safe Mode; 7:35 (so around 5:15 stuck at the same spot at the loading bar)

Have you tried some simple things like resetting your router and/or closing down any background tasks?

yes, I tried all the obvious stuff before spending 14 hours reinstalling :wink:

1 Like

you’re not the only one apparently

No worries I do sometime wonder if people do actually remember to try the basics and not just assume it’s a sim problem. I would probably go the whole hog and get my pc in a clean boot state and perhaps investigate other aspects of my internet connection. Of course you may well have tried all of these as well!
Hope you get to the bottom of it and resolve the issue. :+1:

Edit: actually, it just hit me that you said 14 hours to reinstall… I would definitely be looking more towards some kind of connection/internet issue. :thinking:

1 Like

nah, I have a 75 Mbps connection, averaged about 50 during the main download (120GB these days for the 40th anniversary edition, so roughly 22GB/hour, so that’s over 6 hours there). Then there was an additional 60GB from the content manager, which is always slower, that was averaging 30 Mbps, so that’s another 4.5 hours, and some intermittent slowdowns in between due to who knows what and extracting, and you end up with 12-14 hours.

Hey Mort, try this if you could. If you’re hardwired to router and have WiFi on MB, dis-connect Ethernet cable and turn on WiFi. Try connecting that way. I had several issues concerning connecting with the sim a little while back. I hope this works for you.
Take care.

All - It must be server load. Flew last evening, lost online connection several times during my flight, do not have graphics turned higher than medium. As have stated, wish more of this sim was local control, instead of being connected. X Plane does it, you actually load the scenery files you want to fly in, and that puts them on local drive. Before someone says it would take gobs of storage. The total X-Plane 12 file base is: 62.5 GB of space, and I have USA, Northern Europe, pacific islands, Mediterranean area loaded, may be little more. NO, XP is not as beautiful as MSFS, but again, ad-nauseum, what can you see clearly at FL350. And yes, I get it, some people fly slow and low to see stuff. Again, slow and low, you are not going far, the data could be local.

No, it’s entirely unrelated to server load. I’ve had this issue for about 2 months, it always happens, regardless of the time of day, day of week, week of the month. Please read the bug being discussed. This is not about ‘connection lost’ messages. There are separate bug report threads for you to add your feedback to about those issues.

I’ll give that a try tomorrow, thanks for the suggestion.

I’ve tried with a VPN (no change), and using cloudflare as DNS (for both IPv4 and IPv6), no change.

Shut off IPV6 and see if it helps with downloading and loading with msfs, I have mine off and have fixed all my problems with weather, and hanging or looping downloads.

I have been having this problem in recent days exactly as OP describes. Hangs at 80% loading with no CPU, disk or activity & finally loads normally after about ten minutes.

Then I found this post Stopped OVRSevice causes MSFS loading to hang for 3 minutes

I checked and sure enough my OVRservice was stopped. I restarted the service and loading times are back to normal. Worth looking into if you have an Oculus. (I only dabble with it occasionally for MSFS hence the reason for the service being stopped)


Holy ■■■■, that worked!

I have no idea how, or why, or what is going on. The headset isn’t even connected.

Well, it solved the issue, I’ll let Zendesk know, maybe they can make heads or tails from it.


just a word of warning to anyone thinking of following this advice… there’s a good reason you shouldn’t do this on modern Windows operating systems, none of the testing of the OS has ever been done with this disabled, and there are key parts that will be worse if you do. I’m ok if you choose to do it, but remember other weirdness may arise, just be aware and ready to put it back on if you see any other weird stuff happen.

Hmmm, just checked, that service is NOT running on my system. Assume you have to have VR equipment connected and installed for it to be initiated. But I was not affected, nice information to have in case I ever do.

No, the weird thing is; I do have a Quest2 headset, but even with the headset not connected, I need to have the Oculus software running for the sim to start in a normal timeframe.