Sim Update 3: 1GB download at MS Store but no update ingame

Hi guys,

I just downloaded the 1GB from the MS Store but after starting the game I had no additional downloads. In the main menu the marketplace is greyed out and when trying to start a flight I always get a CTD.

My ingame account looks like this:

It does not make a difference if I empty the community folder.

Any suggestions? What am I missing here to get the whole update?

What should I do if the update doesn’t start automatically?

  1. Check Windows 10 for updates. If any, restart your PC
  2. Manually check MS Store for Updates
  3. Then update MSFS

If this still doesn’t work, the best course of action is to log out, restart your computer, and log back in.

What should I do if the update seems to stall or stop downloading?

The first thing to try is closing down MSFS and restarting it. The downloading should start again once MSFS is restarted. If there are problems with a particular file downloading repeatedly (on a loop) then exit MSFS and browse to the download location where the file is downloading to using windows explorer. Delete the offending file (if it is listed) or the latest downloaded file in that folder and then restart MSFS. The patch should continue as normal. (Note only delete files do not delete folders!)

Also, check Xbox gaming app for updates / try launching from that.

I logged in and out a thousand times
I restarted Windows a thousand times
I updated Windows to the most current version
I repaired MSFS

I still cannot get the ingame update. The game starts right to the main menu and that’s it. It seems as if MSFS is looking to get a connection to the server (which is set to AUTOMATIC) but doesn’t get one.
I do not have problems to connect to the MS Store via the browser. So my account seems to be okay.

Xbox app up to date? Try launching MSFS through that. If that doesn’t work, I’m as lost as you are.

I have the same problem. I have tried the same things still not working :frowning:

Have you searched within the discussion post for the update (the pinned thread)? There are over 900 replies with people having different issues.

That’s where I found the suggestion to launch from the Xbox app. I would suggest checking it out:

I tried the XBOX app without luck.
I even uninstalled MSFS. During the first launch after reinstall it says that the servers are currently not available.

So how to reinstall or update MSFS now?