Sim Update 5 mouse input moves ok but cannot interact (other threads closed)

Like other posters, Sim Update 5 ( has broken the MSFS mouse support on my up-to-date Windows/Nvidia PC, empty Community folder.

I think it’s unhelpful closing the thread so quickly as ‘solved’ when other people are going to hit the same issue and it might not be (hence this new thread).


the mouse moves around as normal, blue highlights appear on clickable in-cockpit objects, clicking or dragging the mouse has no effect.

If it’s a clue, if I hover the mouse over the throttle in the Cessna 152, the tooltip says “Hold [?] to lock”.

It seems possible the mouse profile is broken, I’m pretty sure it used to say “Default Profile” but now it says “Mouse Profile”, but if I change the Mouse option to “Default Profile” MSFS crashes to desktop.

For other readers the ‘Legacy’ mode for the mouse is under “General Options” - “Accessibility” - “User Interface” - “Cockpit Interaction System”

If I change the “Cockpit Interaction System” to “Legacy” it IS possible to interact with the cockpit elements as before (with new icons/tooltips), but still if I try and change the mouse profile to “Default” a CTD occurs. So after a couple of hours I have managed to get a working plane but I would not consider this ‘solved’.

Possibly another clue is the in-flight pop up menu (the one with ‘Weather’ etc on it that appears when you move the mouse near the top of the screen when flying) has a ‘yoke’ icon labelled ‘Basic Controls’ which has a new (!) on it but on clicking it a translucent page labelled “BASIC CONTROLS” appears but apart from a couple of empty select boxes near the top this page is blank.

it’s an odd change isn’t it - and those giant tooltip popups :man_facepalming:

Wow this was painful - it was definitely my ‘Mouse Profile’ that was borked. Via the ‘Controls Options’ - ‘MOUSE’ then bottom of the screen (next to “[Esc] Go Back”) “PRESET MANAGER” you can delete mouse profiles or create new ones.

The only thing that worked* for me was to create a new mouse profile and then configure that from scratch:

zoom = mouse wheel up,
zoom reset = mouse wheel down
view yaw axis = right-click + drag right (VERY difficult to input)
view pitch axis = right-click + drag up (VERY difficult to input)

Then saved this new mouse profile and it’s usable in legacy mode.
At least I’m back up and flying, but the following issues remain:

  • The new/non-legacy “Cockpit Interaction System” is still unavailable

  • MSFS still crashed to desktop if I select the ‘Default’ mouse profile

  • MSFS CTD’s if I attempt the following:

  1. create a new mouse profile
  2. use the Preset Manager to revert that profile to ‘Default Settings’
  3. save the profile (MSFS CTD’s at this point).

I suspect this would have been less grief if the device profiles were accessible as a simple file somewhere rather than the current complex inaccessible arrangement.

1 Like

Before the update, my alienware 610M mouse showed up in the controls menu and used to work perfectly and I could assign the side buttons to Pause and Active Pause. Now I see a standard mouse without the capability to assign any side buttons. Some functions work , some don not. Advice?

Using mouse as legacy but did not change the profile in controls menu. Seems to work as usual except some items mouse refuses to recognize. Just stays in “pointer” mode without reacting to button presses. This occurs at certain parts of CJ4 latest mod and won’t allow me to kill the yokes in Cessna models. Is this a mouse issue? Or has ASOBO just changed the whole way the screens respond to mouse input?

Please ASOBO, give us back our simulator. Make a separate dumbed down version for the kids if you need that market, but leave this simulator for the serious aviators like you promised! Undo the mess you have made. The bad publicity you are starting to receive on this issue will not help your marketing efforts!!!


I set the cockpit interaction system to legacy and it didn’t work. The instrument don’t work if I hold the right button of my mouse to move the camera inside the cockpit. This by far was the worst update from Asobo

1 Like

Try mid-click (mouse wheel button)

1 Like

I had exactly this.

What fixed that particular issue was to go into Controls Options / Mouse, use the Preset Manager button on the bottom of the page to create a NEW (blank) mouse profile, and set the Camera / Cockpit settings in that.

The drag-to-move camera settings are called something like View Yaw and View Pitch.

Assuming you want ‘right-click-drag’ to move the view around, you have to do exactly that in the ‘control select box’ where you are changing the setting. MSFS strangely gives a warning message NOT to use right-click-drag but I think that’s a bug.

Trust me getting ONLY (right click)+(Axis X) into the Axis Yaw setting is really hard because it’s almost impossible to move the mouse in ONE axis so you get (right-click)+(Axis X)+(Axis Y) on your first 50 attempts. Same for view pitch axis setting. Tip: use very short movements of the mouse.

In comparison ‘Scroll Up’ for Zoom and ‘Scroll Down’ for Zoom Reset is easy.

1 Like

Thank you that…i was struggling to find out why this was happening

Thanks for your reply, but I still having troubles with this. Can you please share your settings (upload a screenshot of your mouse config) please?

Thank you!

here y’go - I only needed these 4 settings to look around the cockpit again. When you click the ‘box’ you want to update, the pop-up dialog has a box with “START SCANNING” written in it - you click in there with the mouse, then right-click-drag in there with the mouse, then let go of the right button on the mouse without moving the mouse. In a nutshell it is a real pain to get that right-click+AxisX in there, (because you’re always getting [right-click]+[AxisX]+[AxisY]).

If anyone knows how to EDIT the box, i.e. get [right-click]+[AxisX]+[AxisY] then edit out the [AxisY], please post in here - that would have saved me 20+ attempts.

Thank you!!! I was finally able to fix this!! I appreciate your dedication and explation on this!! :slight_smile:

I don´t like to see the pointer in the screen but at least I can use it!!!

First at all, excuse me about my poor english, I’m spanish.

I fly in VR, and have the same problem. But finally, the mouse is not the problem. The problem is the view point is not correct afther update. Reset my pilot camera options correct my problems.

Now the sim works fine and my mouse interact with cocpit well.

This may help you?

It is totally ridiculous. Why change the Profiles.

At first, I thought the ? mark meant whatever you are using to interact with the cockpit dial/button: mouse, keyboard or joystick.

But what is really meant was that there is nothing assigned to
that dial/button/slide to select it or “interact” with it.

This is a new term for me, “interact”.

40 years flying Flight Simulator and I didn’t know that I was “interacting”
with the cockpit (even FS2020).

Oh well, guess that I am more dunce that I thought that I was/am.