Since simupdate 3 vr with reverb g2 no longer working

Hi all, it is no longer possible to switch from 2D to VR since I installed Sim Update 3. The Screen is swapping in a strange manner and sometimes the Sim crashes to Desktop. I am using the Steam Version on a 9900k / 2080ti Rig. Does anyone else have this problem? The latest Nvidia Drivers are installed. Thanks. BR, Thomas

Hi @ZeichenKorn08, welcome to the Microsoft Flight Simulator forums.

We have a collection of categories for VR topics. I have moved your topic to the VR - Bugs category, hopefully, someone will be able to provide you with some assistance. Best of luck.

Just tested mine for you and had no issues. I was even flying already and then launched WMR and changed to VR with no hitch. I am using the MS Store version though and nvidia driver 461.33

I have the same problem with todays update with a 2080 max q and have tried updating nvidia driver from the in this forum mostly recommended 457.something to lates 461.72 - no luck, same problem. VR with reverb g2 has been wonderfull so I am hoping for a quick fix or for someones solution/workaround soon.
edit: Should have mentioned that this is using store version.

Hi ZeichenKorn08. Problem solved for me - have a look at Sim VR thoughts.. Sim Update 3 - #21 by dybflight8864 . Hopefully it solves your problem as well

Thanks a lot. Fixed it for me, too. It was the ATC Window on the second monitor.

Same thing here! unable to use the G2 any more!
nice solution workaround but how to fix it when I dont have a second monitor?
This cant be the problem…

it doesn’t require a second monitor, just requires you to have clicked the “pop out” button on the tab in question.

I only have on monitor but I get the same behaviour - if for example I leave the VFR map popped out I can’t enter VR without it effectively crashing.

But when I am in 2D view there is nothing opened?!?!

I gave it another try with sound in VR deactivated… it works now but with only 3-10fps and random blackouts every 20-50s. With sound activated I dont even see a picture… just bluescreen in cam!

So for me it cant be any opened window!

I created a post with the same issue

Did any1 try if the new Nvidia Driver (released today) fixes the issues regarding VR in the sim?

I managed to somehow overcome the bug (for now) by clicking “Fly Now” in 2D, then opening all the overlay windows (ATC, VFR Map etc.) one by one and closing them again, to make sure nothing is open either as overlay or undocked, or in the background. After doing this, I was able to switch to VR as before without the jitter and the CTD.

I did receive a reply to my original Zendesk Bug Ticket, but only a very generic (ignorant and almost insulting) set of instructions including reinstalling MFS, reinstalling graphics drivers etc., that I had already ruled out in my report to them.

same specs as you with 457,30… .no problems at all, really enjoying VR lately

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.