Solution for Stutters & Pauses

Happy to test this. I am always in for some tinkering with computers and since I cannot get the hands on the new Ryzens I’ll make do with a 64gb RAM upgrade - 4x 16gb 3200mhz banks coming in this afternoon. Will report back!

2 Likes

Ok, quickly tested with 64gb ram - my ‘loading stutters’ continue. Perhaps in general I did gain some fps and normal performance stutters are a bit less, but my own issue remains. I will test it extensively with rolling cache off, to see if the overhead of caching might have something to do with this.

1 Like

10850k, 2080Ti, 64GB RAM, stutters are present at times. I think it’s game optimisation and for that you have to wait for Asobo.

Don’t waste money, unless you are spending to use the pc for other tasks that require it.

2 Likes

I solved the stuttering issue using Lasso like this (copied these settings from another user)

Main menu: Performance mode enabled ProBalance/enabled

FS exe right click menu:

Priority class/always/high
I/O prioity/always/high
Application power profile/Bitsum highest performance
CPU Limiter : When CPU use is: 98% Reduce: 1 For a period of: 1
More/Disable IdleSaver

Hope it can help others like it helped me!

2 Likes

Will try some of those using LASSO as well my CPU is :poop:

I’ve posted my comments about “Process Lasso” here, it might help you (or not) :innocent::
https://forums.flightsimulator.com/t/my-2070-super-vr-settings-and-suggestions-valve-index/321913/43

Well, don’t know if this applies to anyone else here, but it changed my life and put years back on after 2 months of frustration:

I have an HP Reverb G2 that was (keyword : “Was”) plugged into my Asrock Z490 Taichi’s USB-C onboard port, and it stayed plugged in even though I was sometimes flying without VR.

I discovered that I could fix all of my pauses by using the HP G2’s included USB-C to USB3 adapter, and plugging into a well powered USB 3 port instead. Somehow, the power from the MoBo to that little USB-C port was getting cut and was causing all my issues.

I literally flew for 4 hours yesterday, with tears in my eyes, pushing my VR to the limits, and it was all butter!

Hope this may help someone else here. MSFS 2020 is an amazing piece of software, and obviously all my problems were hardware related.

2 Likes

Can you describe the pauses to me? I’m on a 570 taichi and seemed to have dodged most of these USB issues, but now it makes me wonder if I should at least try…

@trowels Well, while I had my VR headset plugged in to the USB-C jack on the Taichi, I was getting 5-30 second pauses, nearly every 3-5 minutes of flying AND while not even in flight, i.e, the menus would freeze too.

Once I changed my port to a “regular” USB3 powered jack, my problems went away. I suspect that the power supply is insufficient and intermittent to the USB C jack, and this was disconnecting the Headset at regular intervals, thereby causing the pauses.

Ah ok that’s pretty gnarly. I definitely don’t get anything at all like that length of pauses.

I continue to see long-lived pauses (3-5+ seconds) at random times on a 3800X/6900XT.

All this has gotten worse with upgraded 1.14.5.0 just released today. I have opened a bug report in the performance section.

In the last version, on Intel processors, it mostly used four processors. In this upgraded, it is down to one processor.

Really sad to see this great product miss bugs so often while doing upgrades.

Guys,
I discovered something weird tonight. A good and lengthy fight. Today I updated to 1.4.5 and decided to give a try immediately. I started straight away to experience long pauses very frequently (like every minute or so) anytime, anywhere, including during game loading or in the front UI menu. I was 100% convinced it had something to do with the update and I was getting mad at Microsoft, Asobo and the entire universe. Well it turns out that Microsoft might be somehow responsible but maybe not for the reason I was assuming first. I started to investigate what was going on using the Task Manager and I realized that at the time of these pauses there was a very clear pattern of network traffic burst synchronized with the drop of CPU/GPU usage from the FS2020 process. So I checked which process was inducing these network traffic bursts. I figured out it was a Windows service named “Device Association Framework Provider Host” (dasHOST.exe). So I checked what this service was about and it appears it is involved in the process of discovering/managing media devices in your local network. At this point I remembered that today I did not just update FS2020. I had also switched my Windows network profile from “public” network to “private” network in order to start sharing files with other devices. So I immediately tried to switch back to “public” network in order to disable all these fancy network services.
The problem immediately vanished! This is certainly annoying but I believe I can live with not sharing files while I fly…

6 Likes

Anyone else tried this solution?

So what we have to do, it is not clear, public or private?

Hi, first, I’m not saying this is a miracle solution to all stutter and pause issues in FS2020. It has fixed a massive pause issue in my case for sure. It doesn’t mean it’s going to have any effect in your case.
I was looking for a way to disable the network discovery and media streaming services. Setting the network profile to “public network” is a very straightforward solution but there might be other ways to get to the same result in a more subtle fashion.

1 Like

will need to try this one out later, had the exact same behaviour with the pauses just after the world update 3, thanks

i did change it from private to public

1 Like

any luck with that change?

1 Like

It could be a saturation of MS server due to all people trying to fly at the same time to test the new update. It seems we have a peak each time they send a new World or Sim update (expected)…
https://steamdb.info/app/1250410/graphs/