Solved issue with crash to desktop during fresh install when clicking Update packages button

Thought this process may help others struggling with crashes during installation.

After uninstalling MSFS some time back and deciding to jump back in now addons for IFR and more realistic avionics displays are appearing from the team at Working Title, I went through the Steam installation. The Launcher installed fine and runs okay up to the point where it shows the Installation Manager asking for the package’s location and the Update button. Clicking the Update button constantly resulted in a crash to the desktop before 2% of downloads were done.

I followed all advice on the forums to no avail. Some posts then jogged my memory about potential background services possibly interfering with the download and it was then I remembered the Windows Msconfig tool.

I ran this from the command line and from the General tab I clicked on Selective Startup. I then went to the Services tab. Here you can see all of the background services that are loaded when you log in to Windows. At the bottom is a tick box to Hide all Microsoft services. Clicking that filters out all legit Microsoft services leaving just a list of all the services installed by third-party stuff that most users install on their system over the years.

I clicked on the Disable All button and then went through the list looking for services that sounded essential in order to try reinstalling MSFS again. Steam Client Service was clearly essential as I have the Steam version so I enabled that. I also enabled all the Nvidia-related services.

With that done I clicked on Apply then OK and rebooted my system. With a much leaner list of startup services running my MSFS installation progressed without issues. So it seems one of the third-party services was interfering with the installation. Oddly, I’ve installed 3 games today including Red Dead Redemption, Baldur’s Gate 3 and Division 2 and these installs were fine, so I’m not sure what it is about Asobo’s installer technology that is so prone to not ‘playing nicely’ with services installed by other third-party software. After this, I fired up Msconfig again and clicked on Normal Startup to set the system back to a normal launch. So far everything seems good.

Hope this helps others.

FYI the Msconfig tool may be helpful to isolate the exact service that is causing issues. I just wanted to disable everything to get through the install. If I have any issues while playing with everything enabled. I can take the following strategy:

It would take some time but what you can do is disable all the third-party services after hiding all the Microsoft ones and then launch MSFS to see if it works. Then jump back in and enable half of the third-party services in your list. Run MSFS again. If it works you know that those services you just enabled are not the culprit. Go back to Msconfig and disable those. Then enable the next half and repeat. If it did crash you know the problem is in that half of the list you enabled, so go back to Msconfig and disable half of those services and repeat.

Think of this as a type of binary search (or divide and conquer) to nail down the problematic service. It should take you log2 of n attempts through the list with n being the number of services you have to search through. That said if there’s more than one third-party service causing problems, it will complicate things :slight_smile:

1 Like

Well this sucks. After the main game install went fine and FS2020 launched, then flying about a bit, I went back to the main menu and went to Marketplace where I saw some updates were available. I set them downloading and part way through I had to leave the house. So I shut down the app.

Now when I launch FS2020 I’m stuck on the Checking For Updates screen. I’ve been to Zen Desk and followed all the tips such as reinstalling Gaming Services etc mentioned at this link:

All versions - Stuck on “Checking for Updates” – Microsoft Flight Simulator Support (

This time a solution is evading me. I have no addons in the Community folder. Again The entire installation experience for this game is terrible. I’d say Asobo’s account log-in and application delivery and update service technology needs work. I’ve been installing games, uninstalling and moving games for Steam, GOG, EA, Ubisoft and Epic all week and the experience in these eco-systems is problem-free. I did in fact spend a few hours moving some Steam games from my fastest SSD to make room for MSFS packages. No issues at all.

I’d say there are just too many dependencies relying on each other in Asobo’s system making it brittle and frustrating. You’ve got account log-in and licensing, Microsoft Gaming Services, Marketplace connectivity, pending updates for Windows OS and Xbox app account dependencies in effect and any problem with one of these will ruin your FS2020 experience, as it’s doing with me right now.

So far the Games as a Service model of FS2020 is more like Games as a Disservice to users :frowning:

Two things about this Checking For Updates. Why is it mandatory? Let customers update at their own leisure. Secondly, why is it allowed to enter an infinite loop state? It should timeout with an error code that can be followed up or allow the customer to press ESC to stop the check and update later. I also think Asobo need to introduce their own Verify Packages tool into the product to scan packages folders and allow you to do things such as disable third-party packages and generally detect log and repair problems.

I finally have a solve for my Checking For Updates issue. After realising my issues started today I went into my FS Official packages folder and sorted everything by date. I then selected all folders showing the date of 15th June and then cut them into a folder I called TEST on another drive. I then launched FS2020 and after the loading screens, it went straight into the loading screen with the blue progress bar at the bottom and eventually onto the main menu.

I then set about the arduous task of methodically copying packages in the TEST folder back into my FS2020 package folder and checking if FS2020 would launch cleanly. After much pain, I’ve tracked down microsoft-airport-kfhr-friday-harbor as the pesky package that is causing the Checking For Updates issue. With this in my FS2020 packages folder, FS2020 gets stuck checking updates, deleting it allows FS2020 to load to the main screen.

This suggests that the Checking For Updates freeze may not be related to things such as Gaming Services, pending Windows updates, the Xbox app or my Windows Xbox app account but rather the brittleness of the Installation Manager and Content Manager systems that download packages from the Marketplace. There really needs to be package management logic and maybe even separate tools that come with FS2020 to detect and repair installed packages that become faulty for some reason or another.

I’ve zipped up the microsoft-airport-kfhr-friday-harbor folder and am wondering if there’s a mechanism where I might send it to the devs or support staff to have a look at?

1 Like