[SOLVED] Microsoft visual c++ runtime library Assertion failed

Everything was normal in my game before, but today my game crashed once. When I entered the game again and started the game after choosing the flight route, this prompt appeared. How to deal with this problem

- System

|||- Provider

[ Name ] Application Error

|||- EventID 1000

[ Qualifiers ] 0

Version 0

Level 2

Task 100

Opcode 0

Keywords 0x80000000000000

|||- TimeCreated

[ SystemTime ] 2020-09-20T12:59:22.9754507Z

EventRecordID 59964

Correlation

|||- Execution

[ ProcessID ] 0

[ ThreadID ] 0

Channel Application

Computer Alienware17

Security

- EventData

FlightSimulator.exe

0.0.0.0

5f5b8327

ucrtbase.dll

10.0.19041.488

0d8057d8

c0000409

000000000007287e

1050

01d68f4ce7e5d54e

C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.8.3.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

C:\WINDOWS\System32\ucrtbase.dll

f8294f56-b1f6-484c-afe5-f150f77755e2

Microsoft.FlightSimulator_1.8.3.0_x64__8wekyb3d8bbwe

App

Looks like you have Visual Studio installed where an app/program that is built using VS C++ throws the error to a debug in Visual Studio.

You might need to turn that debug off in VS or uninstall and reinstall the VS C++ 2015-2019 libraries.

The debugging of Visual Studio has been closed, and all the Microsoft visual package has been reinstalled. The error still exists.

Are you still getting that same type of error message in the photo you posted? If so, then it’s still going through VS.

However, it really shouldn’t matter. The error is with a VS C++ library and appears it is giving it when loading the main world map. (I’m basing that assumption on the VS error of repository folder for “NativeMapClient”).

In the Add/Remove Programs where those libraries are at, were there any stand alone libraries of 2015? or 2017? or 2019? If there’s any stand alone, remove them as the bundled VS C++ 2015-2019 contains those. If there are, remove and restart your PC - should have also restarted after reinstalling any VS C++ library.


This is the list of microsoft visual c++ that I have installed, it should be very complete

OK, you are good on the libraries (no stand alone ones for 2015, 2017 or 2019).

When you reinstalled the 2015-2019 did you restart Windows 10?

Yes, I installed all of them before. Today, after the error occurred, I reinstalled all of them. After the installation is complete, restart the computer and enter the game again, the error still exists

Where did you get MSFS? MS Store, Game Pass or Steam?

You might need to reset/repair it from the APPS in Windows 10 Settings to see if it will correct the file it’s hanging on.

My MSFS is from the Microsoft Store. I’ll try to reset it to see if it can solve the problem. Thank you

Do you have add-ons in the community folder?

Yes, but I tried to cancel the community file, but still didn’t solve the problem

OK, do the reset or repair without any files in the community folder. After doing this, launch MSFS from the XBOX app, not from it’s own icon.

The reset has been completed. All settings are restored to default. There are no files in the community folder. The game is started from Xbox app, but the error still occurs. It seems that we can only wait for the next update patch

Since are able to access the main menu, clear all cache files for Rolling Cache and any manually added areas related to cache.

What nice about that Visual Studio is that it’s telling you where the fault is. “MicrosoftGeospatialTiles.dll”.

If after clearing all cache, it still does it, either wait for next update or re-install MSFS from new again (that’s what I did). After uninstalling, I manually deleted all folders related to MSFS as the uninstaller does not remove some folders and files.

I feel your pain! :wink:

OK, thank you very much for your answer. I’ll try these methods

Same problem, solution is to delete
C:\Users%your username%\AppData\Local\FlightSimulator
and
Flightsimulator related files in
C:\Users%your username%\AppData\Local\Microsoft\WindowsApps

5 Likes

wow, you solved the problem that has troubled me for several days. I have already given up on this game. Now the game is resurrected again, thank you very much

1 Like

Be very careful about removing this folder. MSFS is NOT the only MS Store app that goes here. Just remove MSFS related folders.

See this post:

1 Like

I modified the answer, thank you for reminding.