Solved - Need help - World Map Fly does't start

Tried another airports - didn’t help
removed Community folder - also didn’t help

1 Like

Yes. Sure. All are up to date.

1 Like

Two other things I have heard of:

  • Try a different server
  • Ensure you have the latest drivers for your GPU

Try a fly from 1st set as departure, if that works then add arrival etc!

I had this problem earlier today, what I found was to quit out of map and click reset then load in flight plan again and it work. Seems like a strange glitch along with the live weather not working today.

Just a guess… but sometimes I have mouse troubles too and if in Windows I press the “task view” button on the task bar and then re-select the MSFS window my mouse problems clear up. An alternative approach would be to put MSFS into windowed mode in the settings and try again. It looks like you’re in full screen view so windowed mode might work better.

Took your #2 advice one step farther: install NVIDIA Geforce Experience, and from there I can launch the game directly ( the green LAUNCH on right upper corner)… didn’t help :frowning:
Also changed server… no.

Just wild guessing further:

  • different aircraft?
  • set own weather instead of live weather?
  • select an activity (f.ex. bush trip, or a training episode) instead of own plan?
  • is the hover effect on the fly button working?

Sounds like something is corrupt.

Clear game cache? Clear Nvidia cache if you have it enabled.

Open command prompt with admin privileges. use the command - sfc /scannow. This will check your windows files.

Check game files by going to settings > apps > use advanced options for MSFS and then choose repair.

Use DDU and uninstall GPU drivers for a clean install.

1 Like

[quote=“syldon13, post:18, topic:485718”]
ear game cache? Clear Nvidia cache if you have it enabled.
[/quo

Did it all. Step by step… sorry -
still the same problem. Any ideas ?

1 Like

TBH I really don’t get it. I would contact zendesk
Sorry I could not offer anything constructive.

1 Like

Tell us more about overlay EN english image

Also uninstall Nvidia Geforce Experience

Regarding to xbox mouse issues the workaround goes:

Unplug keyboard, restart game with keyboard unplugged, mouse should work now, plug in keyboard again.

Deleting rolling cache is also always a good idea. Actually this resolved so many issues in the past for me that I wonder why there isn’t an option to auto delete after every flight.

It’s not Xbox. It’s PC.

Thanks.
Already connected them before trying here at the community.

Except for an angry email that it’s not a bug, they didn’t add a useful help.

Maybe I will try uninstall & total delete of the Nvidia folders on Program Data + Registry.
Worse a try.
Thanks again.

1 Like

[quote=“TenPatrol, post:21, topic:485718”]

Stubborn game. Total Nvidia removal did not help either

1 Like

This poster had success with this just recently, I don’t know if you noticed it so here is a link.

SOLVED!
Thanks you all for your help.
Create a new Windows Admin User on my PC. The game made a full new installation which works.
Got back to my original user, uninstall & wiped again all the files. Reinstall -works this time.
Thanks again.
YD

1 Like

Same thing happens on my system. UI on world map fails especially when after last update

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.