[Solved] Stuck at loading any flight / training / Challenge


Hi Everyone,

I write this messsage here because I didn’t find any solution to my problem and i’m pretty disappointed.
As I written in the title,I’m stuck when I want to launch a flight.
No matter the airport, the planes, the place, the type of flight (training, challenge, normal flight)… it still gets stuck at the loading(approxiametely at 60%, 90% on some flights). Moreover I noticed that every time I arrive in the main menu, I get an internet disconnection then a reconnection. I checked that I have the right update, everything seems ok.
I also noticed that the fans of my computer are very active when I play MSFS2020, but when the simulator get stuck during the loading time, they start to decrease their speed, as the application was closed. It seems that the GPU don’t consider the game as active anymore.

The previous day, everything was working, I even did a flight on IVAO without problem.
The following day, without installing anything or updating something, the game was unplayable. For your information, I don’t overcloack my GPU while playing.

Here the solution I tried in vain :

  • Update my GPU and all windows drivers
  • Delete cache
  • Remove online data in game
  • Remove community folder
  • Uninstall all MSFS with the Official file and downloading them again
  • Downgrade my Nvidia driver to a previous version
  • Uninstall FSUIPC and SLC
  • Desactivate Antivirus and Firewall
  • Run Administrator and not as administrator
  • Change the frequency of my CPU
  • Try different type of flight, different planes
  • Modify Virtual memory
  • Change the place of Package folder
  • Install the game and files in another Hard Drive

Really I have no more solutions and it’s been like 8 days I cannot fly anymore.
Here are my spec:

Windows 10 Professional
Intel(R) Core™ i5-10400 CPU @ 2.90GHz 2.90 GHz
Zotac Geforce GTX 1070 amp Edition 8GB

I would be very glad to get help because i’m pretty lost now.

Thanks in advance for your replies

There is a thread here worth a look on this very topic however it does seem like you have tried most of what’s can do. Only other things I remember that may help are charging graphics/LOD to lowest before click fly and using smaller airports then slew/teleport if want to fly in a built up area.

ive got the same problem bud . havent been able to play since oct 27th . im sure it has something to do with online services , im about to try creating a new user profile for my computer and a new MS account , try that and see if it helps

Thanks for your answer.
I just tried to change my Microsoft user profil with another one and the problem still remain.

I finally found THE SOLUTION !

Actually the problem of downloading the map was linked to a mod that is not placed inside the Community folder. This mod is “MSFS 2020 Google Map replacement” and it aims to replace some part of missing map by Google ones : MSFS 2020 Google Map replacement » Microsoft Flight Simulator
I was thinking this problem came from the map because each time I zoomed in the world map, I get stuck for 20 seconds sometimes without doing nothing.

To activate this one, you should open run file which modificate your hosts file in your system. Then, even if you remove the all mods on community folder, this one still remain until your remove two codes lines in the host file. If you have troubles with administrator rights to open and modify the host file, first open the Notepad as administrator and then File>point the direction of the hosts file in your system. Then you will be able to delete the two code lines and save.

I hope my answer is enough clear to help people meeting this problem too.
And once again, thanks for your quick answer and help.

1 Like

Closing topic as the Bugs & Issues categories is for the “default” sim. No 3rd Party or Addons as well as addons that contain legal issues and intellectual property of others.