Some buildings are boxes after SU5 and 2 Hotfixes (and tiles that miss ai buildings altogether)- Issue still present WU6

I don’t experience this and I am wondering if there are additional troubleshooting steps to take.

One thought that occurred to me is to get MSFS to rebuild all the scenery index files that may have become corrupted (assuming you haven’t already tried this!)

The files concerned are found in
C:\Users\username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SceneryIndexes
again assuming you have the MS Store version of MSFS
Delete all the .dat files and then re-run MSFS. It may take longer to start as the files get rebuilt. It may be that this corrects the issue. (It also may be that it doesn’t!) I would say it is worth a shot.

1 Like

Me neither. I did a tour of Northern Ireland including Belfast last week and it looked very pretty indeed.

1 Like

Sadly I see it. It has been present since sim update 5 beta testing. Even a re-install of Windows 10 and fresh install of the sim has not solved it - Edinburgh shows the same issue as well as other cities. Removing procedural buildings from the UK world update is a workaround of sorts.

There are several other threads on the same topic and perhaps the moderators (@tamalien) could merge and combine votes. Some examples:

Problem with missing / incomplete / misaligned scenery around Edinburgh on Xbox - Bugs & Issues / Scenery - Microsoft Flight Simulator Forums

Can someone confirm or deny this one ? GLOBAL BUILDINGS MISSING - Bugs & Issues / Scenery - Microsoft Flight Simulator Forums

Buildings are boxes after SU5 and 2 Hotfixes - Bugs & Issues / Scenery - Microsoft Flight Simulator Forums
(See pics of Castle Donnington early in that thread)

All settings ultra on a 10700K/RTX3090/32GbRAM/1Tb NVME. Fresh Windows 10. Fresh MSFS. No other apps installed. I’ve tried rolling cache on/off, switching settings Ultra->Low->Ultra - nothing helps. I believe its a server issue as at times it is worse than others. Ticket raised with zendesk.

‘Lego’ land!

p.s. Windows 10 re-install was due to leaving Windows 11 Insider Program and not to solve this issue :slight_smile:

1 Like

@tamalien , I tried Your kind solution, removing the .dat files but it doesn’t work.

Some days ago, I tried also a full reinstallation of MSFS, and neither this solved anything.

It is really strange that somebody, like me and @AboezD , encounter the same problem, and others don’t.

@Duke76ITA and @AboezD

I am thinking along these same lines myself given the extra information that I am now seeing.

That isn’t to say that there couldn’t be any other reasons for this cause but I am at a loss, currently, to think what those may be. The server issue or connectivity issue (i.e. a possibility that for whatever reason the correct data is not making its way into the sim) seems to be like a perfectly plausible (and possibly even probable) explanation.

If that is the case then unless, on a particular PC, the issue can be diagnosed with connection issues/routes at the PC end it is very hard to see a way forward.

With regards to merging the threads listed I am going to enquire about this at my end to see what the best way forward might be.

I really do hope this issue can get resolved!

Note: I will try and get it seen by MS/Asobo as well to check if it is a server side issue!

2 Likes

After further thought it occurs to me I’ve never seen a correctly rendered Belfast/Edinburgh since SU5 but before that update I had no problems. Also I’ve flown at various times of day so presumably different loading. Surely these observations would cast doubt on it being server related or randomly you’d expect to see no issue from time to time.

I should also add I’ve made sure all packages up to date in content manager.

4 Likes

Another example of the issue this time from Sweden…

I Am So Done - Community / General Discussion - Microsoft Flight Simulator Forums

1 Like

That post appears to have been closed a d tagged as WU6 - these issues actually started with SU5

1 Like

What does Edinburgh look like for you? Is it working?

Since SU5 there have been a number of issues there.
Missing terminal building at EGPH (Edinburgh airport)
The castle seems to be a lower Res model with no flag (it used to have the flag!)
Autogen buildings are now generic where previously they were fitting the scenery.

There is also a wall of death in Dublin that aircraft collide with. (Fly about 1000ft along the river = collide with invisible object and flight ends with black screen)

Could you check these and bring these to the attention of MS/Asobo also?

@somethingbrite Edinburgh has the SAME problem. Mine example about EGAC is only one of the great number of issues all around the UK, and not only in the UK.

@tamalien I suppose that, if it were a server issue, it should appear randomly, whereas it appears every time I try to fly on those areas.

2 Likes

Please see my findings here :wink:

https://forums.flightsimulator.com/t/problem-with-missing-incomplete-misaligned-scenery-around-edinburgh-on-xbox/434472/18

2 Likes

@Duke76ITA Following my test of Edinburgh last night (and seeing the ‘blocky’ autogen there) I didn’t have time to go and have another look at Belfast last night.

However, this morning I launched another flight over Belfast and for the first time ever I am now experiencing some of what you describe. I launched a flight over the city (rather than at an airport) and this is what I am seeing:


Exactly the same blocky buildings are appearing for me in some parts of the city. In other parts there is also the expected autogen of procedurally produced buildings I am used to seeing

I am also seeing areas where no ai buildings are being rendered of any type

All the above photos were taken from the drone cam in showcase mode.
However this doesn’t seem to be a factor as I see the same thing from within the aircraft

I started a new flight, this time on runway 04 at EGAC and am seeing exactly the same thing

I was not experiencing any of this before prior to testing today.
I am on the North European server
image
Undeterred by this I exited MSFS and deleted the rollingcache.ccc file using windows explorer. When I relaunched MSFS I noticed the file had been rebuilt, so I deleted rollingcache again in General Options>data and turned off rolling cache and started a new flight from rwy 04 at EGAC. Same issue:

I then tried turning on rolling cache again (and to be sure set it at a different size to the previous size, 10 GiB instead of 8 GiB). I also changed to West European server and then started a similar flight from EGAC. I saw the same issues again.

I then tried turning OFF all online functionality in the sim from General Options>Data and clicked save. I started a new flight again from EGAC runway 04 and again I am seeing some areas with correct procedural buildings and some with the blocky ai: (I think this discounts the possibility that it is a server side issue)


and some areas with no buildings being created at all (as others decribe)

As a final test (for now) I re-enabled online functionality in MSFS. Once again deleted and reset rolling cache and left it on. I then exited MSFS and went to advanced app settings and clicked “repair app”
(Note don’t click Reset app as this can delete all downloaded content that is stored in the defaul installation path)

I re-ran MSFS and launced the same flight from rwy 04 at EGAC on the North European server with live weather on (setting live weather on or off didn’t seem to make a difference in previous tests as I had tried both)
This time limited success… The procedural buildings are back to where they should be and no more blocky ai buildings close to runway 04

However, moving the drone camera further afield from the airfield then I am seeing the same issue manifest itself, i.e blocky ai and missing buildings


and

Note in the lower part of this last screen shot there is evidence that at least some buildings are being correctly rendered as appropriate to this area as a result of the UK world update. Some areas have no buildings and some have blocky ai buildings. (This shot was about 3nm from where my aircraft is, on threshold of 04)

TL;DR from my investigations:

  1. I can reproduce this issue
  2. The areas it manifests itself is not consisent. In some cases I was getting blocky ai buildings that an app reset corrected. However when using the drone camera to move further away from the area I spawned into I was seeing new areas that had missing or blocky ai buildings
  3. The issue may well have been there for me all along and I never noticed it before as I wasn’t paying close enough attention to ground scenery buildings in areas away from the runway as I would have been too high and never used the drone camera to get close enough to the ground to look at the nature of these buildings.
  4. The areas where this happens don’t have to be consistent. An app reset can correct areas that previously had blocky ai buildings and replace them with the correct procedural ai buildings. However, the further away from the spawn point the more likely it is to see the issue manifest itself.
3 Likes

You’ve captured what I meant in my first post when I said the issue was inconsistent - it’s always present but just different areas. You’ll also find that toggling UK procedural buildings sometimes gives that church as a perfect render but then after a reboot it’s back as blocks.

I still think this is not just some UK cities but from other posts it may be limited to Northern Europe cities.

2 Likes

Further update for any developer that may read this.
I forced enabled the new ‘safe’ mode by using task manger to stop the launch of MSFS.
On a subsequent re-run I enabled safe mode at the prompt.

I still see the same issues arising in safe mode which seems to confirm it is a game code issue rather than as a result of any add ons, marketplace or otherwise:

Blocky ai buildings:

and whole areas without any ai buildings:

intermingled with some correct procedurally generated ai buildings appropriate to the region:

3 Likes

I posted earlier that Belfast is fine for me: not any more! And the background satellite imagery has that horrible green hue.

Hey ho.

@tamalien , I know that it would be a very weird workaround, but did You try removing the procedural buildings from the Manager? It seems they are involved in the problem. Obviously, it is strange as a workaround, and maybe it doesn’t allow us to observe the newest archetipal buildings developed from Asobo/Blackshark, anyway it can allow to solve a bit the problem - even if some “blank areas”, that’s to say without buildings, still remains.

No I haven’t. I am not concerned enough about the issue to start tinkering around with core game files, especially as I don’t know what other knock on unkown consequences that may have.

However, I think this visual ‘bug’ is now one that, once it is noticed, I may tend to be more aware of it in future flights and, therefore, it runs the risk of being more of an irritant for me than it may need to be, until it gets fixed. Time will tell, I guess.

2 Likes

@tamalien I deeply agree with You; I simply tried only because it is not a “hardcore” procedure, due to the fact that these little files are regularly accessible by the content manager of the sim and it is not necessary to go on the Windows file system.

Anyway, the only hope we have is that the developers are aware of this serious issue, and are working on its solution.

@tamalien - is it worth considering a merge of topics to add more weight to the issue? Those threads I listed above in my first post have further links to other cities that exhibit the phenomenon and show it’s not just localised to Belfast and Edinburgh.

4 Likes

FWIW I’ve seen the same issues too, both in Edinburgh and Belfast.

1 Like