Some buildings are boxes after SU5 and 2 Hotfixes (and tiles that miss ai buildings altogether)- Issue still present WU6

“IMPORTANT! Be sure to download both thalixte-stockholm1.zip (which is the main file), thalixte-stockholm2.zip and thalixte-stockholm3.zip. Extract thalixte-stockholm1, thalixte-stockholm2 and thalixte-stockholm3 folders into the Community folder. Both packages are mandatory for the scenery to display correctly. The new update is compatible with the WU5 update, but you need to download the nordics MS/Asobo handcrafted objects first”.
“This scenery has been extracted from Google Maps, hence all 3D credits goes to Google.
This scenery has been generated with the Google Earth Decoder tool”.
Therefore, the images refer to a mod or in any case to a manipulated scenario certainly not to the default one of the game. Anyway, nice mod!

Sure! Even if it cannot be accepted that, in order to overcome a problem, we have to use the third-party freeware photorendered sceneries created by passionate volunteers. :unamused:

Maybe you can create a Zendesk ticket to ask for MS/Asobo to add this city in photogrammetry in the game ? That’s where modders can help, providing to you photogrammetry where they do not exist natively.
Also, consider the fact that those photogrammetry addons have not the same level of details as the MS/Asobo ones, as they are stored on the users’ hard drives, and not on servers that can stream and embed more data. Those addons also lack some existing features of the MS/Asobo photogrammetry areas, such as autogen trees (in fact, it can be done, but requires too much work to insert them inside the addon). The advantage of such addons, is that they don’t require good online connection to work correctly (but you can have the same with the existing photogrammetry areas using the manual cache feature).

Merged another thread here at @DreadBeret59473 helpful suggestion. Thanks!

2 Likes

same problem, some buildings are missing and others are even in black color

1 Like

maybe several more to merge?:

My zendesk tickets for these issues is now showing as solved - meaning that, of course it isn’t “solved”, but at least it is into the system now…

3 Likes

Well, back from a long holiday without being able to fly. Kept up with WU6 issues and fixes and had hope that somehow this issue would be fixed.
Alas no. Everything is exactly the same. I ran the Sweden Bush trip too and found all the same issues as I posted at the start of this thread. This needs as many votes as it can get and same with Zendesk reports. I want low level flying to be fun again and not the “box spotting” experience I currently have.

For those who are not aware, removing the Procedural Building packages from the WU updates sould fix (work around) the box issue and the missing autogen issue. Of course you will loose the region spesific autogen, but you will have autogen that displays correctly.

1 Like

Hello everyone, thank you for this thread. I’ve been able to reproduce the issue in the ‘Castle Donington’ area.
I have read other issues not related to the OP, please open a new thread. I’ll be focusing only on the Blocky Auto generated buildings.

For ‘Castle Donington’, if you have the WU3 installed Auto generated building will look like boxes. Without WU3 installed, everything if fine.

Hello fallorama, would you be able to test with Stockholm? Please chose a same area and try with and without the Nordics Update. Maybe this situation happen on all World Updates. Thank you for your help.

My blocky buildings and low LOD is worldwide, once the procedural buildings updates are deleted it turns back to how it should be. Certainly some conflict in there somewhere that MSFS isnt liking at all.

2 Likes



No more buldings airport in LSGG today!

If you have a rolling cache, try deleting it and restart the sim. That happened at City of Derry to me on Saturday. The next day when I continued my flight from the airport, I completely deleted cache, and nearly the entire airport complex appeared. It doesn’t matter if you visited this airport before or not, there’s something in the cache logic contributing to missing objects.

Hi I don’t use the rolling cache…so that’s not the problem If I exit and restart buiildings are here again…this bug was on my arrival to LSGG.

Yes, we talked about it previously in this post. Removing them is only a workaround but, as for now, is better than those awful blocky buildings, or problematic airports.

I don’t know if it will be solved in the next Sim Update.

I could lend you some. xD

Yeah without the procedural buildings of WU5 Stockholm also looks better.

1 Like

Removing a world update does not resolve the issue by making it look the way it should. It simply hides the issue.

This is now 2 months old. (started with SU5)

And just to clarify for those that don’t want to read the whole thread, you only need to remove the procedural buildings part of WU3 for the workaround. It’s only around 50mb.
The buildings won’t look as pretty as they should but they will all be there and not plain boxes. Good to see this is being addressed now.

2 Likes

I can confirm that this is definitely on MS/ Asobo radar and is being looked at. I don’t believe the long term solution is going to be the necessity to remove world updates and/or the procedural buildings part. I suspect that this is just a temporary work around for those who find the blocky ai buildings bothersome in the mean time.