Something went wrong launching your game - Error code: (0x80070002)

Hello,

Today I was able to successfully open / close MSFS. I then proceeded to reenroll in the Insider Program in the Xbox Insider Hub. Afterwards, I was unable to launch the game from the Xbox app on my PC. There are no updates to install, but I am getting this error:

Something went wrong launching your game.
Error code: (0x80070002)

I also tried redownloading “Digital Ownership” from the Microsoft Store, but I get an error each time I try to do that as well. I also tried logging out of Xbox / Microsoft Store and logging back in, as well as restarting my PC.

Anyone know how to fix this without redownloading the entire sim?

I just got it today (September 6, 22). Never had issues with CTDs, or any other problems, and the sim worked fine yesterday and every day before. Today it won’t start… Something went wrong launching your game with the same error code. I’m in SU10 Beta, BTW…

First time for me today (Sept 22nd). I updated my windows10 first, so wondering if this has something to do with it. Have tried many of the suggestions on internet without success. Help required please if anyone has similar problems and found a solution.

First run Digital Ownership in Ms Store.