Somethings are going wrong

Its not a bug at all…its a feature lol

Maby it’s planet x👀

Exactly! I understand that they want to make profit etc but before you do that make sure that the customers who bought the base pack get what they’ve paid for


Maybe testing for Flightsim3020 where we have more apocalyptic weather scenarios to deal with :grinning:

1 Like

We are all part of an beta, they where right about that one haha

See? Everything’s fiiiiine…the engine is suited for the task then…carry on! Lol

1 Like

The live weather engine is getting data from external sources. If those data it’s receiving is faulty somehow, then the engine would misinterpret the temperature and simulate it wrongly too. I don’t think it’s the MSFS Live weather engine that’s at fault. It’s just doing what it’s programmed to do. Grab temperature data, simulate it. That’s it. If the data is corrupted to show 200C instead of 20.0C then by doing its job it would simulate the temperature wrongly as well.

I would think they should put a safety margin in their live weather engine, where there could only be a range of minimum/maximum temperature that it can simulate. So if they’re getting faulty data like this, they can decide to not use the faulty data, and just simulate the minimum/maximum temperature values depending on whichever’s closest?

What’s this hanging flight controls bug? Is it happening under a very specific conditions? Because I’m using my TCA Captain pack hardware and I’ve been flying it without issues for the last few weeks. Been doing short-medium flights with it without issues too.

ok, I can see the possibility of that, but surely if data is ouside of reasonable thresholds the sim should reject it rather than use it? I do hope you are right and the data source rectifies itself by tomorrow. First time its happened in several months of flights though.

Mouse in VR for one

The problem with that random Twitter comment is it’s very generic, it doesn’t say anything really.

Let’s await tonight’s Weekly “Blog” update, and hope that’s not null & void of any relevant information…

1 Like

Is there an ETA for this?

very generic, but admits to the possibility of an fix/update. I think most people are frustrated when they think that there won’t be fixes until end Feb '22 as stated previously by the dev team.


Typically around 2300Z most times…most times…

More like everything is going wrong! I can’t even get my Logitech Plug ins accepted? Had been using the same set up rtill the 7 Update was foisted upon us with minimal problems. Now the game and my controllers (7) are inoperable. I tried everything I could think of to no avail. Sad situation Microsoft.

Please, for all that is holy, STOP making assumptions like this. But I’ll defer to anyone who has some inside knowledge of how these bugs are EASY TO FIX. If you have that knowledge, please send an email to MSAsobo so they can be enlightened.

1 Like

They could mean SU8 regarding an update…!

its not about budget cuts anymore its all about the supply chain

There’s a lot of whiney nonsense in the forums too, hence why I’m trying to understand what’s so game breaking for these responses.

Trust, I’ve had my fair share of frustration with MSFS but I haven’t had any major issues since SU5. I don’t fly VR, but I’ve seen some mention the mouse bug which is critical I’d assume.

The weather engine has some issues but it’s not keeping me from flying.

I guess going through each of these updates since the very beginning, I just have come to accept there will be bugs and they’ll address them when they can.

They’ll never do a quick hotfix, at least they never have since alpha.

One thing they’re not great with is communicating. If they would just update us that they’re aware of said bugs, that would go a long way. But I’m just surprised SU7 is considered so terrible. Just haven’t seen these game breaking bugs yet I guess.

1 Like

Not sure if it meets the definition of “hanging flight controls” but for the past three days my flight controls are frozen after loading a flight and trying to take off. The cockpit view shows everything but there is no interaction either with the yoke, controller, or mouse. Up to this point I have had no issues using Xbox Series S and a Turtle Beach Velocity One yoke system. Likewise, there is no response from the Xbox controller. I have tried all the usual remedies, shut down, reload, unplug, etc. to no avail. My only conclusion is a bug in the program, which is inexcusable considering how much investment there is in this sim. I would hate to think I am grounded until the next major update.

They could , but given the aim of SU7 was “game of the year” & thanks and have fun over the holidays, let’s just say Feb would be a stretch for a good few people on here. They have left date open, but I now think a hotfix likely before Christmas. They want a holiday and they want us to be happily simming not sitting on here moaning all holidays.