Sometimes trust nvidia?

Last few days I’ve had a few issues with fps and stuttering. Tried quite a few things and even thought it was my cpu at one point, as its a 14900k and there a lot of huff lately about those… then i thought I’d test some setting in sim…i disabled vsync and the stutter was gone… but no vsync means other issues…i wanted it back… went to nvidia control panel… reset evening to default… changed from “use 3d settings” to “let the application decide”…vsync now works in the sim again… smoothest flight over ever had.

So just a quick psa… sometimes messing with settings isn’t the best option… sometimes nvidia do know best.

I also found dissabling HT in the bios helps, As MSFS attaches itself to a Core and utilises the HT on that core, which gives stutters.

At least without HT I get a smooth performance, I’m running on a 13700KF.

1 Like

Thanks for the tip. If the stutters come back at some point, I’ll give that a try. For now though, I’m stutter free and enjoying nice smooth flights.

2 Likes