SR22 Throttle Defective

Just completed another flight MSFS2020 in the Asobo Cirrus SR22 to test items that were hopefully fixed in recent updates. There are four items that are persistently defective.

  1. A real Cirrus SR22 has propeller speed integrated into the throttle so the simulated SR22 should have the same feature. There is no separate propeller speed control in an SR22. The last time the developers did anything to the SR22 they fixed engine power problems including correctly increasing the propeller speed to 2,700 rpm under full throttle as prior to this fix the propeller speed was maxed at 2,500 rpm and the engine was under-powered. Now, the problem is that in flight the Asobo SR22 no longer correctly reduces propeller speeds below 2,700 rpm when throttling back. Under full throttle the real world SR22 is designed to climb out at 2,700 rpm. On leveling off SR22 pilots are trained to pull the throttle back until propeller speed is reduced to 2,500 rpm which is the correct propeller speed for en-route level flight. The current version of the Asobo SR22 will not reduce propeller speed below 2,700 rpm until power is pulled back practically to idle. This makes the Asobo SR22 difficult to fly since it is hard to appropriately descend and configure the aircraft for landing. It is also true that throttling back does not change engine sounds until near idle which means the engine now sounds the same 25 percent power as it does at full throttle which is disorienting to a pilot. Ironically, the throttle works perfectly on the ground. When I use full brakes and power the aircraft to 2,700 rpm on the ground and then reduce throttle the engine powers down exactly as a real SR22 would do. The throttle defect is persistent only in flight.
  2. Anytime I use any switch on my Logitech/Saitek switch panel the Garmin G1000 NXI PFD and MFD display brightness goes full dimmed. This does not happen if I use the mouse and click the switch on the SR22 virtual panel.
  3. On the Garmin G1000 NXI, the heading bug does not sync when the heading button is clicked.
  4. The Garmin G1000 NXI does not display the wind speed/direction in flight. The Working Title G1000 had a lot of problems but it did display the wind speed/direction.

Of the three items described above, #2, #3, and #4 are minor and just somewhat annoying. The throttle issue, however, is major and substantially reduces the value of the simulated experience.

Not sure what’s happening here, but I used all three HDG knobs (the ones on the PFD/MFD bezels and the one on the multifunction input panel on center console) and all three correctly synched to current heading. I am using the NXi.

NXi does display wind speed/dir vector information - you need to click on the PFD Opt soft key, Wind soft key, then select one of the three options. I personally Prefer Option 3.

Usually this is a sign you may have multiple key bindings or an LVAR that is in contention. Unfortunately I have no experience with the Saitek panel, but conflicting bindings is usually the No. 1 suspect.

Another possibility - you may have both the Marketplace G1000 NXi and the legacy Working Title G1000 (in your Community folder) installed at the same time. You may only have one or the other at any time and need to restart the sim for changes to take effect.

4 Likes

Hi, A.J. … thanks for taking time to provide feedback on the G1000 NXi. I flew the Asobo SR22 again today and found that I still cannot sync my heading by clicking on the heading button. All three heading buttons failed to produce a sync. I checked control options and there is no option to assign a key to sync the heading bug so for now I’m flying without the ability to instantly sync the heading bug to my current heading. Your instructions for displaying the wind speed and direction worked perfectly. I was looking for it on the MFD, not the PFD, so I appreciate you directing me to the PFD. This is quite helpful. As for the PFD and MFD dimming on flipping a switch on the Logitech/Saitek switch panel it is probably not caused by multiple key bindings as it is not possible to manually assign key bindings to individual switches. The switch panel connects to the sim with a software driver supplied from the vendor’s website and every switch action on the panel produces the same dimming on the PFD and MFD. Of course, the throttle defect did not magically correct itself and that problem persists again today, too. Also, I double-checked for the legacy Working Title G1000 in the Community folder and it was removed from that folder when I installed NXi. Thanks again for the tip on getting the wind data to display on the PDF. One out of four ain’t bad… SR22Flyer

Just a double-check, are you on Legacy mode for Cockpit Interaction Controls, because I am. The new Lock is supposedly easier to twirl things like the Garmin knobs, but I can’t get my muscle memory to recall it.

In any case, the reason I ask is that it may be affecting the way you’re interacting with the Heading Button. In Legacy mode, I point the mouse arrow at the front of the knob and left-click once. Works, so I’m sort of stumped what’s happening on your end.

I don’t have this switch panel but it does sound like there is a value for the dimming control at a set value that will only be refreshed when the device is used. It’s a bit like if I start a landing challenge with my joystick throttle at zero, the preset value in game is used until I push a button or move my stick, at which point the throttle value is also updated to match that of my physical device.

So, possibly a rotary control or something in your panel has a value / simvar that is what the game looks for with regard to the display brightness and when you use any other function, that value is also refreshed in game.

Edit: I also don’t have the NXi installed so I cannot check if it is a wider issue with other devices, which could be possible.

Yes, the automatic propeller control never worked in the cirrus. Really annoying that it doesn’t get fixed after such a long time. The Cirrus has always been the most incomplete GA plane in the sim. And since the last update the call sign is missing on the fuselage.

1 Like

A post was split to a new topic: How to get the SR22?