Still Cannot make the dowload the last update! :(((( #pc


Microsoft Store version

The last dowload still doesn’t appear in XBox or MS Store.

I did all those steps described untill yeasterday with no success.

I saw this problem descried is this forum as a “Resolved bug”??? How come??? It is not solved at all!!!

I am very very disappointed…

`PC specs = i9 + RTX3080 + 32Gb (HP Omen PC)

Did these fixes involve resetting the windows store if not might be worth a try.

I’ve got the same issues… One big loop! Start MSFS boots up to load screen than Mandatory update available go to MS Store, Get drop down menu in upper right corner, go to updates select FS and proceeds to download. Finishes restart same steps as described above. Over and Over… What am I missing?

1 Like

What proceeds to download? Also, do you have the XBox app installed from the MS Store? Not the companion app, the one simply called XBox.

Yes I have XBox.


How to reset windows store?

Ok, I found how to do the reset… I did it… Didn’t work as solution neither.

1 Like

[I just posted this as separate post, but repeating myself here hoping it will help you]

I have MS Store version. I was stuck with and couldn’t find a way to trigger MS Store to download updates. The 3 part zendesk Download & Installation issues troubleshooter didn’t fix the issue. XBOX app removed mandatory update issue, but didn’t trigger updates. Finally I decided to uninstall MSFS. Luckily I stumbled on a fix:

Go to Add or Remove Programs
Select MSFS
Select Advanced Options
Select Repair

After the repair I switced to MS Store and it was already downloading the latest update (I have auto-updates on)!

1 Like


Where can I find the “Add or Remove Programs”?


Oh, and just a thing… The MSFS doesn’t appear in my MS Store App. I bought it directly in the MS web page.

Repair in Add/Remove Programs fixed no updates for me - Bugs & Issues / Install, Performance & Graphics - Microsoft Flight Simulator Forums

Try this fix. I wish I had seen this yesterday, fought the update for several hours until I saw update in x-box area under MSFS-2020 base game, little update button.

Try this it worked for me.

  1. Make sure your Windows is up to date.
  2. Install if you do not have it Xbox app.
  3. Important under the Xbox app select My apps.
  4. It should show the update.
  5. If it does not show re-boot your computer and try again.

I know this is more then ridiculous for any update. We are stuck with this nonsense.

There is no sense to go on because it just gets me upset.
Good Luck


There is no such button on my installed XBox app.

But thanks,anyway.

Hi there!!

I did all that stuff, and the rest that was published on the MSFS suport forum page.

No good… There is no button, no link, (on XBox app, MS Store, or inside MSFS) anything that could take me to those updates… I am stucked on the 1.18… :frowning:

Ok, I did this “repair” @ Add or Remove Prgrams… No good :frowning:

Did you start Xbox App? If yes go to my apps the update should show up if not restart your computer and go back to the Xbox app my apps and look for it again.

Make sure your community folder is empty.
Hope this will work for you.

Ok, I went into store and these are I think things needed for game to run and update. Not necessarily in this order, but all might be required for you situation.

  1. X-Box, modified yesterday.
  2. X-Box Insider - I signed up to test game, need this for that-never could get game to download*
  3. Digital Ownership - Been on here for while updated 9-9-2021.
  4. X-Box Game Bar - Has been needed since believe earlier in year, WU4 or thereabouts.
  5. Gaming Services - Has been needed for long time, believe it is MSFS associated Check of somkind.
    *I found that Zone Alarm prevented the game from getting the core files from MS Store. Once I took off and then ran their clean.exe, was able to download. This is ongoing since game release, so most of the time I leave it off system.
    One other thing, MS released a program called “Microsoft Security Scanner” one person reported his sytem had down deep bug/threat/something which deleted all his game files. He ran that (free, search for it on MS site)and that fixed his system, and he was good to go.
    If, some of those things missing, maybe???
    If none of this works, I am at loss. Maybe someone else has suggestions. If your system is real old (don’t know nothing about AMD, etc) the hardware requirements have changed since game release, real old video cards (my old laptop - game one, but old Video Card) would not now run this game period. So you might check those components against the newest HW requirements and make sure something has not gotten overridden by technology.
    Good Luck.

4 evenings to find an solution, this helped me:
Install latest drivers for videocard !!!
Pc off / on
Find updates in x-box /microsoft store and install
pc off / on
run MSFS2020 as administrator

I have done all the tips above and it’s still stuck at [2/49]. It’s been almost a month now that I cannot install updates.

You might have some luck with a VPN. Proton have a free service, or NordVPN, who have a time limited trial.