Still CTD in 1.18.14.0

Still getting CTD.

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001a123c7
Faulting process id: 0x5488
Faulting application start time: 0x01d786c3e4140c99
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 8f2af949-3678-4305-ac19-6b1cf4258edb
Faulting package full name: Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

No addons, nothing in community folder, fresh install of MSFS.

AMD3900x
RTX2080ti
32GB DDR4
HTC Vive (Original)

I used to get CTD from the menu, however since limiting frames to 60fps in Nvidia control panel I can now at least start flights and have around 5 mins flying until CTD.

I have the Premium Delux version bought from MS store…

As I said, already tried that several times, steam cloud disabled, steam cache cleared, even reinstalled the sim. It does not work. Even steam support doesn’t know how to clear the data…

Dear KorruptCow,

I followed your advise about reparing the .net, did only step 3 and 4.

Before this, every return back to the menu (after a flight) results in a CTD, i just did one testflight (no time for more at the moment) and for the first time since the SimV upodate and hotfix the menu did not CTD.

So looks promising, thanks so much !

Regards,
Ben

It´s so frustrating. I tried a lot of the suggestions from this thread but no success for me.

I wonder if this is ASOBO’s idea of a one year anniversary of the game: bring back the launch day feeling… Crashes, missing features, so much eye candy but not long enough gameplay to enjoy it…

1 Like

3 CTD’s tonight whilst flying on Vatsim:

  • Spawning into Airport (Copenhagen)
  • 15 minutes after being at the gate (Copenhagen)
  • Printing the Metar from the FBW 320

Not for me …

1.18.14.0 seems to have cured all my other CTD issues (I also did the Delete Rolling Cache thing not sure if that helped) but I still get CTD on FBW A320nx everytime trying to load into LFPG.

There is another thread that FBW seems to CTD only at larger airports for some (inc me I reckon) have you tried starting parked at gate at LFPG ?

I’ve had nothing but CTD, other than a quick black screen, since downloading this game.

Maybe someone can diagnose this:

Faulting application name: FlightSimulator.exe, version: 1.18.14.0, time stamp: 0x00000000
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process id: 0x27f0
Faulting application start time: 0x01d788121f2892dc
Faulting application path: D:\Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: e52be704-ea88-4493-b465-2df5cd58f334
Faulting package full name:
Faulting package-relative application ID:

Spoke too fast… CTD on my last flight, but only when leaving the flight. Annoying, but liveable.
This being said, it certainly UNACCEPTABLE from MS/Asobo to release such f… up updates and patches for a paid product, especially when those updates are mandatory !

Sooo, sadly I’ll get CTDs there as well (Latest Dev Version @ CDG, tried to load up at Gate C10 - All Ultra +LOD400)
To be fair I was referring to their statement shortly after the SU5 release, that their newest Dev Build should be somewhat ready for the update - a statement that got reverted recently as far as i know, saying that they are still aware of some issues.
I wasn’t too deep into the A320NX just after the SU5, as I’m still trying to troubleshoot my other CTDs I’m getting (Random pressing Fly CTD, Going back to Menu CTD, CTDs in Activities without any Mods active)

I’d say those are issues that Asobo has to adress, like the Custom Airports CTD after the UK World Update - where two custom airports couldn’t share the same .CGL tile without crashing.

Well, I followed every advice seen on the last CTD’s threads. Nothing worked. Just went and made sure my community folder is empty (as it was before) but this time removed EVERYTHING which didn’t start with the words “asobo” or “Microsoft” from the official folder. Sim seems to be stable now (knock wood).

I just heard that FBW are withdrawing the A320 from the marketplace because they can’t guarantee compatibility. Looks like every add on (including those bought on the Sim’s marketplace) are now prawn to CTD the sim at some point.

I get it when you buy add ons from another company but when I buy one from Microsoft on the own platform it should be compatible with whatever update been published.

Sorry to say Asobo dropped the ball big time with SU5 !!!

UPDATE :
Carenado add ons are working fine… I’ll start going one by one until I’ll get those who are CTD’ing the Sim
PMDG DC-6 works fine
IndiaFoxEcho Goshank T45 is working fine
FSDREAMTAEM Switzerland mesh is creating CTD ! (It’s a freeware found on the marketplace)

I’m at the brink of nervous breakdown… or should I call it CTD? I’ve kept the record, since the SU5 and the hotfix I tried to fly 30 times and had CTD’s on every flight I tried except for 3. A sad record. Before SU5 I had absolutely zero CTD’s. The crashes vary between real CTD’s or freezed image without anything else to do but to hit ALT F4 to close it down and restart. I tried without community, with community, with the tweaks that I read on the forum, without the tweeks… I’m really getting mad. What makes me even more mad is that there’s absolute radio silence from the part of microsoft and asobo. They do as if everything is normal, even launching a new aircraft in thet marketplace. An aircraft I can’t fly because the sim doesn’t work anymore. This is outrageous!

CTDs all the time. Sim is broken

I have exactly the same problems as you. CDT all the time, no flight possible except “discovery” flights.
I followed all the advice from the Zendesk ticket (automatic message) but to no avail …
ASOBO, thank you for taking our plight into consideration.

Here is their response to my Zendesk ticket:

Before we gather more information, please ensure you have taken the necessary precautions to install and test the new build in a vanilla state (i.e. without interfering programs that may be responsible for the issue).

I. MAKE SURE YOU HAVE INSTALLED PENDING UPDATES
While you may be on an up-to-date version of the OS, there may be essential application updates waiting to install.

  • Click on Start (the Windows icon in the bottom left corner of your screen)

  • Select Settings

  • Go to Update & Security

  • Stay on Windows Update

  • Click the Check for Updates button.

  • Wait until the verification is finished.

II. MAKE SURE YOU HAVE INSTALLED STORE UPDATES & REFRESHED THE CONNECTION TO THE MICROSOFT STORE APP
Apps and services such as Gaming Services and the Xbox app are constantly updated. To make sure you’re running the latest version, install Store updates regularly.

  • Click the Store icon pinned to your menu bar or type “Store” in the “Type here to search bar” next to the Start icon then select “Open

  • In the top right corner of the Microsoft Store app—next to your profile icon—click on the Arrow icon or the three-dots menu.

  • In the drop-down menu, select Downloads and updates.

  • Click Get updates then Update all and wait for the updates to install.

  • Once the updates are installed, click on your profile icon in the top right corner of the screen.

  • Click on your email address.

  • Click on Sign out.

  • Click on the icon in the top right corner, then click on Sign in.

  • Sign in with the email address used to purchase Microsoft Flight Simulator

III. MAKE SURE YOU HAVE SYNCHRONIZED TIME SETTINGS
Incorrect Time & Location settings can prevent you from signing in or authenticating your DLCs.

  • Go back to Start, then select Settings > Time & Language.

  • Select Date & Time and toggle the “Set time automatically setting" and “Set time zone automatically” to ON.

  • Click on Synchronize your clock to synchronize your system’s clock with an Internet time server.

  • Then click Region, double-check that your country or region is correctly set up (for example if you live in Canada, make sure that the region isn’t automatically set to the USA or vice-versa)

IV. MAKE SURE YOU HAVE MOVED THE COMMUNITY FOLDER AND DISABLE 3RD PARTY APPS
You should not download and test a new build before moving the community folder and disabling apps such as navigraph, littlenavmap etc…

  • Close Microsoft Flight Simulator
  • Navigate to the Community Folder that is located by default at the following location:

MICROSOFT STORE VERSION

C:\Users*YourUsername*\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages

STEAM VERSION

AppData\Roaming\Microsoft Flight Simulator\Packages

BOXED VERSION

C:\Users*YourUsername*\AppData\Local\MSFSPackages

NOTE: If you have installed the packages on a different drive than C: you’ll need to look inside your custom installation folder instead.

  • Copy-cut (CTRL + X) the Community Folder

  • Paste (CTRL + V) the Community Folder on your desktop for instance

V. MAKE SURE YOU HAVE DISABLED PROGRAMS KNOWN TO CAUSE CONFLICTS

Before launching a new build, disable ALL non-essential apps on startup and disable ALL non-Windows apps and processes from running in the background before installing and testing the new build.

Pay particular attention to the programs from this list:

  1. Seagate Toolkit

  2. Nahimic service

  3. Asus Sonic Studio 2

  4. Windows Audio Service

  5. Garmin Express

  6. WD Backup

  7. Logitech G Hub

  8. Project Lasso software

  9. MSI Afterburner / Riva Tuner Statistics Server

  10. EVGA Precision

  11. OBS

  12. Xsplit

  13. Discord

  14. MacType

  15. Warsaw Banking App

  16. Wallpaper Engine

  17. A-Volute Sound studio

  18. Malwarebytes

  19. Trend Micro Maximum Security

  20. Comodo Antivirus

  21. Sophos

  22. Emisoft Anti-Malware

  23. Avira

  24. Avast & Avast Cleanup

  25. Bullguard

To disable apps on startup

  • In the Windows Search bar, type “Task Manager
  • Select Open
  • Go to the Start-up tab
  • Disable all non-Microsoft applications and services
  • Reboot the computer
  • Try launching Microsoft Flight Simulator again

To disable apps from running in the background wasting system resources

  • Open Settings.
  • Click on Privacy.
  • Click on Background apps.
  • Under the “Choose which apps can run in the background” section, turn off the toggle switch for the apps you want to restrict.

VI. TEST THE NEW BUILD IN A VANILLA STATE

We recommend launching a flight or two in a vanilla state before reinstalling the community folder and enabling non-essential programs and background processes.

1. Test your mods.

  • Find the community folder you moved earlier

  • Copy-cut (CTRL + X) the Community Folder

  • Navigate to the Packages folder

  • Replace the (CTRL + V) empty Community Folder with your Community folder

If the sim starts crashing or behaving abnormally after reinstalling the mods, you’ll need to investigate which add-on is not compatible anymore with the base sim.

2. Test your apps and background processes

Enable your non-essential programs and background processes. If the sim starts acting up, you’ll need to investigate which programs are causing a conflict or putting too much strain on the system.

VII. INVESTIGATION
If the problem occurs in a vanilla state, please re-open this ticket and provide more information regarding the problem, and how to reproduce it.

For example, provide information such as:

  • What is the error message?

  • When did the issue start?

  • Is the issue happening with all aircraft? What aircraft is impacted?

  • What do you expect to happen? What is actually happening?

Attach screenshots and video captures to illustrate the issue better

If a feature is not working as intended / true to life, feel free to provide documentation/information that the Design team can review.

We appreciate you taking the time to provide as many details as possible. Once our team has reviewed the information we will provide troubleshooting steps or record the issue in our internal bug and issue tracker.

Kind regards,
Microsoft Flight Simulator Support Team

Since the 5update + hotfix , I’ve huge problems flying without CTD. In my case, I have a modest video card, NVIDIA GTX 1060 3Gb. I have completely reinstalled the simulator. I have performed tests with very low, medium, etc. graphic settings. Testing WITHOUT third party addons. I suspect that, in my case, the VRAM memory overflow, when I focus on graphics dense areas (cities), causes CTD.

Pathetic standard response, it is almost as if they have cut and paste from the forums rather than doing any investigative work themselves.

If you have to go through all these steps just to enable their software to run, surely they must acknowledge that it is their problem and they must fix it.

I have spend over a £1000 on MSFS (more if the upgrade of my PC is included), and I think it is reasonable to expect software which does not crash after 5 minutes use.

Given the number of people that appear to be in the same situation, this is absolutely not acceptable. Microsoft need to address this issue, firstly by acknowledging the scale of the problem and secondly by issuing a hotfix. They have broken it, they must fix it.

1 Like

Hello, almost that they better say desistala the video game and we finished before.

1 Like

I know and support closed my ticket without being able to follow up.
Microsoft / Asobo, why leave us in the embarrassment and do nothing?

1 Like