Still getting 10FPS eventho with the latest update of the game :)

Usually in main menu I get around 25-30 FPS, and now is back to 10 FPS why?

Intel® Core™ i5-8250U CPU @ 1.60GHz 1.80 GHz 20.0 GB DDR4 Rams (19.9 GB usable) MX150 2GB VRAM 256SSD (Installed the game in)

Could anyone help me?

Is it just sitting and staying at 10 fps in the menu or fluctuating the CPU usage is extremely high have you tried closing any programs in task manager that aren’t being used.

I’m quite amazed the sim is even usuable on those specs.


really ?

I just finished flying the helicopter using RC - Usb Radio…
Low level fligth tour of hometown beaches… Impressing.
Not perfect graphics but eveything is where it belongs ( online everything over 4g phone ) Cars on the roads etc.

2016 i7-7500 16 Gb Ram with “INTEL 620 INTERNAL Graphics” because my Radeon R7 M440 4Gb ( it is a Laptop ) will NOT load.

I have said it before, this software has some serious flaws in it.

And that is why it presents so many dissimilar issues and results.

Help ? I guess not. Hundreds of tricks and tips… to no avail. It is what it is.

But , I love it.


1 Like

I think your CPU is the bottleneck.


Yes really his CPU clock speed is like half the recommended hence the CPU bottleneck.
Though if its the glitch in the sim where it gets stuck on 10 fps and the mainthread goes sky high then maybe his CPU load drops when working correctly.

Yeah CPU is the bottleneck so not really a system issue. Youre just using hardware that is kneecapping any really usage of the sim. Using hardware in the minimum requirements category isnt going to result in a pleasant experience.

It was working all fine, but all of the sudden the main menu is stuck at 10 FPS again, in game I do get the average of 18 FPS :slight_smile:

Your system is below the minimum requirements. But it also has two other problems.
20 Gbytes are probably made up of 4 Gbytes + 16 Gbytes. The motherboard has 2 memory channels. One for each module. The 2 memory channels are only used for the first 8 Gbytes. The next 12 GB are only addressed with one memory channel. The performance is halved in this area.

The MX150 only has 2 Gbytes of VRam. Main memory is probably also used.
Windows needs its own memory and this is used from the lower, faster area. This leaves mainly slow memory for the program.


Yup but I could actually run the game average of 18 FPS in flight :smiley:

it’s an older issue since 1.13… and there are some threads and posts for it…

one of the older Example:

I noticed this in older release too, then it was gone some time… my assumption was that it had something to do with the marketplace. You can go to the world map and have again “normal fps” , or ?

Yeah was having that issue before the last update but wouldn’t always happen and most times you could go to the world map screen and it would fix it then go back to the menu. Did have a few times that nothing would sort it, but a restart of the sim.

1 Like

Have you tried going into Task Manager and changing the priority of FS2020 to High? For my system this increases fps 10-12 fps? Maybe you have some heavy stuff being processed by Win10, which takes priority over FS2020. Setting to High makes your system pay attendion to FS needs first.

It might be worth changing the powerplan on your pc to high performance mode this will also speed things up a little. On the gpu driver update before last nvidia control panel reset to default setting

it is on high performance always. it just goes off sometimes then comes back another time, is this the server problem or?

yup i did, but the problem of the 10fps is going off then coming back another time which is annoying

tried it, didnt really worked out

nope, sometimes the 10fps just comes and goes everytime which is quite annoying

1 Like

you cant blame the game in thsi case, its your really low specs, and it wont get better.
the more they add the more power yo need to run it properly.

1 Like

Yeah this happens to me too, all I have is the WT CJ4 installed and it’s happened without mods too, just randomly game stops using GPU properly. GPU usage is sitting around only 25%, CPU usage looks ok.

I had to set up 3 different flights with different planes before I could takeoff without encountering game breaking bugs, now on approach I get this 10FPS. Pretty done with this sim tbh, it’s barely passable as a beta release. Gonna have to go back to X-Plane.

btw i have video in youtube that could proof i am actually running the game quite well :slight_smile: