[STILL LOW FPS] i9 12900k and RTX 3090 strix 32 Giga RAM ddr5 6000MHz

Hi,

I thought I was safe with this build but after having set everything to ULTRA, I’m stuck at 20 fps with GPU limitation when flying the FBW A320. Which settings can I lower a bit and get some fps improvement without degrading too much the graphics? Also my resolution 5120x13651 (Odyssey Neo G9) and my render scaling is 100.

Thanks for your help

You have to be completely missing a driver for something, everything looks good in system properties, no yellow triangle things?

Assuming you mean 5120x1440 that’s just over 7million pixels

I have a 9900k and a 3060 with triple monitor for 5760x1080 for just over 6million and do better than 20FPS

2 Likes

I’m not savvy enough to suggest what might be wrong, but your system is much more capable than what you are seeing. I run a pretty steady 30fps (limited by me) with a 9900k/2080ti at 5120x1440.

1 Like

I have pretty similar setup, 3090, 12900k, running a 4k panel.

You won’t be able to ultra this with a 3090 and get reasonable frames. Assume ultra is for the future, or if you are running at 720p.

I recommend looking at Hardware unboxed video on the settings to see which impact the most, top of my head, clouds have a huge impact (I run on med I think with a 3090), turn glass cockpit refresh down to low.

I can take a look at my settings later and report back, I average around 60-70 with my custom settings, mixture of med to high, few things on ultra.

1 Like

I guess you are CPU bound. Reducing LOD should help. See below post. Should give you some hints.

I reach 60 fps with my rig. My specs Win11 Pro latest build 64Bit, 12700K 3.60GHz (UV -80mV), MB: ROG STRIX Z690-I GAMING WIFI, GPU: RTX 3080 (UV 806mV, 1830 MHz) , 32 GB DDR5 RAM (5600 MHz), Custom water cooling of CPU and GPU, Resolution: 5120x1440, Samsung G9, HAGS on, VBS on

1 Like

Thanks I’ll be happy to try your settings since we have the same build! :slightly_smiling_face:

1 Like

I’ll read the post thanks! :slightly_smiling_face:

1 Like

Here are a few articles and vids to give you some ideas.
https://www.flightsimulator.blog/2021/11/18/best-graphics-settings-guide/
https://www.flightsimulator.blog/2022/01/18/performance-boost-tricks/

4 Likes

Your Rendering setting at 100 is too high. Try 60-80.

2 Likes



1 Like

Thank you so much! :raised_hands:

12900K/3080/32@5600 here and I have locked it down to 60fps with everything at ultra, 200 LOD and 100 render into 3 screens, 1 at 1440, a touchscreen and an old monitor at 1080. I have my own problem here with cooling, but otherwise, there seems horsepower to spare.

5900x/3090/64x3000 and I used the exact settings from the screenshots above. I’m still getting frame rates no higher than 40fps and 25-30 fps in heavy maneuvering or going through clouds. My GPU and CPU are never maxed out. Usually the GPU is only sitting between 30-50% utilization and looking across the cores of the CPU it looks like they never exceed 60-80%. I wouldn’t normally be upset with 40fps because it is ok and looks beautiful, but it bothers me greatly to have a beast of a GPU and it be underutilized. I’ve got everything water cooled with way too many fans/radiators (heavy load on GPU and CPU max out the Core temperatures at 51-55C) so I know I’m not being thermally throttled.

Any suggestions for how I can actually use my whole GPU to get better performance?

Look at the vid created by Pilot Pete posted a few posts up.

I watched and followed the steps in the videos. Neither really addressed the issue I’m looking to solve. I can solidly get 30-40fps during normal operations, but it is only using 40-50% of the GPU capacity. I want to know if there is something I can do to take advantage of the other 50-60% of the GPU to achieve better fps or more consistent frame rates (without forcing MSFS to no more than 30fps).

1 Like

Nevermind everyone. I finally downloaded GPU-Z which told me what was limiting my performance. Turns out I was being power and voltage limited (despite power being nowhere near 400W). With MSI Afterburner I was able to increase the voltage and power limits and now I’m getting a solid 50-60fps on Ultra settings. With the increased FPS, when I go into fullscreen mode, I’m now using 80% of the GPU, which I think is good enough. This is what I was hoping for.

1 Like

Thanks for your help I’ll try that

1 Like