Strange controls, steering, banking ALL airplanes and clean install problem

Hello guys.
Got 2 things :frowning:

  1. I am struggling with a strange behaviour of any aircraft in the game. It is suddenly banking left right as in a wind gusts or some turbulences but in total calm conditions. No autopilot, No wind layer, Clear sky. I did run out of ideas how to solve it or find the cause. I would say it is not a problem from the beggining… Maybe I made a mistake in a setup or bindings. Worst situation is with twin smaller engines… Baron 58, KingAir 350. Its flyable in cessna 152 but it has this problem too.

I just slightly pull a stick backward at rotation speed and it immediately bank left right and so on…
Every takeoff, any plane, any assist setup…

I tried to solve it up with deadzones, sensitivities but same problem is here when the game is started without a joystick connected. Only a keyboard and mouse.
My setup is Saitek X52, Logitech Pro flight pedals.

One thing I did is opentrack and smoothtrack installed.

OK, I messed up it somehow I said. Yes, I can delete my custom control profiles, but this problem is still there when DEFAULT controls are choosen.

  1. Clean install from a scratch. I wanted to make a clean install. Realized that is not possible to uninstall MICROSOFT flight simulator on MICROSOFT windows smart and comfortable way. So based on recommendations uninstalled app, manually removed packages downloaded 140gb again and this “smart” app remembers all its settings. I am mad about it.

I don’t expect realism, I don’t expect a professional sim, I just want to play a basic default (deluxe) version of this game where it is OK to takeoff even on a keyboard.

Thank you for all your attempts to help
Honza

problem:

The only thing I can think of is, have you made sure that the bindings are correct on your analog controls?

I had a similar problem. It turned out the drivers for my controllers had become corrupted. Try uninstalling and reinstalling your drivers, which fixed it for me.

Thank you. I did. I don’t know how to be sure there is no duplicity. I presume that I have to check the basic axes right? Roll, Pitch, Yaw… or it might be a problem if there is for example COM1 button assigned on both devices?

BTW: do you have any tip how to “smart” check these duplicities?

THX

Not sure, sorry. The only other thing I could suggest is that you say it’s not a problem since the beginning, so do you mean that everything was working correctly at first?
If so, at what point did it go wrong? Did you make any changes to your system between it working and it not working? If so, try rolling those back - even if they would seem to be completely unrelated.
Good luck! Hope you can solve it…

I wish I can tell for sure. My first flight were with tutors on Cessna 152 and then come custom flights with 172SP. If there were a problem it looked like as gusting wind… I noticed this problem later on in larger aircrafts Baron G58 and King Air…

The only “toxic” event might be a headtracking via opentrack / smoothtack. Removed…

Mildly unrelated, but you have your spoilers extended on the jet.

Are you sure you fully understand your control bindings?

I think its OK, but I would do it everything from a scratch. BUT this problem its still there while I am

  • in default controls profiles
  • with joysticks and pedals unplugged (MSFS started only mouse and keyboard)

Thank you Pieter :slight_smile: I am only sure I already don’t understand anything now.
Anyway… have you seen a BaronG58 video? Same behaviour in C172… As soon as we will find a solution how to takeoff a cessna without immediately bank to the left / right,
we can discuss a spoilers… :slight_smile: Trust me that right takeoff procedure is not a solution…

That is the beginning of wisdom. :+1:

All my user presets deleted. All reset to DEFAULT. No keybindings.

Have you calibrated/recalibrated your controllers? (I’d suggest not using the Windows calibration, which didn’t work properly for me, but finding a calibration app on-line for your specific brand.)

Is there anything in your Community folder? Obviously, empty that if so.

However, it sounds like a clean reinstall might be your best bet, but you say you also had problems there. Did you follow the default installation, or did you ask it to install anything in a custom folder? If the latter, did you also delete those files before reinstalling? I would try it again, and restart your pc and then double check that all related files (and anything else MSF related) are actually gone before reinstalling.

No I agree :slight_smile: Your plane does behave erratically. Did you have a look at the default profile of your joystick? There might also be an error in there like a double binding or wrong axis.

The X52/X56 joysticks were notorious during the alpha when there were a lot of weird behaviors from those sticks. Did you try to reset/update your joystick driver? When you look at the sensitivity settings, do you see the axes moving?

Thank you mate. I have X52 calibrated only via Windows calibration. Do you think that can cause problems only in MSFS app? DCS and Xplane is working properly… I was trying to download X52 drivers for WIN10 but there is only 32bit setup version online. I am waiting for a Logitech support response, if they have 64bit one. (if you guys someone have 64bit drivers, I would appreciate it).

Clean install… hmm - that’s what I thought.
I did choose alternative drive F:/games/msfs

  1. Uninstalled App as instructed
  2. Removed as much as possible. Beside the package folder (Comunity and Official), there were three folders in root dir on drive F:

I deleted WpSystem but Program Files and WindowsApps were unable to delete because of non TrustedInstaller problem.

135216227_423364412433872_8397283284177213062_n

I went crazy at this point and reinstalled it… (but it remembered my User Profiles)

My Hotas X didn’t work properly until I calibrated it with a custom app.

It’s probably something in the settings/bindings that is causing this.

Also try solving the drivers problem first as that might well do it.

Otherwise, I think a proper clean re-install will fix your issue. Try right clicking on the files that won’t delete, select properties-security-advanced and then change the owner of the file from TrustedInstaller, then delete. Everything needs to be gone first otherwise there isn’t much point in reinstalling.

OK, thank you for all your effort.

I found a proper Saitek X52 drivers and app.
I will try later on.

If this wont help, I will try a clean install, when calmed down.

Is this the HOTAS custom app you are talking about?

No, it had a simpler interface than that. But anything that’s specifically for your controller should work.

hmm… this offical one has no calibration tool… only reffers to windows calibration

It was unofficial.