Stuck at asobo-flight-tutorials-powersettings-0.1.8.fspackage (STUCK AT 1% for HOURS)

I have a big problem since today’s update. Because of a problem on my pc, I had to reinstall the game, but it now hangs at the step mentioned in the title of the topic.

If someone has a solution, I’m interested.

I recommend to quit the process and start the update/installation again.

I will try this.

1 Like

I have tried and nothing helps. I still have the same problem.

1 Like

TBH I’m at the stage where I am going to quit the process and just go back to the stability of XP11.

1 Like

Sorry to hear that.

Download netlimiter and and set speep to 500

I finally found the solution, connected to my VPN and chose New York. Since then it works pretty well and I have a good download speed.
PS: I am in Western Europe

1 Like


Thanks for your help

How and where is the option ?

1 Like

Use CyberGhost VPN or another VPN supplier. Install it on your pc and voila

Thank that The solution

Dont have a VPN. Can i still do something ?

My solution did not work in the end.
Yet there I have just tested everything, I even reinstalled windows.

Try running a line direct from modem not though router. i also changed my adapter settings, speed and duplex to 100 mbps Half Duplex. It got me out of the looping and stuck downloads. I hope this helps you because I am very frustrated at having to go through all this just to update a program. I can imagine everyone is.

I also have this error. Incredibly frustrating!! I can’t move past 1%. Have tried restarting, no difference.

Has anybody found a fix yet? I can only use WiFi.

In 15+ years of gaming I have not had to resort to running physical cables to simply play a game.

Good for you guys you had 1%. Mine always got stuck at 0% since SU5. Tried millions of suggested solutions for more than a week!!

My solution? (and hopefully it will work) - Right now I am painfully waiting for a slooow download. I am on Steam version, so I installed the game in a friend’s PC with my steam account (with their slow internet) and it went past that problematic point. Nevermind slow, as long as it is moving forward. At this pace i guess this would take another 12-24 hours to complete. So after it installs on that PC, I would just copy the Packages folder into my sim PC. Hopefully it will work.

This problem has been plaguing lots of users and I do not know if there will ever be a universal fix or solution that works :frowning: Very frustrating.

Deafening silence from Microsoft here - we are paying for a non functional game

Same problem here. I refuse to believe it’s location or speed related. What sketchy problems, totally msft panache

Same problem here. I’m stuck on asobo-flight-tutorials-newbasic-0.1.8.fspackage (Steam edition).
3rd attempt since yesterday and not able to install MSFS

After several attempts during weeekend and today, trying different solutions (different disks, admin rights, VPN) still staying stuck in same unpacking. (Steam version)